summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-01 04:53:48 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-01 04:53:48 +0000
commitc250723bfb01d25e95127bcd70df04632b93d5b6 (patch)
tree013f1212f69e5470638512f1c30944e3678975be /dev-java
parentCheck for existence of CC variable, since some old gcc versions didn't supply... (diff)
downloadhistorical-c250723bfb01d25e95127bcd70df04632b93d5b6.tar.gz
historical-c250723bfb01d25e95127bcd70df04632b93d5b6.tar.bz2
historical-c250723bfb01d25e95127bcd70df04632b93d5b6.zip
Clean ups + bug fixes.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-lang/ChangeLog10
-rw-r--r--dev-java/commons-lang/Manifest8
-rw-r--r--dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild24
-rw-r--r--dev-java/commons-lang/commons-lang-2.0-r1.ebuild40
-rw-r--r--dev-java/commons-lang/commons-lang-2.0.ebuild4
-rw-r--r--dev-java/commons-lang/files/digest-commons-lang-1.0.1-r11
-rw-r--r--dev-java/commons-lang/files/digest-commons-lang-2.0-r11
7 files changed, 55 insertions, 33 deletions
diff --git a/dev-java/commons-lang/ChangeLog b/dev-java/commons-lang/ChangeLog
index 47f222eadac1..f64de70ddf2c 100644
--- a/dev-java/commons-lang/ChangeLog
+++ b/dev-java/commons-lang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-lang
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.10 2003/04/26 05:36:58 strider Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.11 2004/03/01 04:53:48 zx Exp $
+
+*commons-lang-2.0-r1 (29 Feb 2004)
+
+ 29 Feb 2004; Chris Aniszczyk <zx@gentoo.org> commons-lang-1.0.1-r1.ebuild,
+ commons-lang-2.0-r1.ebuild, commons-lang-2.0.ebuild:
+ Some cleanup + can't rely on jakarta-commons eclass anymore.
*commons-lang-1.0.1-r1 (22 Mar 2003)
diff --git a/dev-java/commons-lang/Manifest b/dev-java/commons-lang/Manifest
index c83c908410e4..bab51d48b524 100644
--- a/dev-java/commons-lang/Manifest
+++ b/dev-java/commons-lang/Manifest
@@ -1,6 +1,6 @@
-MD5 0462d336c5bbd72153c881cf8e326064 commons-lang-2.0.ebuild 808
-MD5 6c7d6b29579f06276a7ccc7bb08663e3 ChangeLog 1537
+MD5 a92baa6df5414382ea18e7265440cbb2 commons-lang-2.0.ebuild 802
+MD5 b3b8ac9278b16b5d0d570ace68b283ca ChangeLog 1763
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-MD5 a27f80500aad05cdf2291e4e75fd160d commons-lang-1.0.1-r1.ebuild 821
+MD5 cae04f7158c9115666e0f70ef384add6 commons-lang-2.0-r1.ebuild 1108
MD5 07c97be405d9ddaa1bbf5c24825fbb86 files/digest-commons-lang-2.0 72
-MD5 6d6cffba5fd941a3b59f72bb8a4e6365 files/digest-commons-lang-1.0.1-r1 65
+MD5 07c97be405d9ddaa1bbf5c24825fbb86 files/digest-commons-lang-2.0-r1 72
diff --git a/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild b/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild
deleted file mode 100644
index d353d479dc47..000000000000
--- a/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-1.0.1-r1.ebuild,v 1.3 2003/04/26 05:36:58 strider Exp $
-
-inherit jakarta-commons
-
-S="${WORKDIR}/${PN}-${PV}-src/lang"
-DESCRIPTION="Jakarta components to manipulate core java classes"
-HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
-SRC_URI="mirror://apache/jakarta/commons/lang/source/lang-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- junit? ( >=dev-java/junit-3.7 )"
-RDEPEND=">=virtual/jre-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="x86 ppc sparc"
-IUSE="doc jikes junit"
-
-src_compile() {
- cp LICENSE.txt ../LICENSE
- jakarta-commons_src_compile myconf make
- use doc && jakarta-commons_src_compile makedoc
-}
diff --git a/dev-java/commons-lang/commons-lang-2.0-r1.ebuild b/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
new file mode 100644
index 000000000000..8669eceeec94
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0-r1.ebuild,v 1.1 2004/03/01 04:53:48 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Jakarta components to manipulate core java classes"
+HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
+SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ junit? ( >=dev-java/junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc jikes junit"
+
+S="${WORKDIR}/${PN}-${PV}-src"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ echo "junit.jar=`java-config -p junit`" >> build.properties
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+ ant ${antflags}
+}
+
+src_install() {
+ mv dist/commons-lang-2.0.jar dist/${PN}.jar
+ java-pkg_dojar dist/*.jar
+ dohtml *.html
+ use doc && dohtml -r dist/docs/*
+}
diff --git a/dev-java/commons-lang/commons-lang-2.0.ebuild b/dev-java/commons-lang/commons-lang-2.0.ebuild
index 5a23468614bc..81638efc3652 100644
--- a/dev-java/commons-lang/commons-lang-2.0.ebuild
+++ b/dev-java/commons-lang/commons-lang-2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0.ebuild,v 1.1 2003/10/18 18:04:47 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-2.0.ebuild,v 1.2 2004/03/01 04:53:48 zx Exp $
inherit jakarta-commons
diff --git a/dev-java/commons-lang/files/digest-commons-lang-1.0.1-r1 b/dev-java/commons-lang/files/digest-commons-lang-1.0.1-r1
deleted file mode 100644
index 944714070d4b..000000000000
--- a/dev-java/commons-lang/files/digest-commons-lang-1.0.1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7217632e6a7f18770734128baba273c2 lang-1.0.1-src.tar.gz 96843
diff --git a/dev-java/commons-lang/files/digest-commons-lang-2.0-r1 b/dev-java/commons-lang/files/digest-commons-lang-2.0-r1
new file mode 100644
index 000000000000..372fd0253970
--- /dev/null
+++ b/dev-java/commons-lang/files/digest-commons-lang-2.0-r1
@@ -0,0 +1 @@
+MD5 200a40d46fe6a60af76acf973298b8fe commons-lang-2.0-src.tar.gz 440989