summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-30 19:46:10 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-30 19:46:10 +0000
commit9b26becf4bc83884e022c31be052c0e9e06c0a70 (patch)
treef72b1a2874dfa2bf4632467e3b3e70333710d76b /dev-java
parentStable on sparc. (diff)
downloadhistorical-9b26becf4bc83884e022c31be052c0e9e06c0a70.tar.gz
historical-9b26becf4bc83884e022c31be052c0e9e06c0a70.tar.bz2
historical-9b26becf4bc83884e022c31be052c0e9e06c0a70.zip
inital import, ebuild contributed by Dan <dan@intuitivelyobvious.net>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/oscache/ChangeLog10
-rw-r--r--dev-java/oscache/Manifest14
-rw-r--r--dev-java/oscache/files/digest-oscache-2.0.21
-rw-r--r--dev-java/oscache/metadata.xml5
-rw-r--r--dev-java/oscache/oscache-2.0.2.ebuild70
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-java/oscache/ChangeLog b/dev-java/oscache/ChangeLog
new file mode 100644
index 000000000000..136bc8770391
--- /dev/null
+++ b/dev-java/oscache/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/oscache
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/ChangeLog,v 1.1 2004/10/30 19:46:10 axxo Exp $
+
+*oscache-2.0.2 (30 Oct 2004)
+
+ 30 Oct 2004; Thomas Matthijs <axxo@gentoo.org> +metadata.xml,
+ +oscache-2.0.2.ebuild:
+ inital import, ebuild contributed by Dan <dan@intuitivelyobvious.net>
+
diff --git a/dev-java/oscache/Manifest b/dev-java/oscache/Manifest
new file mode 100644
index 000000000000..f139685c58a0
--- /dev/null
+++ b/dev-java/oscache/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 a97b889f594ed79d7cda2e370a2e8b01 oscache-2.0.2.ebuild 2120
+MD5 c998056cbbf723aa12740a08aefa2a0b ChangeLog 395
+MD5 123cf9440c1d4ac78f2caba1624765f9 metadata.xml 158
+MD5 d52039b83271f4379d0aefff244164aa files/digest-oscache-2.0.2 68
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBg++M/rLF9B432nYRAiIsAJ4925pEydUXPiouZWbJppeAorpemQCeKgRl
+G2wqcONwZD27xzTK3a3cC8o=
+=hjc3
+-----END PGP SIGNATURE-----
diff --git a/dev-java/oscache/files/digest-oscache-2.0.2 b/dev-java/oscache/files/digest-oscache-2.0.2
new file mode 100644
index 000000000000..5b905b4bd986
--- /dev/null
+++ b/dev-java/oscache/files/digest-oscache-2.0.2
@@ -0,0 +1 @@
+MD5 0f724f71a998c8be3bbeb1eb2d1fa783 oscache-2.0.2-full.zip 2533146
diff --git a/dev-java/oscache/metadata.xml b/dev-java/oscache/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/oscache/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/oscache/oscache-2.0.2.ebuild b/dev-java/oscache/oscache-2.0.2.ebuild
new file mode 100644
index 000000000000..aac523b29223
--- /dev/null
+++ b/dev-java/oscache/oscache-2.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/oscache-2.0.2.ebuild,v 1.1 2004/10/30 19:46:10 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="OSCache is a widely used, high performance J2EE caching framework."
+SRC_URI="https://oscache.dev.java.net/files/documents/629/2653/${P}-full.zip"
+HOMEPAGE="http://www.opensymphony.com/oscache/"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=virtual/jre-1.3
+ dev-java/commons-collections
+ dev-java/commons-logging
+ =dev-java/servletapi-2.3*
+ dev-java/jms
+ dev-java/jgroups"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.3"
+IUSE="doc jikes"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ rm *.jar
+}
+
+src_compile() {
+ javac_cmd="javac"
+ use jikes && javac_cmd="jikes -bootclasspath ${JAVA_HOME}/jre/lib/rt.jar"
+
+ build_dir=${S}/build
+ local classpath="-classpath $(java-config -p commons-logging,commons-collections,servletapi-2.3,jms,jgroups):${build_dir}:."
+ mkdir ${build_dir}
+
+ einfo "Building core..."
+ cd ${S}/src/core/java
+ ${javac_cmd} ${classpath} -nowarn -d ${build_dir} `find -name "*.java"`
+
+ einfo "Building cluster support plugin..."
+ cd ${S}/src/plugins/clustersupport/java
+ find -name "*.java" -exec sed -i -e "s/org.javagroups/org.jgroups/g" {} \;
+ ${javac_cmd} ${classpath} -nowarn -d ${build_dir} `find -name "*.java"`
+
+ einfo "Building disk persistence plugin..."
+ cd ${S}/src/plugins/diskpersistence/java
+ ${javac_cmd} ${classpath} -nowarn -d ${build_dir} `find -name "*.java"` || die "compile failed"
+
+ if use doc ; then
+ einfo "Building documentation..."
+ mkdir ${S}/javadoc
+ cd ${build_dir}
+ local sourcepath="${S}/src/core/java:${S}/src/plugins/diskpersistence/java:${S}/src/plugins/clustersupport/java"
+ javadoc ${classpath} -sourcepath ${sourcepath} -d ${S}/javadoc \
+ $(find com/opensymphony/oscache -type d | tr '/' '.') \
+ || die "failed to create javadoc"
+ fi
+
+ einfo "Building JAR..."
+ cd ${S}
+ jar cf ${PN}.jar -C build .
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ dodoc readme.txt
+ use doc && java-pkg_dohtml -r javadoc
+}