summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-22 12:24:43 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-22 12:24:43 +0000
commit68854e563f0eecb7675e9eb76064bb1fdcd06171 (patch)
treec8c065ebdbe317ae10837d174ae16f00b7496e73 /dev-java
parentFix for jakarta-commons_src_install() dojar target. (diff)
downloadhistorical-68854e563f0eecb7675e9eb76064bb1fdcd06171.tar.gz
historical-68854e563f0eecb7675e9eb76064bb1fdcd06171.tar.bz2
historical-68854e563f0eecb7675e9eb76064bb1fdcd06171.zip
Moved to using jakarta-commons eclass; 'doc' USE flag. Keywords ~x86.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-logging/ChangeLog8
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.2-r2.ebuild26
-rw-r--r--dev-java/commons-logging/files/digest-commons-logging-1.0.2-r21
3 files changed, 34 insertions, 1 deletions
diff --git a/dev-java/commons-logging/ChangeLog b/dev-java/commons-logging/ChangeLog
index 5771b416de89..c951dc8b3895 100644
--- a/dev-java/commons-logging/ChangeLog
+++ b/dev-java/commons-logging/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-logging
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/ChangeLog,v 1.6 2003/02/12 05:51:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/ChangeLog,v 1.7 2003/03/22 12:24:43 absinthe Exp $
+
+*commons-logging-1.0.2-r2 (22 Mar 2003)
+
+ 22 Mar 2003; Dylan Carlson <absinthe@gentoo.org>
+ commons-logging-1.0.2-r2.ebuild:
+ Changed to add 'doc' USE flag and jakarta-commons eclass.
*commons-logging-1.0.2-r1 (06 Nov 2002)
diff --git a/dev-java/commons-logging/commons-logging-1.0.2-r2.ebuild b/dev-java/commons-logging/commons-logging-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..abb40f4a5854
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.0.2-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.2-r2.ebuild,v 1.1 2003/03/22 12:24:43 absinthe Exp $
+
+inherit jakarta-commons
+
+S="${WORKDIR}/${P}-src/logging"
+DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries."
+HOMEPAGE="http://jakarta.apache.org/commons/logging.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/log4j-1.2.5
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ [ -f LICENSE.txt ] && cp LICENSE.txt ../LICENSE
+ jakarta-commons_src_compile myconf make
+ jakarta-commons_src_install dojar
+ use doc && jakarta-commons_src_compile makedoc
+ use doc && jakarta-commons_src_install html
+}
diff --git a/dev-java/commons-logging/files/digest-commons-logging-1.0.2-r2 b/dev-java/commons-logging/files/digest-commons-logging-1.0.2-r2
new file mode 100644
index 000000000000..608ab555e60d
--- /dev/null
+++ b/dev-java/commons-logging/files/digest-commons-logging-1.0.2-r2
@@ -0,0 +1 @@
+MD5 78bfaac25906a54b925bcc285872c9c9 commons-logging-1.0.2-src.tar.gz 33550