summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-09-29 15:56:25 +0000
committerVlastimil Babka <caster@gentoo.org>2009-09-29 15:56:25 +0000
commit35c7705aa9fc8dbfe0fa2f3dbbb7ae97123772c5 (patch)
treef0c3c8cc8d819c46833b0b2b637cab2359c79ea7 /dev-java
parentSuggest usage of gpointing-device-settings instead of this package. (diff)
downloadhistorical-35c7705aa9fc8dbfe0fa2f3dbbb7ae97123772c5.tar.gz
historical-35c7705aa9fc8dbfe0fa2f3dbbb7ae97123772c5.tar.bz2
historical-35c7705aa9fc8dbfe0fa2f3dbbb7ae97123772c5.zip
Version bump.
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jdk/ChangeLog7
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.21.ebuild139
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.21.ebuild114
4 files changed, 266 insertions, 2 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 916dc1e55dd2..f63c22f93c28 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.268 2009/08/18 10:07:54 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.269 2009/09/29 15:51:45 caster Exp $
+
+*sun-jdk-1.5.0.21 (29 Sep 2009)
+
+ 29 Sep 2009; Vlastimil Babka <caster@gentoo.org> +sun-jdk-1.5.0.21.ebuild:
+ Version bump.
*sun-jdk-1.6.0.16 (18 Aug 2009)
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.21.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.21.ebuild
new file mode 100644
index 000000000000..28d5abc704d0
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.21.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.21.ebuild,v 1.1 2009/09/29 15:51:45 caster Exp $
+
+inherit versionator java-vm-2 eutils pax-utils
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
+
+X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's Java SE Development Kit"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa doc examples jce nsplugin odbc"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so opt/${P}/jre/lib/i386/libdeploy.so"
+QA_DT_HASH="opt/${P}/.*"
+
+DEPEND="jce? ( =dev-java/sun-jce-bin-1.5.0* )"
+RDEPEND="sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ doc? ( =dev-java/java-sdk-docs-1.5.0* )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+
+S="${WORKDIR}/jdk$(replace_version_separator 3 _)"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+src_unpack() {
+ sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This needs to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"{,/jre}/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+ dodoc COPYRIGHT README.html || die
+ dohtml README.html || die
+
+ cp -pP src.zip "${D}/opt/${P}/" || die
+
+ if use examples; then
+ cp -pPR demo "${D}/opt/${P}/" || die
+ cp -pPR sample "${D}/opt/${P}/" || die
+ fi
+
+ if use jce; then
+ cd "${D}"/opt/${P}/jre/lib/security || die
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv "${D}"/opt/${P}/jre/lib/security/US_export_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ mv "${D}"/opt/${P}/jre/lib/security/local_policy.jar \
+ "${D}"/opt/${P}/jre/lib/security/strong-jce || die
+ local jcedir="/opt/sun-jce-bin-1.5.0/jre/lib/security/unlimited-jce/"
+ dosym ${jcedir}/US_export_policy.jar \
+ /opt/${P}/jre/lib/security/ || die
+ dosym ${jcedir}/local_policy.jar \
+ /opt/${P}/jre/lib/security/ || die
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.system.lock
+ touch "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ chmod 644 "${D}"/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # install control panel for Gnome/KDE
+ if [[ -f ${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop ]]; then
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+ -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+ "${D}"/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ "${T}"/sun_java-${SLOT}.desktop \
+ || die "Failed to sed .desktop file"
+
+ domenu "${T}"/sun_java-${SLOT}.desktop
+ fi
+
+ # bug #56444
+ insinto /opt/${P}/jre/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+ elog ""
+}
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 545bbc4dc5cd..1a6ff4ce8a25 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.158 2009/08/18 10:12:17 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.159 2009/09/29 15:56:25 caster Exp $
+
+*sun-jre-bin-1.5.0.21 (29 Sep 2009)
+
+ 29 Sep 2009; Vlastimil Babka <caster@gentoo.org>
+ +sun-jre-bin-1.5.0.21.ebuild:
+ Version bump.
*sun-jre-bin-1.6.0.16 (18 Aug 2009)
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.21.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.21.ebuild
new file mode 100644
index 000000000000..b158ce943c06
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.21.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.21.ebuild,v 1.1 2009/09/29 15:56:25 caster Exp $
+
+inherit pax-utils versionator eutils java-vm-2
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
+
+X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's Java SE Runtime Environment"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa nsplugin odbc"
+
+RDEPEND="sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
+DEPEND=""
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash "${FILESDIR}/construct.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
+
+ # see bug #207282
+ if use x86; then
+ einfo "Creating the Class Data Sharing archives"
+ "${S}"/bin/java -client -Xshare:dump || die
+ fi
+}
+
+src_install() {
+ local dirs="bin lib man"
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ # bug #56444
+ insinto /opt/${P}/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties \
+ fontconfig.properties || die
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}