summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-04-13 11:05:54 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-04-13 11:05:54 +0000
commit91c3b47df827d5fd701f25c89b0e8624d52914af (patch)
tree6ed4b1889069c2d0703ab2d69303f14060e9513a /dev-java/saxon/saxon-8.4b-r3.ebuild
parentApply the patch in 2.8.2, thanks to Charles Clément <caratorn at gmail dot c... (diff)
downloadhistorical-91c3b47df827d5fd701f25c89b0e8624d52914af.tar.gz
historical-91c3b47df827d5fd701f25c89b0e8624d52914af.tar.bz2
historical-91c3b47df827d5fd701f25c89b0e8624d52914af.zip
Add launcher script named saxon8 and add Main-Class attribute to saxon8.jar. Fixes bug #174419.
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'dev-java/saxon/saxon-8.4b-r3.ebuild')
-rw-r--r--dev-java/saxon/saxon-8.4b-r3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-java/saxon/saxon-8.4b-r3.ebuild b/dev-java/saxon/saxon-8.4b-r3.ebuild
new file mode 100644
index 000000000000..275c403aec17
--- /dev/null
+++ b/dev-java/saxon/saxon-8.4b-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/saxon/saxon-8.4b-r3.ebuild,v 1.1 2007/04/13 11:05:54 betelgeuse Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 eutils java-ant-2
+
+DESCRIPTION="The SAXON package is a collection of tools for processing XML documents: XSLT processor, XSL library, parser."
+MyPV=${PV%b}
+SRC_URI="mirror://sourceforge/saxon/saxonb${MyPV/./-}.zip"
+HOMEPAGE="http://saxon.sourceforge.net/"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/xom
+ ~dev-java/jdom-1.0
+ =dev-java/xml-commons-external-1.3*"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+
+ unpack ./source.zip
+ mkdir src
+ mv net src
+
+ epatch ${FILESDIR}/${P}-jikes.patch
+
+ cp "${FILESDIR}/build-${PV}.xml" build.xml -i || die
+
+ rm -v *.jar || die
+ mkdir lib && cd lib
+ java-pkg_jar-from jdom-1.0
+ java-pkg_jar-from xom
+ # Is not needed with 1.5 but gets pulled in by deps any way
+ # without this emerging with sun-jdk-1.4 fails with
+ # JAVA_PKG_STRICT
+ java-pkg_jar-from xml-commons-external-1.3
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+
+ # the jar is named saxon8 and and helps if new slots come along
+ java-pkg_dolauncher ${PN}8 --main net.sf.saxon.Transform
+ if use doc; then
+ java-pkg_dojavadoc dist/doc/api doc/*
+ java-pkg_dohtml doc/*
+ fi
+ use source && java-pkg_dosrc src/*
+}