summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-18 23:54:47 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-18 23:54:47 +0000
commitbc6f3261b23c88bd9f61d1820b5582f2d81c39d2 (patch)
tree6bc7ca3383f0ce18a41dbe8b6f037295a9288769 /dev-java/jswat
parentbalsa-2.0.1 temporally masked (diff)
downloadhistorical-bc6f3261b23c88bd9f61d1820b5582f2d81c39d2.tar.gz
historical-bc6f3261b23c88bd9f61d1820b5582f2d81c39d2.tar.bz2
historical-bc6f3261b23c88bd9f61d1820b5582f2d81c39d2.zip
new package. Fixes #3846
Diffstat (limited to 'dev-java/jswat')
-rw-r--r--dev-java/jswat/ChangeLog13
-rw-r--r--dev-java/jswat/files/digest-jswat-2.61
-rw-r--r--dev-java/jswat/jswat-2.6.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/jswat/ChangeLog b/dev-java/jswat/ChangeLog
new file mode 100644
index 000000000000..fdcee63cefc6
--- /dev/null
+++ b/dev-java/jswat/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-java/jswat
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jswat/ChangeLog,v 1.1 2002/06/18 23:54:46 rphillips Exp $
+
+*jswat-2.6 (18 Jun 2002)
+
+ 18 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-java/jswat/files/digest-jswat-2.6 b/dev-java/jswat/files/digest-jswat-2.6
new file mode 100644
index 000000000000..e074bb253dd0
--- /dev/null
+++ b/dev-java/jswat/files/digest-jswat-2.6
@@ -0,0 +1 @@
+MD5 fc718cc6f6d7a654cdde484814ff1d26 jswat2-src-20020617.tar.gz 1193935
diff --git a/dev-java/jswat/jswat-2.6.ebuild b/dev-java/jswat/jswat-2.6.ebuild
new file mode 100644
index 000000000000..24d3f5b8e631
--- /dev/null
+++ b/dev-java/jswat/jswat-2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Maik Schreiber <bZ@iq-computing.de>
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jswat/jswat-2.6.ebuild,v 1.1 2002/06/18 23:54:47 rphillips Exp $
+
+S="${WORKDIR}/jswat"
+DESCRIPTION="Extensible graphical Java debugger"
+HOMEPAGE="http://www.bluemarsh.com/java/jswat"
+LICENSE="GPL-2"
+DEPEND=">=dev-java/ant-1.4.1"
+RDEPEND=">=virtual/jdk-1.4"
+SRC_URI="http://www.bluemarsh.com/binaries/java/jswat/jswat2-src-20020617.tar.gz"
+
+src_compile() {
+ cd build
+ # we cannot use jikes here because we would get
+ # a java.lang.VerifyError from the ClassLoader (why?)
+ ant || die
+}
+
+src_install () {
+ # install it as new CLASSPATH package because other programs
+ # (like app-editors/jedit) can make use of it
+ cd dist/jswat
+ dojar jswat2.jar parser.jar
+
+ cd ../..
+
+ echo -e >jswat '#!/bin/sh\njava -classpath /usr/share/jswat/lib/jswat2.jar:/opt/sun-jdk-1.4.0/lib/tools.jar com.bluemarsh.jswat.Main $@'
+ chmod 755 jswat
+ dobin jswat
+
+ dodoc AUTHORS.txt BUGS.txt HISTORY.txt LICENSE.txt OLD_HISTORY.txt TODO.txt
+ dohtml README.html
+ dohtml -r docs
+}