summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-09-11 14:15:55 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-09-11 14:15:55 +0000
commitcd0d59191228ec2ed6adadcd14589c182791f147 (patch)
treed76c707f3beb2caadd0b173804206bf8750994ad /dev-java/jldap
parentInitial import - dependency of dev-java/jldap. (diff)
downloadhistorical-cd0d59191228ec2ed6adadcd14589c182791f147.tar.gz
historical-cd0d59191228ec2ed6adadcd14589c182791f147.tar.bz2
historical-cd0d59191228ec2ed6adadcd14589c182791f147.zip
Migrated to new Java build system.
Package-Manager: portage-2.1.1
Diffstat (limited to 'dev-java/jldap')
-rw-r--r--dev-java/jldap/ChangeLog11
-rw-r--r--dev-java/jldap/files/200603-javac.xml.patch24
-rw-r--r--dev-java/jldap/files/digest-jldap-200603003
-rw-r--r--dev-java/jldap/jldap-20060300.ebuild67
4 files changed, 103 insertions, 2 deletions
diff --git a/dev-java/jldap/ChangeLog b/dev-java/jldap/ChangeLog
index 5b96c9be4b3a..a42dd9032e5c 100644
--- a/dev-java/jldap/ChangeLog
+++ b/dev-java/jldap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jldap
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jldap/ChangeLog,v 1.5 2005/12/08 13:07:53 betelgeuse Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jldap/ChangeLog,v 1.6 2006/09/11 14:15:55 nelchael Exp $
+
+*jldap-20060300 (11 Sep 2006)
+
+ 11 Sep 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ -files/200510-javac.xml.patch, +files/200603-javac.xml.patch,
+ -jldap-20051000.ebuild, +jldap-20060300.ebuild:
+ Migrated to new Java build system.
*jldap-20051000 (08 Dec 2005)
diff --git a/dev-java/jldap/files/200603-javac.xml.patch b/dev-java/jldap/files/200603-javac.xml.patch
new file mode 100644
index 000000000000..222e22e8d452
--- /dev/null
+++ b/dev-java/jldap/files/200603-javac.xml.patch
@@ -0,0 +1,24 @@
+--- javac.xml.original 2006-09-11 15:28:53.000000000 +0200
++++ javac.xml 2006-09-11 15:29:07.000000000 +0200
+@@ -66,8 +66,7 @@
+
+ <!-- Take care of optional components -->
+ <fileset dir="${ext}">
+- <include name="commons-httpclient-*.jar"/>
+- <include name="openspml*.jar"/>
++ <include name="*.jar"/>
+ </fileset>
+ </classpath>
+ </javac>
+@@ -102,6 +101,11 @@
+ <pathelement location="external/jsse/lib/jnet.jar"/>
+ <pathelement location="external/jsse/lib/jsse.jar"/>
+ <pathelement location="external/commons-httpclient-2.0-rc2.jar"/>
++
++ <!-- Take care of optional components -->
++ <fileset dir="${ext}">
++ <include name="*.jar"/>
++ </fileset>
+ </classpath>
+ </javac>
+
diff --git a/dev-java/jldap/files/digest-jldap-20060300 b/dev-java/jldap/files/digest-jldap-20060300
new file mode 100644
index 000000000000..5663ba5fd9f1
--- /dev/null
+++ b/dev-java/jldap/files/digest-jldap-20060300
@@ -0,0 +1,3 @@
+MD5 80f438aa8891e70d46000603f8beeb6d jldap-Mar_ndk_2006-gentoo.tar.bz2 384035
+RMD160 71994fea10d5d75d1a09e1f7bb0acbe9f53c120a jldap-Mar_ndk_2006-gentoo.tar.bz2 384035
+SHA256 9725abe4a64eb3197a507be165185f48ad6a2384fae47e763d360edf664e50fc jldap-Mar_ndk_2006-gentoo.tar.bz2 384035
diff --git a/dev-java/jldap/jldap-20060300.ebuild b/dev-java/jldap/jldap-20060300.ebuild
new file mode 100644
index 000000000000..98c8278b7419
--- /dev/null
+++ b/dev-java/jldap/jldap-20060300.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jldap/jldap-20060300.ebuild,v 1.1 2006/09/11 14:15:55 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The LDAP Class Libraries for Java (JLDAP) enable you to write applications to access, manage, update, and search for information stored in directories accessible using LDAPv3."
+HOMEPAGE="http://www.openldap.org/jldap/"
+SRC_URI="mirror://gentoo/jldap-Mar_ndk_2006-gentoo.tar.bz2"
+
+LICENSE="OPENLDAP"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.4
+ =dev-java/commons-httpclient-2.0*
+ dev-java/openspml
+ dev-java/openspml2"
+DEPEND=">=virtual/jdk-1.4
+ ${REDEND}
+ >=dev-java/ant-core-1.5.1"
+
+S="${WORKDIR}/openldap-${PN}"
+
+src_unpack() {
+
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/200603-javac.xml.patch"
+
+}
+
+src_compile() {
+
+ java-ant_bsfix_one "${S}/javac.xml"
+
+ mkdir "${S}/ext"
+ cd "${S}/ext"
+ java-pkg_jar-from commons-httpclient
+ java-pkg_jar-from openspml
+ java-pkg_jar-from openspml2
+
+ cd "${S}"
+ local antflags="release"
+ use doc && antflags="${antflags} doc"
+
+ eant ${antflags}
+
+}
+
+src_install() {
+
+ dodoc README
+ dodoc README.dsml
+
+ java-pkg_dojar lib/ldap.jar
+
+ if use doc; then
+ dohtml *.html
+ dodoc design/*
+ java-pkg_dohtml -r doc/*
+ fi
+
+ use source && java-pkg_dosrc org com
+
+}