summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2004-10-20 09:14:23 +0000
committerDylan Carlson <absinthe@gentoo.org>2004-10-20 09:14:23 +0000
commit91414950012ca00cbd8b462bffb33dd00434eebc (patch)
tree7c777fa5b4882d4b578c23dd271f1452d827801c /dev-java/jcommon
parentKeywords ~amd64. (diff)
downloadhistorical-91414950012ca00cbd8b462bffb33dd00434eebc.tar.gz
historical-91414950012ca00cbd8b462bffb33dd00434eebc.tar.bz2
historical-91414950012ca00cbd8b462bffb33dd00434eebc.zip
Version bump. Added KEYWORDS ~amd64.
Diffstat (limited to 'dev-java/jcommon')
-rw-r--r--dev-java/jcommon/ChangeLog8
-rw-r--r--dev-java/jcommon/files/digest-jcommon-0.9.71
-rw-r--r--dev-java/jcommon/jcommon-0.9.4.ebuild4
-rw-r--r--dev-java/jcommon/jcommon-0.9.7.ebuild32
4 files changed, 42 insertions, 3 deletions
diff --git a/dev-java/jcommon/ChangeLog b/dev-java/jcommon/ChangeLog
index 24085c235e47..766a59aad884 100644
--- a/dev-java/jcommon/ChangeLog
+++ b/dev-java/jcommon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jcommon
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/ChangeLog,v 1.3 2004/10/16 17:20:40 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/ChangeLog,v 1.4 2004/10/20 09:14:23 absinthe Exp $
+
+*jcommon-0.9.7 (20 Oct 2004)
+
+ 20 Oct 2004; Dylan Carlson <absinthe@gentoo.org> jcommon-0.9.4.ebuild,
+ +jcommon-0.9.7.ebuild:
+ Version bump. Added KEYWORDS ~amd64.
16 Oct 2004; Thomas Matthijs <axxo@gentoo.org> jcommon-0.9.4.ebuild:
use java-pkg_dohtml instead of dohtml to also install the package-list in
diff --git a/dev-java/jcommon/files/digest-jcommon-0.9.7 b/dev-java/jcommon/files/digest-jcommon-0.9.7
new file mode 100644
index 000000000000..dc6e68b06e13
--- /dev/null
+++ b/dev-java/jcommon/files/digest-jcommon-0.9.7
@@ -0,0 +1 @@
+MD5 b119cd7e09e23f45a08e908755cfe1f3 jcommon-0.9.7.tar.gz 820330
diff --git a/dev-java/jcommon/jcommon-0.9.4.ebuild b/dev-java/jcommon/jcommon-0.9.4.ebuild
index c605e323fbcf..e5084327c5a3 100644
--- a/dev-java/jcommon/jcommon-0.9.4.ebuild
+++ b/dev-java/jcommon/jcommon-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.4.ebuild,v 1.3 2004/10/16 17:20:40 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.4.ebuild,v 1.4 2004/10/20 09:14:23 absinthe Exp $
inherit java-pkg
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.jfree.org"
SRC_URI="mirror://sourceforge/jfreechart/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
IUSE="doc jikes"
DEPEND=">=virtual/jdk-1.3
dev-java/ant
diff --git a/dev-java/jcommon/jcommon-0.9.7.ebuild b/dev-java/jcommon/jcommon-0.9.7.ebuild
new file mode 100644
index 000000000000..206f40e72107
--- /dev/null
+++ b/dev-java/jcommon/jcommon-0.9.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.7.ebuild,v 1.1 2004/10/20 09:14:23 absinthe Exp $
+
+inherit java-pkg
+
+DESCRIPTION="JCommon is a collection of useful classes used by JFreeChart, JFreeReport and other projects."
+HOMEPAGE="http://www.jfree.org"
+SRC_URI="mirror://sourceforge/jfreechart/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant
+ dev-java/junit
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jdk-1.3"
+
+src_compile() {
+ rm -f junit/*
+ local antflags="compile javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant -f ant/build.xml ${antflags} || die "compile failed"
+}
+
+src_install() {
+ java-pkg_dojar ${P}.jar
+ dodoc README.txt licence-LGPL.txt
+ use doc && java-pkg_dohtml -r javadoc
+}
+