summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-30 19:32:24 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-30 19:32:24 +0000
commitadd8dbd6b5454f673675d3d297f05f51e86d230a (patch)
tree1084d0295efb86aaa527ac3017aad7aa9cf984d1 /dev-java/datavision-bin/datavision-bin-0.8.1.ebuild
parentmove dev-java/datavision dev-java/datavision-bin (diff)
downloadhistorical-add8dbd6b5454f673675d3d297f05f51e86d230a.tar.gz
historical-add8dbd6b5454f673675d3d297f05f51e86d230a.tar.bz2
historical-add8dbd6b5454f673675d3d297f05f51e86d230a.zip
move dev-java/datavision dev-java/datavision-bin
Diffstat (limited to 'dev-java/datavision-bin/datavision-bin-0.8.1.ebuild')
-rw-r--r--dev-java/datavision-bin/datavision-bin-0.8.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/datavision-bin/datavision-bin-0.8.1.ebuild b/dev-java/datavision-bin/datavision-bin-0.8.1.ebuild
new file mode 100644
index 000000000000..3c3203bd3465
--- /dev/null
+++ b/dev-java/datavision-bin/datavision-bin-0.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/datavision-bin/datavision-bin-0.8.1.ebuild,v 1.1 2004/07/30 19:31:35 axxo Exp $
+
+DESCRIPTION="DataVision is an Open Source reporting tool similar to Crystal Reports"
+SRC_URI="mirror:///sourceforge/datavision/${P/-bin}.tar.gz"
+HOMEPAGE="http://datavision.sourceforge.net/"
+
+IUSE="mysql postgres"
+
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="x86 amd64 ~ppc"
+
+DATAVISION_HOME=/opt/datavision
+
+RDEPEND=">=virtual/jdk-1.3 \
+ mysql? ( >=jdbc-mysql-3.0 ) \
+ postgres? ( >=jdbc2-postgresql-7.3 )"
+
+
+src_compile() { :; }
+
+src_install() {
+ dodir ${DATAVISION_HOME}
+ cp -r * ${D}${DATAVISION_HOME}
+}
+
+pkg_postinst() {
+ einfo "CONFIGURATION NOTES"
+ echo " "
+ einfo "Make sure your CLASSPATH variable is updated via java-config(1)"
+ einfo "to use your desired JDBC driver."
+ echo " "
+ einfo "You must then create a database. Run ${DATAVISION_HOME}/datavision.sh"
+ einfo "and fill the connection dialog box with your database details."
+
+ if use mysql; then
+ echo " "
+ echo "MySQL example:"
+ eerror "Driver class name: com.mysql.jdbc.Drive"
+ eerror "Connection: jdbc:mysql://localhost/database"
+ fi
+
+ if use postgres; then
+ echo " "
+ echo "PostgreSQL example:"
+ eerror "Driver class name:org.postgresql.Driver"
+ eerror "Connection: jdbc:postgresql://localhost/database"
+ fi
+ echo " "
+ echo " "
+}