summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-10 13:54:07 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-10 13:54:07 +0000
commit125a48ec128e2147f4185553e457b8e14af9d601 (patch)
tree9fc2105c314d9b5978c5c7d4f16a12d073d81e51 /dev-java/commons-el
parentUpdate Hardened-PHP digests. (diff)
downloadhistorical-125a48ec128e2147f4185553e457b8e14af9d601.tar.gz
historical-125a48ec128e2147f4185553e457b8e14af9d601.tar.bz2
historical-125a48ec128e2147f4185553e457b8e14af9d601.zip
cleanup
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/commons-el')
-rw-r--r--dev-java/commons-el/Manifest12
-rw-r--r--dev-java/commons-el/commons-el-1.0.ebuild20
2 files changed, 21 insertions, 11 deletions
diff --git a/dev-java/commons-el/Manifest b/dev-java/commons-el/Manifest
index 7338fccbd357..7290987a7aef 100644
--- a/dev-java/commons-el/Manifest
+++ b/dev-java/commons-el/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 350fe86ee029a150d8593a170abc0922 commons-el-1.0.ebuild 1611
MD5 55c4e4abeb53c55e4ed5f023298ecacc ChangeLog 1123
-MD5 bb0f501e9435ebc1d45246174a5ac0ec commons-el-1.0.ebuild 1558
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 35c69c54a30e1f87340edb6d13bc529b files/digest-commons-el-1.0 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC0SiV/rLF9B432nYRAmpyAKCTn8nVCHL653iyMeDxTx9pD0MzBACgjEPk
+3CtqWuDdK2BiEgvbpXc1vN0=
+=4FWO
+-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-el/commons-el-1.0.ebuild b/dev-java/commons-el/commons-el-1.0.ebuild
index 158e47c8f7fd..121e0ed37584 100644
--- a/dev-java/commons-el/commons-el-1.0.ebuild
+++ b/dev-java/commons-el/commons-el-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0.ebuild,v 1.11 2005/05/29 15:47:29 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0.ebuild,v 1.12 2005/07/10 13:54:07 axxo Exp $
inherit java-pkg
@@ -11,12 +11,13 @@ LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
IUSE="jikes source"
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/servletapi-2.4"
DEPEND=">=virtual/jdk-1.4
- >=dev-java/ant-1.5
+ >=dev-java/ant-core-1.5
+ ${RDEPEND}
jikes? ( dev-java/jikes )
source? ( app-arch/zip )"
-RDEPEND=">=virtual/jdk-1.4
- >=dev-java/servletapi-2.4"
S=${WORKDIR}/${P}-src
@@ -25,15 +26,14 @@ src_unpack() {
cd ${S}
mv build.properties build.properties.old
- local SAPI="`java-config -p servletapi-2.4`"
- echo "servlet-api.jar=${SAPI/*:/}" >> build.properties
- echo "jsp-api.jar=${SAPI/:*/}" >> build.properties
- echo "junit.jar = `java-config --classpath=junit`" >> build.properties
+ echo "servlet-api.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)" >> build.properties
+ echo "jsp-api.jar=$(java-pkg_getjar servletapi-2.4 jsp-api.jar)" >> build.properties
+ echo "junit.jar = $(java-pkg_getjars junit)" >> build.properties
echo "servletapi.build.notrequired = true" >> build.properties
echo "jspapi.build.notrequired = true" >> build.properties
# Build.xml is broken, fix it
- sed -i "s:../LICENSE:./LICENSE.txt:" build.xml
+ sed -i "s:../LICENSE:./LICENSE.txt:" build.xml || die "sed failed"
}
src_compile() {
@@ -42,7 +42,7 @@ src_compile() {
ant ${antflags} || die "compile problem"
}
-src_install () {
+src_install() {
java-pkg_dojar dist/${PN}.jar || die "Unable to install"
dodoc LICENSE.txt RELEASE-NOTES.txt
dohtml STATUS.html PROPOSAL.html