summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 23:10:19 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 23:10:19 +0000
commite8496d84bdb47dfe292ee9e099484914b917e830 (patch)
tree566e3dd9df2a9dd05ac340ebbcae19951092c1d0 /dev-java/commons-daemon
parentReplace arch with uname -m for Gentoo/FreeBSD compatibility. See bug #141422. (diff)
downloadhistorical-e8496d84bdb47dfe292ee9e099484914b917e830.tar.gz
historical-e8496d84bdb47dfe292ee9e099484914b917e830.tar.bz2
historical-e8496d84bdb47dfe292ee9e099484914b917e830.zip
Migrated to Generation 2.
Package-Manager: portage-2.1.1_pre3-r3
Diffstat (limited to 'dev-java/commons-daemon')
-rw-r--r--dev-java/commons-daemon/ChangeLog8
-rw-r--r--dev-java/commons-daemon/commons-daemon-1.0.1-r1.ebuild59
-rw-r--r--dev-java/commons-daemon/files/digest-commons-daemon-1.0.1-r13
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-java/commons-daemon/ChangeLog b/dev-java/commons-daemon/ChangeLog
index 26cceec0c99a..95c0b38cdd4f 100644
--- a/dev-java/commons-daemon/ChangeLog
+++ b/dev-java/commons-daemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-daemon
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/ChangeLog,v 1.18 2006/07/04 19:00:27 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/ChangeLog,v 1.19 2006/07/22 22:32:40 nelchael Exp $
+
+*commons-daemon-1.0.1-r1 (22 Jul 2006)
+
+ 22 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +commons-daemon-1.0.1-r1.ebuild:
+ Migrated to Generation 2.
04 Jul 2006; Markus Rothe <corsair@gentoo.org>
commons-daemon-1.0.1.ebuild:
diff --git a/dev-java/commons-daemon/commons-daemon-1.0.1-r1.ebuild b/dev-java/commons-daemon/commons-daemon-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..73a35d77c4c5
--- /dev/null
+++ b/dev-java/commons-daemon/commons-daemon-1.0.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-daemon/commons-daemon-1.0.1-r1.ebuild,v 1.1 2006/07/22 22:32:40 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Tools to allow java programs to run as unix daemons"
+SRC_URI="mirror://apache/jakarta/commons/daemon/source/daemon-${PV}.tar.gz"
+HOMEPAGE="http://jakarta.apache.org/commons/daemon/"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples source"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/daemon-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ # Submitted upstream to http://bugs.gentoo.org/show_bug.cgi?id=132563
+ epatch "${FILESDIR}/1.0.1-as-needed.patch"
+
+ cd ${S}/src/native/unix
+ sed -e "s/powerpc/powerpc|powerpc64/g" -i support/apsupport.m4
+ export WANT_AUTOCONF="2.5"
+ autoconf
+}
+
+src_compile() {
+ # compile native stuff
+ cd ${S}/src/native/unix
+ econf || die "configure failed"
+ emake || die "make failed"
+
+ # compile java stuff
+ cd ${S}
+ local antflags="jar"
+ use doc && antflags="${antflags} javadoc"
+ eant ${antflags} || die "compilation problem"
+}
+
+src_install() {
+ dobin src/native/unix/jsvc
+ java-pkg_dojar dist/${PN}.jar || die "Unable to install"
+
+ dodoc README RELEASE-NOTES.txt *.html
+ use doc && java-pkg_dohtml -r dist/docs/*
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -R src/samples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+ use source && java-pkg_dosrc src/java/* src/native/unix/native
+}
diff --git a/dev-java/commons-daemon/files/digest-commons-daemon-1.0.1-r1 b/dev-java/commons-daemon/files/digest-commons-daemon-1.0.1-r1
new file mode 100644
index 000000000000..3e3fd1923d9c
--- /dev/null
+++ b/dev-java/commons-daemon/files/digest-commons-daemon-1.0.1-r1
@@ -0,0 +1,3 @@
+MD5 df3eb5aafa53ca530843a09d40b8a1c0 daemon-1.0.1.tar.gz 301023
+RMD160 b77ffd3dbc40d18d867afd62015ba1aa05bd9c65 daemon-1.0.1.tar.gz 301023
+SHA256 177107b8d99cabdbcda58cec284a2e2ccb5063113cc1fdb1b672754d4652848c daemon-1.0.1.tar.gz 301023