summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-29 21:01:53 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-29 21:01:53 +0000
commit04acfca21e62e113bcda0c364e4f40d766f08b79 (patch)
tree9d47ba6c0d9dfe72ec36f12cbf54a5c143c9f97e /dev-java/blackdown-jdk
parentThe directory needs to exist for older clients to prune the directory. (diff)
downloadhistorical-04acfca21e62e113bcda0c364e4f40d766f08b79.tar.gz
historical-04acfca21e62e113bcda0c364e4f40d766f08b79.tar.bz2
historical-04acfca21e62e113bcda0c364e4f40d766f08b79.zip
Cleaned up plugin instalation, Moved some messages to the eclass, see #22395 for more information
Diffstat (limited to 'dev-java/blackdown-jdk')
-rw-r--r--dev-java/blackdown-jdk/ChangeLog9
-rw-r--r--dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild29
-rw-r--r--dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r8.ebuild37
-rw-r--r--dev-java/blackdown-jdk/blackdown-jdk-1.4.1.ebuild36
-rw-r--r--dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1-r1.ebuild16
-rw-r--r--dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1.ebuild32
6 files changed, 89 insertions, 70 deletions
diff --git a/dev-java/blackdown-jdk/ChangeLog b/dev-java/blackdown-jdk/ChangeLog
index 56ec2f98eee0..296fdb6bcaf0 100644
--- a/dev-java/blackdown-jdk/ChangeLog
+++ b/dev-java/blackdown-jdk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/blackdown-jdk
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/ChangeLog,v 1.56 2004/09/21 13:58:18 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/ChangeLog,v 1.57 2004/09/29 20:59:28 axxo Exp $
+
+ 29 Sep 2004; Thomas Matthijs <axxo@gentoo.org>
+ blackdown-jdk-1.3.1-r10.ebuild, blackdown-jdk-1.3.1-r8.ebuild,
+ blackdown-jdk-1.4.1.ebuild, blackdown-jdk-1.4.2_rc1-r1.ebuild,
+ blackdown-jdk-1.4.2_rc1.ebuild:
+ Cleaned up plugin instalation, Moved some messages to the eclass, see #22395
+ for more information
21 Sep 2004; Thomas Matthijs <axxo@gentoo.org>
-blackdown-jdk-1.3.1-r7.ebuild, blackdown-jdk-1.3.1-r8.ebuild,
diff --git a/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild b/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild
index 01a3b5458f87..d7dc7c2c79f8 100644
--- a/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild
+++ b/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild,v 1.12 2004/07/14 01:44:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r10.ebuild,v 1.13 2004/09/29 20:59:28 axxo Exp $
-inherit java nsplugins gcc
+inherit java gcc
S=${WORKDIR}/j2sdk1.3.1
DESCRIPTION="Blackdown Java Development Kit 1.3.1"
@@ -12,7 +12,7 @@ SRC_URI="ppc? ( http://distro.ibiblio.org/pub/Linux/distributions/yellowdog/soft
LICENSE="sun-bcla-java-vm"
SLOT="1.3"
KEYWORDS="ppc"
-IUSE="doc"
+IUSE="doc mozilla"
DEPEND="virtual/libc
>=dev-java/java-config-0.2.5
@@ -52,15 +52,17 @@ src_install() {
dohtml README.html
# Install ns plugin
- if [ "${ARCH}" == "x86" ] ; then
- PLATFORM="i386"
- elif [ "${ARCH}" == "ppc" ] ; then
- PLATFORM="ppc"
- elif [ "${ARCH}" == "sparc" ] ; then
- PLATFORM="sparc"
- fi
+ if use mozilla; then
+ if [ "${ARCH}" == "x86" ] ; then
+ PLATFORM="i386"
+ elif [ "${ARCH}" == "ppc" ] ; then
+ PLATFORM="ppc"
+ elif [ "${ARCH}" == "sparc" ] ; then
+ PLATFORM="sparc"
+ fi
- inst_plugin /opt/${P}/jre/plugin/${PLATFORM}/mozilla/javaplugin_oji.so
+ install_mozilla_plugin /opt/${P}/jre/plugin/${PLATFORM}/mozilla/libjavaplugin_oji.so
+ fi
find ${D}/opt/${P} -type f -name "*.so" -exec chmod +x \{\} \;
@@ -76,8 +78,3 @@ src_install() {
# install env into /etc/env.d
set_java_env ${FILESDIR}/${VMHANDLE} || die
}
-
-pkg_postinst () {
- # Set as default system VM if none exists
- java_pkg_postinst
-}
diff --git a/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r8.ebuild b/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r8.ebuild
index 28eebc786acd..4a536452eb79 100644
--- a/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r8.ebuild
+++ b/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r8.ebuild,v 1.16 2004/09/21 13:58:18 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.3.1-r8.ebuild,v 1.17 2004/09/29 20:59:28 axxo Exp $
-inherit java nsplugins
+inherit java
S=${WORKDIR}/j2sdk1.3.1
DESCRIPTION="Blackdown Java Development Kit 1.3.1"
@@ -14,7 +14,7 @@ SRC_URI="x86? ( mirror://blackdown.org/JDK-${PV}/i386/FCS/j2sdk-${PV}-FCS-linux-
LICENSE="sun-bcla-java-vm"
SLOT="1.3"
KEYWORDS="x86 ~ppc sparc"
-IUSE="doc"
+IUSE="doc mozilla"
DEPEND="virtual/libc
>=dev-java/java-config-0.2.5
@@ -23,7 +23,7 @@ PROVIDE="virtual/jdk-1.3.1
virtual/jre-1.3.1
virtual/java-scheme-2"
-src_unpack () {
+src_unpack() {
if use ppc || use sparc ; then
tail -n +400 ${DISTDIR}/${A} | tar jxpf -
else
@@ -37,7 +37,7 @@ src_unpack () {
}
-src_install () {
+src_install() {
dodir /opt/${P}
@@ -49,16 +49,17 @@ src_install () {
dodoc COPYRIGHT LICENSE README INSTALL
dohtml README.html
- # Install ns plugin
- if [ "${ARCH}" == "x86" ] ; then
- PLATFORM="i386"
- elif [ "${ARCH}" == "ppc" ] ; then
- PLATFORM="ppc"
- elif [ "${ARCH}" == "sparc" ] ; then
- PLATFORM="sparc"
- fi
+ if use mozilla; then
+ if [ "${ARCH}" == "x86" ] ; then
+ PLATFORM="i386"
+ elif [ "${ARCH}" == "ppc" ] ; then
+ PLATFORM="ppc"
+ elif [ "${ARCH}" == "sparc" ] ; then
+ PLATFORM="sparc"
+ fi
- inst_plugin /opt/${P}/jre/plugin/${PLATFORM}/mozilla/javaplugin_oji.so
+ install_mozilla_plugin /opt/${P}/jre/plugin/${PLATFORM}/mozilla/javaplugin_oji.so
+ fi
find ${D}/opt/${P} -type f -name "*.so" -exec chmod +x \{\} \;
@@ -72,7 +73,13 @@ src_install () {
set_java_env ${FILESDIR}/${VMHANDLE} || die
}
-pkg_postinst () {
+pkg_postinst() {
# Set as default system VM if none exists
java_pkg_postinst
+
+ if use mozilla; then
+ einfo "The java mozilla plugin supplied by this package does not"
+ einfo "work with newer version mozilla/firefox."
+ einfo "You need >=${PN}-1.4 for them."
+ fi
}
diff --git a/dev-java/blackdown-jdk/blackdown-jdk-1.4.1.ebuild b/dev-java/blackdown-jdk/blackdown-jdk-1.4.1.ebuild
index d2c36e5e1881..ad4b7187c753 100644
--- a/dev-java/blackdown-jdk/blackdown-jdk-1.4.1.ebuild
+++ b/dev-java/blackdown-jdk/blackdown-jdk-1.4.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.4.1.ebuild,v 1.20 2004/09/21 08:14:39 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.4.1.ebuild,v 1.21 2004/09/29 20:59:28 axxo Exp $
-inherit java nsplugins
+inherit java
JREV="01"
@@ -21,7 +21,7 @@ CHPAX_CONSERVATIVE_FLAGS="pemsv"
LICENSE="sun-bcla-java-vm"
SLOT="1.4.1"
KEYWORDS="x86 -ppc sparc amd64"
-IUSE="doc"
+IUSE="doc mozilla"
DEPEND="virtual/libc
>=dev-java/java-config-0.2.6
@@ -48,7 +48,7 @@ get_offset() {
eval echo $offset
}
-src_unpack () {
+src_unpack() {
local offset="`get_offset ${DISTDIR}/${A}`"
if [ -z "${offset}" ] ; then
@@ -61,7 +61,7 @@ src_unpack () {
}
-src_install () {
+src_install() {
local PLATFORM=
dodir /opt/${P}
@@ -74,20 +74,21 @@ src_install () {
dodoc COPYRIGHT LICENSE README INSTALL
dohtml README.html
- # Install mozilla plugin
- if [ "${ARCH}" = "x86" ] ; then
- PLATFORM="i386"
- fi
+ if use mozilla; then
+ if [ "${ARCH}" = "x86" ] ; then
+ PLATFORM="i386"
+ fi
- if [ "${ARCH}" = "amd64" ] ; then
- PLATFORM="i386"
- fi
+ if [ "${ARCH}" = "amd64" ] ; then
+ PLATFORM="i386"
+ fi
- if [ "${ARCH}" = "sparc" ] ; then
- PLATFORM="sparc"
- fi
+ if [ "${ARCH}" = "sparc" ] ; then
+ PLATFORM="sparc"
+ fi
- inst_plugin /opt/${P}/jre/plugin/${PLATFORM}/mozilla/javaplugin_oji.so
+ install_mozilla_plugin /opt/${P}/jre/plugin/${PLATFORM}/mozilla/javaplugin_oji.so
+ fi
find ${D}/opt/${P} -type f -name "*.so" -exec chmod +x \{\} \;
@@ -104,7 +105,7 @@ src_install () {
fi
}
-pkg_postinst () {
+pkg_postinst() {
# Set as default system VM if none exists
java_pkg_postinst
@@ -113,6 +114,7 @@ pkg_postinst () {
# but may confuse things like AV scanners and automatic tripwire
if has_version "sys-apps/chpax"
then
+ echo
einfo "setting up conservative PaX flags for jar and javac"
for paxkills in "jar" "javac" "java"
diff --git a/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1-r1.ebuild b/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1-r1.ebuild
index e7b38377343a..6296afbeaf21 100644
--- a/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1-r1.ebuild
+++ b/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1-r1.ebuild,v 1.2 2004/07/14 01:44:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1-r1.ebuild,v 1.3 2004/09/29 20:59:28 axxo Exp $
IUSE="doc mozilla"
-inherit java nsplugins
+inherit java
JREV=${PV#*_}
JV=${PV%_*}
@@ -44,7 +44,7 @@ get_offset() {
echo $offset
}
-src_unpack () {
+src_unpack() {
local offset=$(get_offset ${DISTDIR}/${A})
if [ -z "${offset}" ] ; then
@@ -56,7 +56,7 @@ src_unpack () {
}
unpack_jars() {
- # New to 1.4.2
+ # New to 1.4.2
local PACKED_JARS="lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/javaws/javaws.jar"
local JAVAHOME="${D}/opt/${P}"
local UNPACK_CMD=""
@@ -81,7 +81,7 @@ unpack_jars() {
rm -f "$UNPACK_CMD"
}
-src_install () {
+src_install() {
typeset platform
dodir /opt/${P}
@@ -102,7 +102,8 @@ src_install () {
sparc*) platform="sparc" ;;
x86) platform="i386" ;;
esac
- inst_plugin /opt/${P}/jre/plugin/${platform}/mozilla/libjavaplugin_oji.so
+
+ install_mozilla_plugin /opt/${P}/jre/plugin/${platform}/mozilla/libjavaplugin_oji.so
fi
find ${D}/opt/${P} -type f -name "*.so" -exec chmod +x \{\} \;
@@ -120,7 +121,7 @@ src_install () {
unpack_jars
}
-pkg_postinst () {
+pkg_postinst() {
# Set as default system VM if none exists
java_pkg_postinst
@@ -129,6 +130,7 @@ pkg_postinst () {
# but may confuse things like AV scanners and automatic tripwire
if has_version "sys-apps/chpax"
then
+ echo
einfo "setting up conservative PaX flags for jar and javac"
for paxkills in "jar" "javac" "java"
diff --git a/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1.ebuild b/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1.ebuild
index 8e33d46f5a7b..63c842bccd49 100644
--- a/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1.ebuild
+++ b/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1.ebuild,v 1.13 2004/07/14 01:44:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blackdown-jdk/blackdown-jdk-1.4.2_rc1.ebuild,v 1.14 2004/09/29 20:59:28 axxo Exp $
-IUSE="doc"
-
-inherit java nsplugins
+inherit java
JREV=${PV#*_}
JV=${PV%_*}
@@ -30,6 +28,8 @@ PROVIDE="virtual/jdk-1.4.2
virtual/jre-1.4.2
virtual/java-scheme-2"
+IUSE="doc mozilla"
+
# Extract the 'skip' value (offset of tarball) we should pass to tail
get_offset() {
[ ! -f "$1" ] && return
@@ -44,7 +44,7 @@ get_offset() {
echo $offset
}
-src_unpack () {
+src_unpack() {
local offset=$(get_offset ${DISTDIR}/${A})
if [ -z "${offset}" ] ; then
@@ -56,7 +56,7 @@ src_unpack () {
}
unpack_jars() {
- # New to 1.4.2
+ # New to 1.4.2
local PACKED_JARS="lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/javaws/javaws.jar"
local JAVAHOME="${D}/opt/${P}"
local UNPACK_CMD=""
@@ -81,7 +81,7 @@ unpack_jars() {
rm -f "$UNPACK_CMD"
}
-src_install () {
+src_install() {
typeset platform
dodir /opt/${P}
@@ -95,12 +95,15 @@ src_install () {
dohtml README.html
# Install mozilla plugin
- case ${ARCH} in
- amd64|x86) platform="i386" ;;
- ppc) platform="ppc" ;;
- sparc*) platform="sparc" ;;
- esac
- inst_plugin /opt/${P}/jre/plugin/${platform}/mozilla/javaplugin_oji.so
+ if use mozilla; then
+ case ${ARCH} in
+ amd64|x86) platform="i386" ;;
+ ppc) platform="ppc" ;;
+ sparc*) platform="sparc" ;;
+ esac
+
+ install_mozilla_plugin /opt/${P}/jre/plugin/${platform}/mozilla/libjavaplugin_oji.so
+ fi
find ${D}/opt/${P} -type f -name "*.so" -exec chmod +x \{\} \;
@@ -118,7 +121,7 @@ src_install () {
unpack_jars
}
-pkg_postinst () {
+pkg_postinst() {
# Set as default system VM if none exists
java_pkg_postinst
@@ -127,6 +130,7 @@ pkg_postinst () {
# but may confuse things like AV scanners and automatic tripwire
if has_version "sys-apps/chpax"
then
+ echo
einfo "setting up conservative PaX flags for jar and javac"
for paxkills in "jar" "javac" "java"