summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-05-15 22:29:35 +0000
committerVlastimil Babka <caster@gentoo.org>2009-05-15 22:29:35 +0000
commit15e75099e8d5b19c9e2e7ddb45c5e72065b6e3bd (patch)
treeb0222792ea3a16bb3008840a27f4489002708b41 /dev-java/ant-core
parentVersion bump (bug #269920). (diff)
downloadhistorical-15e75099e8d5b19c9e2e7ddb45c5e72065b6e3bd.tar.gz
historical-15e75099e8d5b19c9e2e7ddb45c5e72065b6e3bd.tar.bz2
historical-15e75099e8d5b19c9e2e7ddb45c5e72065b6e3bd.zip
Removing ant 1.7.0, bug #261563.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-java/ant-core')
-rw-r--r--dev-java/ant-core/ChangeLog10
-rw-r--r--dev-java/ant-core/ant-core-1.7.0-r1.ebuild94
-rw-r--r--dev-java/ant-core/ant-core-1.7.0-r2.ebuild95
-rw-r--r--dev-java/ant-core/ant-core-1.7.0.ebuild94
-rw-r--r--dev-java/ant-core/ant-core-1.7.1-r1.ebuild102
-rwxr-xr-xdev-java/ant-core/files/1.7.0-ant197
-rw-r--r--dev-java/ant-core/files/1.7.1-ant197
-rw-r--r--dev-java/ant-core/files/ant-core-1.7.0-services.patch12
8 files changed, 8 insertions, 793 deletions
diff --git a/dev-java/ant-core/ChangeLog b/dev-java/ant-core/ChangeLog
index a83942498573..f182ee741bb6 100644
--- a/dev-java/ant-core/ChangeLog
+++ b/dev-java/ant-core/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for dev-java/ant-core
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.94 2009/05/10 15:14:37 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.95 2009/05/15 22:29:34 caster Exp $
# Ant-core blocks lower/older versions of ant-tasks,
# since it will not run when there is a version mismatch betwean the 2 packages
# Please unemerge ant-tasks when updating ant-core.
+ 15 May 2009; Vlastimil Babka <caster@gentoo.org> -files/1.7.0-ant,
+ -ant-core-1.7.0.ebuild, -ant-core-1.7.0-r1.ebuild,
+ -ant-core-1.7.0-r2.ebuild, -files/1.7.1-ant,
+ -files/ant-core-1.7.0-services.patch, -ant-core-1.7.1-r1.ebuild:
+ Removing ant 1.7.0, bug #261563.
+
10 May 2009; Raúl Porcel <armin76@gentoo.org> ant-core-1.7.1-r2.ebuild:
ia64 stable
diff --git a/dev-java/ant-core/ant-core-1.7.0-r1.ebuild b/dev-java/ant-core/ant-core-1.7.0-r1.ebuild
deleted file mode 100644
index b4f8f478c1b0..000000000000
--- a/dev-java/ant-core/ant-core-1.7.0-r1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.7.0-r1.ebuild,v 1.5 2008/04/12 10:28:19 nixnut Exp $
-
-# don't depend on itself
-JAVA_ANT_DISABLE_ANT_CORE_DEP=true
-# rewriting build.xml files for the testcases has no reason atm
-JAVA_PKG_BSFIX_ALL=no
-inherit java-pkg-2 java-ant-2
-
-MY_P="apache-ant-${PV}"
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/${MY_P}-src.tar.bz2
- mirror://gentoo/ant-${PV}-gentoo.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="doc source"
-
-# 1.7.0 instead of $PV in blocks is intentional, >1.7.0 upgrades should
-# be block free (but these fixed blocks should stay there for users upgrading
-# from <1.7.0 of course)
-RDEPEND=">=virtual/jdk-1.4
- !<dev-java/ant-tasks-1.7.0
- !<dev-java/ant-1.7.0
- !dev-java/ant-optional"
-DEPEND="${RDEPEND}
- source? ( app-arch/zip )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # remove bundled xerces
- rm -v lib/*.jar
-
- # use our split-ant build.xml
- mv -f "${WORKDIR}/build.xml" .
-}
-
-src_compile() {
- export ANT_HOME=""
-
- local bsyscp
-
- # this ensures that when building ant with bootstrapped ant,
- # only the source is used for resolving references, and not
- # the classes in bootstrapped ant
- # but jikes in kaffe has issues with this...
- if ! java-pkg_current-vm-matches kaffe; then
- bsyscp="-Dbuild.sysclasspath=ignore"
- fi
-
- ./build.sh ${bsyscp} jars-core $(use_doc javadocs) \
- || die "build failed"
-}
-
-src_install() {
- newbin "${FILESDIR}/${PV}-ant" ant || die "failed to install wrapper"
-
- dodir /usr/share/${PN}/bin
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin "${S}/src/script/${each}"
- dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
- done
-
- echo "ANT_HOME=\"/usr/share/${PN}\"" > "${T}/20ant"
- doenvd "${T}/20ant" || die "failed to install env.d file"
-
- java-pkg_dojar build/lib/ant.jar
- java-pkg_dojar build/lib/ant-bootstrap.jar
- java-pkg_dojar build/lib/ant-launcher.jar
-
- use source && java-pkg_dosrc src/main/*
-
- dodoc README WHATSNEW KEYS
-
- if use doc; then
- dohtml welcome.html
- dohtml -r docs/*
- java-pkg_dojavadoc --symlink manual/api build/javadocs
- fi
-}
-
-pkg_postinst() {
- elog "The way of packaging ant in Gentoo has changed significantly since"
- elog "the 1.7.0 version, For more information, please see:"
- elog "http://www.gentoo.org/proj/en/java/ant-guide.xml"
-}
diff --git a/dev-java/ant-core/ant-core-1.7.0-r2.ebuild b/dev-java/ant-core/ant-core-1.7.0-r2.ebuild
deleted file mode 100644
index 9ee7ba30dab8..000000000000
--- a/dev-java/ant-core/ant-core-1.7.0-r2.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.7.0-r2.ebuild,v 1.1 2008/06/16 18:59:17 betelgeuse Exp $
-
-# don't depend on itself
-JAVA_ANT_DISABLE_ANT_CORE_DEP=true
-# rewriting build.xml files for the testcases has no reason atm
-JAVA_PKG_BSFIX_ALL=no
-inherit java-pkg-2 java-ant-2
-
-MY_P="apache-ant-${PV}"
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/${MY_P}-src.tar.bz2
- mirror://gentoo/ant-${PV}-gentoo.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc source"
-
-# 1.7.0 instead of $PV in blocks is intentional, >1.7.0 upgrades should
-# be block free (but these fixed blocks should stay there for users upgrading
-# from <1.7.0 of course)
-RDEPEND=">=virtual/jdk-1.4
- !<dev-java/ant-tasks-1.7.0
- !<dev-java/ant-1.7.0
- !dev-java/ant-optional"
-DEPEND="${RDEPEND}
- source? ( app-arch/zip )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/ant-core-1.7.0-services.patch"
-
- # remove bundled xerces
- rm -v lib/*.jar
-
- # use our split-ant build.xml
- mv -f "${WORKDIR}/build.xml" .
-}
-
-src_compile() {
- export ANT_HOME=""
-
- local bsyscp
-
- # this ensures that when building ant with bootstrapped ant,
- # only the source is used for resolving references, and not
- # the classes in bootstrapped ant
- # but jikes in kaffe has issues with this...
- if ! java-pkg_current-vm-matches kaffe; then
- bsyscp="-Dbuild.sysclasspath=ignore"
- fi
-
- ./build.sh ${bsyscp} jars-core $(use_doc javadocs) \
- || die "build failed"
-}
-
-src_install() {
- newbin "${FILESDIR}/${PV}-ant" ant || die "failed to install wrapper"
-
- dodir /usr/share/${PN}/bin
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin "${S}/src/script/${each}"
- dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
- done
-
- echo "ANT_HOME=\"/usr/share/${PN}\"" > "${T}/20ant"
- doenvd "${T}/20ant" || die "failed to install env.d file"
-
- java-pkg_dojar build/lib/ant.jar
- java-pkg_dojar build/lib/ant-bootstrap.jar
- java-pkg_dojar build/lib/ant-launcher.jar
-
- use source && java-pkg_dosrc src/main/*
-
- dodoc README WHATSNEW KEYS
-
- if use doc; then
- dohtml welcome.html
- dohtml -r docs/*
- java-pkg_dojavadoc --symlink manual/api build/javadocs
- fi
-}
-
-pkg_postinst() {
- elog "The way of packaging ant in Gentoo has changed significantly since"
- elog "the 1.7.0 version, For more information, please see:"
- elog "http://www.gentoo.org/proj/en/java/ant-guide.xml"
-}
diff --git a/dev-java/ant-core/ant-core-1.7.0.ebuild b/dev-java/ant-core/ant-core-1.7.0.ebuild
deleted file mode 100644
index a42fe205363f..000000000000
--- a/dev-java/ant-core/ant-core-1.7.0.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.7.0.ebuild,v 1.14 2007/05/12 17:43:18 wltjr Exp $
-
-# don't depend on itself
-JAVA_ANT_DISABLE_ANT_CORE_DEP=true
-# rewriting build.xml files for the testcases has no reason atm
-JAVA_PKG_BSFIX_ALL=no
-inherit java-pkg-2 java-ant-2
-
-MY_P="apache-ant-${PV}"
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/${MY_P}-src.tar.bz2
- mirror://gentoo/ant-${PV}-gentoo.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="doc source"
-
-# 1.7.0 instead of $PV in blocks is intentional, >1.7.0 upgrades should
-# be block free (but these fixed blocks should stay there for users upgrading
-# from <1.7.0 of course)
-RDEPEND=">=virtual/jdk-1.4
- !<dev-java/ant-tasks-1.7.0
- !<dev-java/ant-1.7.0
- !dev-java/ant-optional"
-DEPEND="${RDEPEND}
- source? ( app-arch/zip )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # remove bundled xerces
- rm -v lib/*.jar
-
- # use our split-ant build.xml
- mv -f ${WORKDIR}/build.xml .
-}
-
-src_compile() {
- export ANT_HOME=""
-
- local bsyscp
-
- # this ensures that when building ant with bootstrapped ant,
- # only the source is used for resolving references, and not
- # the classes in bootstrapped ant
- # but jikes in kaffe has issues with this...
- if ! java-pkg_current-vm-matches kaffe; then
- bsyscp="-Dbuild.sysclasspath=ignore"
- fi
-
- ./build.sh ${bsyscp} jars-core $(use_doc javadocs) \
- || die "build failed"
-}
-
-src_install() {
- newbin ${FILESDIR}/${PV}-ant ant || die "failed to install wrapper"
-
- dodir /usr/share/${PN}/bin
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin ${S}/src/script/${each}
- dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
- done
-
- echo "ANT_HOME=\"/usr/share/${PN}\"" > ${T}/20ant
- doenvd ${T}/20ant || die "failed to install env.d file"
-
- java-pkg_dojar build/lib/ant.jar
- java-pkg_dojar build/lib/ant-bootstrap.jar
- java-pkg_dojar build/lib/ant-launcher.jar
-
- use source && java-pkg_dosrc src/main/*
-
- dodoc README WHATSNEW KEYS
-
- if use doc; then
- dohtml welcome.html
- dohtml -r docs/*
- java-pkg_dojavadoc build/javadocs
- fi
-}
-
-pkg_postinst() {
- elog "The way of packaging ant in Gentoo has changed significantly since"
- elog "the 1.7.0 version, For more information, please see:"
- elog "http://www.gentoo.org/proj/en/java/ant-guide.xml"
-}
diff --git a/dev-java/ant-core/ant-core-1.7.1-r1.ebuild b/dev-java/ant-core/ant-core-1.7.1-r1.ebuild
deleted file mode 100644
index 2225ccd79f4a..000000000000
--- a/dev-java/ant-core/ant-core-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.7.1-r1.ebuild,v 1.2 2008/07/16 21:25:23 caster Exp $
-
-# don't depend on itself
-JAVA_ANT_DISABLE_ANT_CORE_DEP=true
-# rewriting build.xml files for the testcases has no reason atm
-JAVA_PKG_BSFIX_ALL=no
-JAVA_PKG_IUSE="doc source"
-inherit java-pkg-2 java-ant-2
-
-MY_P="apache-ant-${PV}"
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/${MY_P}-src.tar.bz2
- mirror://gentoo/ant-${PV}-gentoo.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.4
- !dev-java/ant-tasks
- !dev-java/ant-optional"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # remove bundled xerces
- rm -v lib/*.jar || die
-
- # use our split-ant build.xml
- mv -f "${WORKDIR}/build.xml" . || die
-
- # bug #196080
- java-ant_bsfix_one build.xml
-}
-
-src_compile() {
- export ANT_HOME=""
-
- local bsyscp
-
- # this ensures that when building ant with bootstrapped ant,
- # only the source is used for resolving references, and not
- # the classes in bootstrapped ant
- # but jikes in kaffe has issues with this...
- if ! java-pkg_current-vm-matches kaffe; then
- bsyscp="-Dbuild.sysclasspath=ignore"
- fi
-
- ./build.sh ${bsyscp} jars-core internal_dist $(use_doc javadocs) \
- || die "build failed"
-}
-
-src_install() {
- dodir /usr/share/ant/lib
- for jar in ant.jar ant-bootstrap.jar ant-launcher.jar ; do
- java-pkg_dojar build/lib/${jar}
- dosym /usr/share/${PN}/lib/${jar} /usr/share/ant/lib/${jar}
- done
-
- newbin "${FILESDIR}/${PV}-ant" ant || die "failed to install wrapper"
- dodir /usr/share/${PN}/bin
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin "${S}/src/script/${each}"
- dosym /usr/bin/${each} /usr/share/${PN}/bin/${each}
- done
- dosym /usr/share/${PN}/bin /usr/share/ant/bin
-
- insinto /usr/share/${PN}
- doins -r dist/etc
- dosym /usr/share/${PN}/etc /usr/share/ant/etc
-
- echo "ANT_HOME=\"/usr/share/ant\"" > "${T}/20ant"
- doenvd "${T}/20ant" || die "failed to install env.d file"
-
- dodoc README WHATSNEW KEYS
-
- if use doc; then
- dohtml welcome.html
- dohtml -r docs/*
- java-pkg_dojavadoc --symlink manual/api build/javadocs
- fi
-
- use source && java-pkg_dosrc src/main/*
-}
-
-pkg_postinst() {
- elog "The way of packaging ant in Gentoo has changed significantly since"
- elog "the 1.7.0 version, For more information, please see:"
- elog "http://www.gentoo.org/proj/en/java/ant-guide.xml"
- elog
- elog "Since 1.7.1, the ant-tasks meta-ebuild has been removed and its USE"
- elog "flags have been moved to dev-java/ant."
-}
diff --git a/dev-java/ant-core/files/1.7.0-ant b/dev-java/ant-core/files/1.7.0-ant
deleted file mode 100755
index e5d1a7100495..000000000000
--- a/dev-java/ant-core/files/1.7.0-ant
+++ /dev/null
@@ -1,197 +0,0 @@
-#! /bin/bash
-
-# Licensed to the Apache Software Foundation (ASF) under one or more
-# contributor license agreements. See the NOTICE file distributed with
-# this work for additional information regarding copyright ownership.
-# The ASF licenses this file to You under the Apache License, Version 2.0
-# (the "License"); you may not use this file except in compliance with
-# the License. You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-# Edited for Gentoo Linux
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.7.0-ant,v 1.1 2007/01/21 21:56:58 caster Exp $
-
-# Extract launch and ant arguments, (see details below).
-ant_exec_args=
-no_config=false
-use_jikes_default=false
-ant_exec_debug=false
-show_help=false
-for arg in "$@" ; do
- if [ "$arg" = "--noconfig" ] ; then
- no_config=true
- elif [ "$arg" = "--usejikes" ] ; then
- use_jikes_default=true
- elif [ "$arg" = "--execdebug" ] ; then
- ant_exec_debug=true
- elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
- show_help=true
- ant_exec_args="$ant_exec_args -h"
- else
- if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
- show_help=true
- fi
- ant_exec_args="$ant_exec_args \"$arg\""
- fi
-done
-
-# Source/default ant configuration
-if $no_config ; then
- rpm_mode=false
- usejikes=$use_jikes_default
-else
- # load system-wide ant configuration (ONLY if ANT_HOME has NOT been set)
- if [ -z "$ANT_HOME" -o "$ANT_HOME" = "/usr/share/ant" ]; then
- if [ -f "/etc/ant.conf" ] ; then
- . /etc/ant.conf
- fi
- fi
-
- # load user ant configuration
- if [ -f "$HOME/.ant/ant.conf" ] ; then
- . $HOME/.ant/ant.conf
- fi
- if [ -f "$HOME/.antrc" ] ; then
- . "$HOME/.antrc"
- fi
-
- # provide default configuration values
- if [ -z "$rpm_mode" ] ; then
- rpm_mode=false
- fi
- if [ -z "$usejikes" ] ; then
- usejikes=$use_jikes_default
- fi
-fi
-
-export WANT_JAVA_CONFIG=2
-
-# Always get JAVA_HOME from java-config.
-# Use GENTOO_VM to change which VM is used instead.
-export JAVA_HOME="$(java-config -g JAVA_HOME)"
-
-if [ -z $JAVA_HOME ] ; then
- echo 'Error: No JDK found!'
- echo "Try using java-config script to set your JDK"
- echo "Remember that you need a JDK not a JRE"
- exit 1
-fi
-
-ANT_HOME=/usr/share/ant-core
-
-# set ANT_LIB location
-ANT_LIB="${ANT_HOME}/lib"
-
-if [ -z "$JAVACMD" ] ; then
- if [ -n "$JAVA_HOME" ] ; then
- JAVACMD="$JAVA_HOME/bin/java"
- else
- JAVACMD=`which java 2> /dev/null `
- if [ -z "$JAVACMD" ] ; then
- JAVACMD=java
- fi
- fi
-fi
-
-if [ ! -x "$JAVACMD" ] ; then
- echo "Error: JAVA_HOME is not defined correctly."
- echo " We cannot execute $JAVACMD"
- exit 1
-fi
-
-if [ -z "$LOCALCLASSPATH" ] ; then
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
-else
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
-fi
-
-# if ANT_TASKS is not set, default to "all"
-ANT_TASKS="${ANT_TASKS:-all}"
-
-# if ANT_TASKS is set to "all", get the tasks list from /usr/share/ant/tasks/
-if [[ "${ANT_TASKS}" == "all" ]]; then
- ANT_TASKS=""
- # but only if it exists
- if [[ -d /usr/share/ant/tasks ]]; then
- ANT_TASKS="${ANT_TASKS} "/usr/share/ant/tasks/*
- fi
- if [[ -d /usr/share/ant/tasks-1.7.0 ]]; then
- ANT_TASKS="${ANT_TASKS} "/usr/share/ant/tasks-1.7.0/*
- fi
-# if set to "none", make ANT_TASKS empty list
-elif [[ "${ANT_TASKS}" == "none" ]]; then
- ANT_TASKS=""
-fi
-# otherwise ANT_TASKS defines explicit task list
-
-# construct the tasks list separated with commas to pass to java-config
-TASKS_LIST=""
-for task in $ANT_TASKS; do
- TASKS_LIST="${TASKS_LIST},$(basename $task)"
-done
-TASKS_LIST=${TASKS_LIST#,}
-
-# get the classpath for optional tasks and their dependency .jar files
-if [[ -n "${TASKS_LIST}" ]] ; then
- ANT_TASKS_CLASSPATH="-lib \"$(java-config -dp ${TASKS_LIST})\""
- ANT_TASKS_LIBPATH="-Djava.library.path=\"$(java-config -di ${TASKS_LIST})\""
-else
- ANT_TASKS_CLASSPATH=""
- ANT_TASKS_LIBPATH=""
-fi
-
-TOOLS_JAR="$(java-config --tools)"
-
-if [[ -n "${TOOLS_JAR}" ]] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:${TOOLS_JAR}"
-else
- echo "Warning: Unable to determine tools.jar location."
- echo " If build fails because sun.* classes could not be found,"
- echo " Make sure you are using a JDK, not JRE as your user/system VM."
- echo " and that you have java-config version 2.0.30 or above installed."
-fi
-
-# Allow Jikes support (off by default)
-if $usejikes; then
- ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
-fi
-
-# Show script help if requested
-if $show_help ; then
- echo $0 '[script options] [options] [target [target2 [target3] ..]]'
- echo 'Script Options:'
- echo ' --help, --h print this message and ant help'
- echo ' --noconfig suppress sourcing of /etc/ant.conf,'
- echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
- echo ' configuration files'
- echo ' --usejikes enable use of jikes by default, unless'
- echo ' set explicitly in configuration files'
- echo ' --execdebug print ant exec line generated by this'
- echo ' launch script'
- echo ' '
-fi
-
-# Execute ant using eval/exec to preserve spaces in paths,
-# java options, and ant args
-ant_sys_opts=
-
-if [ -n "$JIKESPATH" ]; then
- ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
-fi
-
-ant_exec_command="exec \"${JAVACMD}\" ${ANT_OPTS} -classpath \"${LOCALCLASSPATH}\" \
- -Dant.home=\"${ANT_HOME}\" -Dant.library.dir=\"${ANT_LIB}\" ${ant_sys_opts} \
- ${ANT_TASKS_LIBPATH} org.apache.tools.ant.launch.Launcher \
- ${ANT_TASKS_CLASSPATH} ${ANT_ARGS} -cp \"${CLASSPATH}\" ${ant_exec_args}"
-
-if $ant_exec_debug ; then
- echo $ant_exec_command
-fi
-eval $ant_exec_command
diff --git a/dev-java/ant-core/files/1.7.1-ant b/dev-java/ant-core/files/1.7.1-ant
deleted file mode 100644
index d31519cafd70..000000000000
--- a/dev-java/ant-core/files/1.7.1-ant
+++ /dev/null
@@ -1,197 +0,0 @@
-#! /bin/bash
-
-# Licensed to the Apache Software Foundation (ASF) under one or more
-# contributor license agreements. See the NOTICE file distributed with
-# this work for additional information regarding copyright ownership.
-# The ASF licenses this file to You under the Apache License, Version 2.0
-# (the "License"); you may not use this file except in compliance with
-# the License. You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-# Edited for Gentoo Linux
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.7.1-ant,v 1.2 2008/07/16 14:41:51 caster Exp $
-
-# Extract launch and ant arguments, (see details below).
-ant_exec_args=
-no_config=false
-use_jikes_default=false
-ant_exec_debug=false
-show_help=false
-for arg in "$@" ; do
- if [ "$arg" = "--noconfig" ] ; then
- no_config=true
- elif [ "$arg" = "--usejikes" ] ; then
- use_jikes_default=true
- elif [ "$arg" = "--execdebug" ] ; then
- ant_exec_debug=true
- elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
- show_help=true
- ant_exec_args="$ant_exec_args -h"
- else
- if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
- show_help=true
- fi
- ant_exec_args="$ant_exec_args \"$arg\""
- fi
-done
-
-# Source/default ant configuration
-if $no_config ; then
- rpm_mode=false
- usejikes=$use_jikes_default
-else
- # load system-wide ant configuration (ONLY if ANT_HOME has NOT been set)
- if [ -z "$ANT_HOME" -o "$ANT_HOME" = "/usr/share/ant" ]; then
- if [ -f "/etc/ant.conf" ] ; then
- . /etc/ant.conf
- fi
- fi
-
- # load user ant configuration
- if [ -f "$HOME/.ant/ant.conf" ] ; then
- . $HOME/.ant/ant.conf
- fi
- if [ -f "$HOME/.antrc" ] ; then
- . "$HOME/.antrc"
- fi
-
- # provide default configuration values
- if [ -z "$rpm_mode" ] ; then
- rpm_mode=false
- fi
- if [ -z "$usejikes" ] ; then
- usejikes=$use_jikes_default
- fi
-fi
-
-export WANT_JAVA_CONFIG=2
-
-# Always get JAVA_HOME from java-config.
-# Use GENTOO_VM to change which VM is used instead.
-export JAVA_HOME="$(java-config -g JAVA_HOME)"
-
-if [ -z $JAVA_HOME ] ; then
- echo 'Error: No JDK found!'
- echo "Try using java-config script to set your JDK"
- echo "Remember that you need a JDK not a JRE"
- exit 1
-fi
-
-ANT_HOME=/usr/share/ant-core
-
-# set ANT_LIB location
-ANT_LIB="${ANT_HOME}/lib"
-
-if [ -z "$JAVACMD" ] ; then
- if [ -n "$JAVA_HOME" ] ; then
- JAVACMD="$JAVA_HOME/bin/java"
- else
- JAVACMD=`which java 2> /dev/null `
- if [ -z "$JAVACMD" ] ; then
- JAVACMD=java
- fi
- fi
-fi
-
-if [ ! -x "$JAVACMD" ] ; then
- echo "Error: JAVA_HOME is not defined correctly."
- echo " We cannot execute $JAVACMD"
- exit 1
-fi
-
-if [ -z "$LOCALCLASSPATH" ] ; then
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
-else
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
-fi
-
-# if ANT_TASKS is not set, default to "all"
-ANT_TASKS="${ANT_TASKS:-all}"
-
-# if ANT_TASKS is set to "all", get the tasks list from /usr/share/ant/tasks/
-if [[ "${ANT_TASKS}" == "all" ]]; then
- ANT_TASKS=""
- # but only if it exists
- if [[ -d /usr/share/ant/tasks ]]; then
- ANT_TASKS="${ANT_TASKS} "/usr/share/ant/tasks/*
- fi
- if [[ -d /usr/share/ant/tasks-1.7.1 ]]; then
- ANT_TASKS="${ANT_TASKS} "/usr/share/ant/tasks-1.7.1/*
- fi
-# if set to "none", make ANT_TASKS empty list
-elif [[ "${ANT_TASKS}" == "none" ]]; then
- ANT_TASKS=""
-fi
-# otherwise ANT_TASKS defines explicit task list
-
-# construct the tasks list separated with commas to pass to java-config
-TASKS_LIST=""
-for task in $ANT_TASKS; do
- TASKS_LIST="${TASKS_LIST},$(basename $task)"
-done
-TASKS_LIST=${TASKS_LIST#,}
-
-# get the classpath for optional tasks and their dependency .jar files
-if [[ -n "${TASKS_LIST}" ]] ; then
- ANT_TASKS_CLASSPATH="-lib \"$(java-config -dp ${TASKS_LIST})\""
- ANT_TASKS_LIBPATH="-Djava.library.path=\"$(java-config -di ${TASKS_LIST})\""
-else
- ANT_TASKS_CLASSPATH=""
- ANT_TASKS_LIBPATH=""
-fi
-
-TOOLS_JAR="$(java-config --tools)"
-
-if [[ -n "${TOOLS_JAR}" ]] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:${TOOLS_JAR}"
-else
- echo "Warning: Unable to determine tools.jar location."
- echo " If build fails because sun.* classes could not be found,"
- echo " Make sure you are using a JDK, not JRE as your user/system VM."
- echo " and that you have java-config version 2.0.30 or above installed."
-fi
-
-# Allow Jikes support (off by default)
-if $usejikes; then
- ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
-fi
-
-# Show script help if requested
-if $show_help ; then
- echo $0 '[script options] [options] [target [target2 [target3] ..]]'
- echo 'Script Options:'
- echo ' --help, --h print this message and ant help'
- echo ' --noconfig suppress sourcing of /etc/ant.conf,'
- echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
- echo ' configuration files'
- echo ' --usejikes enable use of jikes by default, unless'
- echo ' set explicitly in configuration files'
- echo ' --execdebug print ant exec line generated by this'
- echo ' launch script'
- echo ' '
-fi
-
-# Execute ant using eval/exec to preserve spaces in paths,
-# java options, and ant args
-ant_sys_opts=
-
-if [ -n "$JIKESPATH" ]; then
- ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
-fi
-
-ant_exec_command="exec \"${JAVACMD}\" ${ANT_OPTS} -classpath \"${LOCALCLASSPATH}\" \
- -Dant.home=\"${ANT_HOME}\" -Dant.library.dir=\"${ANT_LIB}\" ${ant_sys_opts} \
- ${ANT_TASKS_LIBPATH} org.apache.tools.ant.launch.Launcher \
- ${ANT_TASKS_CLASSPATH} ${ANT_ARGS} -cp \"${CLASSPATH}\" ${ant_exec_args}"
-
-if $ant_exec_debug ; then
- echo $ant_exec_command
-fi
-eval $ant_exec_command
diff --git a/dev-java/ant-core/files/ant-core-1.7.0-services.patch b/dev-java/ant-core/files/ant-core-1.7.0-services.patch
deleted file mode 100644
index 423e066d2c04..000000000000
--- a/dev-java/ant-core/files/ant-core-1.7.0-services.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r -U3 apache-ant-1.7.0/src/main/org/apache/tools/ant/taskdefs/Jar.java apache-ant-1.7.0.my/src/main/org/apache/tools/ant/taskdefs/Jar.java
---- apache-ant-1.7.0/src/main/org/apache/tools/ant/taskdefs/Jar.java 2006-12-13 13:16:21.000000000 +0100
-+++ apache-ant-1.7.0.my/src/main/org/apache/tools/ant/taskdefs/Jar.java 2008-06-16 17:58:08.000000000 +0200
-@@ -397,7 +397,7 @@
- service = (Service) serviceIterator.next();
- //stolen from writeManifest
- super.zipFile(service.getAsStream(), zOut,
-- "META-INF/service/" + service.getType(),
-+ "META-INF/services/" + service.getType(),
- System.currentTimeMillis(), null,
- ZipFileSet.DEFAULT_FILE_MODE);
- }