summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:49 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-07-02 19:09:49 +0000
commit85c89a6a1e184e931c2ea612675ecda59bb299d3 (patch)
tree1664d9add2584720f897a268ab95f2b26fc8faa3 /dev-haskell
parentStable on ppc. (diff)
downloadhistorical-85c89a6a1e184e931c2ea612675ecda59bb299d3.tar.gz
historical-85c89a6a1e184e931c2ea612675ecda59bb299d3.tar.bz2
historical-85c89a6a1e184e931c2ea612675ecda59bb299d3.zip
New 1.0 version of HDBC and backends.
Package-Manager: portage-2.1-r1
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hdbc-odbc/ChangeLog7
-rw-r--r--dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.03
-rw-r--r--dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild32
-rw-r--r--dev-haskell/hdbc-postgresql/ChangeLog8
-rw-r--r--dev-haskell/hdbc-postgresql/files/digest-hdbc-postgresql-1.0.0.03
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild23
-rw-r--r--dev-haskell/hdbc-sqlite/ChangeLog8
-rw-r--r--dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.0.0.03
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild23
-rw-r--r--dev-haskell/hdbc/ChangeLog7
-rw-r--r--dev-haskell/hdbc/files/digest-hdbc-1.0.03
-rw-r--r--dev-haskell/hdbc/hdbc-1.0.0.ebuild23
12 files changed, 139 insertions, 4 deletions
diff --git a/dev-haskell/hdbc-odbc/ChangeLog b/dev-haskell/hdbc-odbc/ChangeLog
index 6c009396d7aa..4182e04ab946 100644
--- a/dev-haskell/hdbc-odbc/ChangeLog
+++ b/dev-haskell/hdbc-odbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdbc-odbc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/ChangeLog,v 1.7 2006/03/30 16:05:50 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/ChangeLog,v 1.8 2006/07/02 19:09:02 dcoutts Exp $
+
+*hdbc-odbc-1.0.0.0 (02 Jul 2006)
+
+ 02 Jul 2006; Duncan Coutts <dcoutts@gentoo.org> +hdbc-odbc-1.0.0.0.ebuild:
+ New 1.0 version of HDBC and backends.
30 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> hdbc-odbc-0.99.2.1.ebuild:
Patch build bug as recommened by upstream.
diff --git a/dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.0 b/dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.0
new file mode 100644
index 000000000000..b3b197b090f3
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/files/digest-hdbc-odbc-1.0.0.0
@@ -0,0 +1,3 @@
+MD5 7db49cc29f8b106c92059ce15fd675ff hdbc-odbc_1.0.0.0.tar.gz 36486
+RMD160 8d727479f85ca7b432a26a179ee68ca76829e127 hdbc-odbc_1.0.0.0.tar.gz 36486
+SHA256 cadfb22db6a02e0cc07dd32c90b7280b4c2fae32f79258394cd985b6c5ef5f80 hdbc-odbc_1.0.0.0.tar.gz 36486
diff --git a/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild b/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild
new file mode 100644
index 000000000000..f6d5f337a7ca
--- /dev/null
+++ b/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-odbc/hdbc-odbc-1.0.0.0.ebuild,v 1.1 2006/07/02 19:09:02 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit base haskell-cabal versionator
+
+DESCRIPTION="ODBC database driver for HDBC"
+HOMEPAGE="http://quux.org/devel/hdbc/"
+SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+hdbc_PV=$(get_version_component_range 1-3)
+
+DEPEND=">=virtual/ghc-6.4.1
+ ~dev-haskell/hdbc-${hdbc_PV}
+ >=dev-db/unixODBC-2.2"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ base_src_unpack
+
+ # temp patch for missing #include. It seems different versions of
+ # dev-db/unixODBC #include their headers in each other differently.
+ sed -i 's/#include <sqlext.h>/#include <sqlext.h>\n#include <sqlucode.h>/' \
+ "${S}/Database/HDBC/ODBC/TypeConv.hsc"
+}
diff --git a/dev-haskell/hdbc-postgresql/ChangeLog b/dev-haskell/hdbc-postgresql/ChangeLog
index e86ee2820fd4..3c41cad5f28f 100644
--- a/dev-haskell/hdbc-postgresql/ChangeLog
+++ b/dev-haskell/hdbc-postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hdbc-postgresql
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.6 2006/03/30 15:36:14 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.7 2006/07/02 19:09:24 dcoutts Exp $
+
+*hdbc-postgresql-1.0.0.0 (02 Jul 2006)
+
+ 02 Jul 2006; Duncan Coutts <dcoutts@gentoo.org>
+ +hdbc-postgresql-1.0.0.0.ebuild:
+ New 1.0 version of HDBC and backends.
*hdbc-postgresql-0.99.2.1 (30 Mar 2006)
diff --git a/dev-haskell/hdbc-postgresql/files/digest-hdbc-postgresql-1.0.0.0 b/dev-haskell/hdbc-postgresql/files/digest-hdbc-postgresql-1.0.0.0
new file mode 100644
index 000000000000..f6bb3402463d
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/files/digest-hdbc-postgresql-1.0.0.0
@@ -0,0 +1,3 @@
+MD5 eda452e301dacf2691ad592858fae1a7 hdbc-postgresql_1.0.0.0.tar.gz 34131
+RMD160 afd1a8cf1766e4ba4423951d947e5e605359080b hdbc-postgresql_1.0.0.0.tar.gz 34131
+SHA256 03d79756ec0b2eb102e247745202b53f80c0228da8856a11ef24a121142a4092 hdbc-postgresql_1.0.0.0.tar.gz 34131
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild
new file mode 100644
index 000000000000..b2c6fccc387c
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-1.0.0.0.ebuild,v 1.1 2006/07/02 19:09:24 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal versionator
+
+DESCRIPTION="PostgreSQL database driver for HDBC"
+HOMEPAGE="http://quux.org/devel/hdbc/"
+SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
+IUSE=""
+
+hdbc_PV=$(get_version_component_range 1-3)
+
+DEPEND=">=virtual/ghc-6.4.1
+ ~dev-haskell/hdbc-${hdbc_PV}
+ >=dev-db/libpq-8"
+
+S="${WORKDIR}/${PN}"
diff --git a/dev-haskell/hdbc-sqlite/ChangeLog b/dev-haskell/hdbc-sqlite/ChangeLog
index 1b436f4eefaf..68c8d4268e62 100644
--- a/dev-haskell/hdbc-sqlite/ChangeLog
+++ b/dev-haskell/hdbc-sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hdbc-sqlite
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.6 2006/03/30 15:36:45 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.7 2006/07/02 19:09:49 dcoutts Exp $
+
+*hdbc-sqlite-1.0.0.0 (02 Jul 2006)
+
+ 02 Jul 2006; Duncan Coutts <dcoutts@gentoo.org>
+ +hdbc-sqlite-1.0.0.0.ebuild:
+ New 1.0 version of HDBC and backends.
*hdbc-sqlite-0.99.2.0 (30 Mar 2006)
diff --git a/dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.0.0.0 b/dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.0.0.0
new file mode 100644
index 000000000000..e4e8b8912f97
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.0.0.0
@@ -0,0 +1,3 @@
+MD5 afc6310a7e260754eedc893ee72cf867 hdbc-sqlite3_1.0.0.0.tar.gz 23787
+RMD160 ac277b6aed7a4436662ede731d98826d1c270884 hdbc-sqlite3_1.0.0.0.tar.gz 23787
+SHA256 5d82afea0aec889e2a24f9070b94ce5d5cefc4b568e35f3402ea0ff90fcc706e hdbc-sqlite3_1.0.0.0.tar.gz 23787
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild
new file mode 100644
index 000000000000..43ca014dca23
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.0.0.0.ebuild,v 1.1 2006/07/02 19:09:49 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal versionator
+
+DESCRIPTION="Sqlite v3 database driver for HDBC"
+HOMEPAGE="http://quux.org/devel/hdbc/"
+SRC_URI="http://quux.org/devel/hdbc/${PN}3_${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc"
+IUSE=""
+
+hdbc_PV=$(get_version_component_range 1-3)
+
+DEPEND=">=virtual/ghc-6.4.1
+ ~dev-haskell/hdbc-${hdbc_PV}
+ >=dev-db/sqlite-3.2"
+
+S="${WORKDIR}/${PN}3"
diff --git a/dev-haskell/hdbc/ChangeLog b/dev-haskell/hdbc/ChangeLog
index c6a62cd893f8..366ba81b109a 100644
--- a/dev-haskell/hdbc/ChangeLog
+++ b/dev-haskell/hdbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdbc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/ChangeLog,v 1.6 2006/03/30 15:35:07 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/ChangeLog,v 1.7 2006/07/02 19:08:39 dcoutts Exp $
+
+*hdbc-1.0.0 (02 Jul 2006)
+
+ 02 Jul 2006; Duncan Coutts <dcoutts@gentoo.org> +hdbc-1.0.0.ebuild:
+ New 1.0 version of HDBC and backends.
*hdbc-0.99.2 (30 Mar 2006)
diff --git a/dev-haskell/hdbc/files/digest-hdbc-1.0.0 b/dev-haskell/hdbc/files/digest-hdbc-1.0.0
new file mode 100644
index 000000000000..adda7d0de8c5
--- /dev/null
+++ b/dev-haskell/hdbc/files/digest-hdbc-1.0.0
@@ -0,0 +1,3 @@
+MD5 3f01da20bd47f0f748bc31d285a283c7 hdbc_1.0.0.tar.gz 52179
+RMD160 ae60ca444373f07ca63787c9f980264542a39131 hdbc_1.0.0.tar.gz 52179
+SHA256 e6aed275c61a28fc95176564675482c25bad06e2afd07bf989ac6a24a8280bd8 hdbc_1.0.0.tar.gz 52179
diff --git a/dev-haskell/hdbc/hdbc-1.0.0.ebuild b/dev-haskell/hdbc/hdbc-1.0.0.ebuild
new file mode 100644
index 000000000000..1eb6f47fccc4
--- /dev/null
+++ b/dev-haskell/hdbc/hdbc-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/hdbc-1.0.0.ebuild,v 1.1 2006/07/02 19:08:39 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell Database Connectivity"
+HOMEPAGE="http://quux.org/devel/hdbc/"
+SRC_URI="http://quux.org/devel/hdbc/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="odbc postgres sqlite"
+
+DEPEND=">=virtual/ghc-6.4.1"
+
+PDEPEND="odbc? ( =dev-haskell/hdbc-odbc-${PV}* )
+ postgres? ( =dev-haskell/hdbc-postgresql-${PV}* )
+ sqlite? ( =dev-haskell/hdbc-sqlite-${PV}* )"
+
+S="${WORKDIR}/${PN}"