summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2007-10-29 06:51:08 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2007-10-29 06:51:08 +0000
commit64f7d1af6d8a4dbdb4af9f11a284c7309297767b (patch)
tree9ab0ac44831eafe0555c36761dafd46da69a2dce /dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild
parent(#197154, fd.o #12982) xorg-server thinks net-dialup/dtrace is Solaris dtrace... (diff)
downloadhistorical-64f7d1af6d8a4dbdb4af9f11a284c7309297767b.tar.gz
historical-64f7d1af6d8a4dbdb4af9f11a284c7309297767b.tar.bz2
historical-64f7d1af6d8a4dbdb4af9f11a284c7309297767b.zip
Fix for recent glib that changes the type of the gtype typedef
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild')
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild
index b7320d9e58d2..509c4d60ddd6 100644
--- a/dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild
+++ b/dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild,v 1.2 2007/10/12 08:41:45 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.12.ebuild,v 1.3 2007/10/29 06:51:08 araujo Exp $
inherit base eutils ghc-package multilib toolchain-funcs versionator
@@ -12,16 +12,16 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc glade gnome opengl firefox seamonkey profile xulrunner"
+IUSE="doc glade gnome opengl svg firefox seamonkey profile xulrunner"
RDEPEND=">=dev-lang/ghc-6.2
dev-haskell/mtl
>=x11-libs/gtk+-2
glade? ( >=gnome-base/libglade-2 )
gnome? ( >=gnome-base/libglade-2
- =x11-libs/gtksourceview-1*
- >=gnome-base/gconf-2
- >=gnome-base/librsvg-2.16 )
+ >=x11-libs/gtksourceview-0.6
+ >=gnome-base/gconf-2 )
+ svg? ( >=gnome-base/librsvg-2.16 )
opengl? ( x11-libs/gtkglext )
seamonkey? ( >=www-client/seamonkey-1.0.2 )
firefox? ( >=www-client/mozilla-firefox-1.0.4 )
@@ -29,6 +29,14 @@ RDEPEND=">=dev-lang/ghc-6.2
DEPEND="${RDEPEND}
doc? ( >=dev-haskell/haddock-0.8 )"
+src_unpack() {
+ unpack "${A}"
+
+ # Fix for recent glib that changes the type of the gtype typedef:
+ sed -i -e 's/(CULong)/(CULong, CUInt)/' \
+ "${S}/tools/hierarchyGen/Hierarchy.chs.template"
+}
+
src_compile() {
econf \
--enable-packager-mode \
@@ -38,7 +46,7 @@ src_compile() {
$(use glade || use gnome && echo --enable-libglade) \
$(use_enable gnome gconf) \
$(use_enable gnome sourceview) \
- $(use_enable gnome svg) \
+ $(use_enable svg svg) \
$(use_enable opengl opengl) \
$(use_enable seamonkey seamonkey) \
$(use_enable firefox firefox) \
@@ -85,8 +93,9 @@ src_install() {
"${D}/usr/$(get_libdir)/gtk2hs/glade.${pkgext}") \
$(use gnome && echo \
"${D}/usr/$(get_libdir)/gtk2hs/gconf.${pkgext}" \
- "${D}/usr/$(get_libdir)/gtk2hs/sourceview.${pkgext}" \
- "${D}/usr/$(get_libdir)/gtk2hs/svgcairo.${pkgext}") \
+ "${D}/usr/$(get_libdir)/gtk2hs/sourceview.${pkgext}" ) \
+ $(use svg && echo \
+ "${D}/usr/$(get_libdir)/gtk2hs/svgcairo.${pkgext}")
$(use opengl && echo \
"${D}/usr/$(get_libdir)/gtk2hs/gtkglext.${pkgext}") \
$(use seamonkey || use firefox || use xulrunner && echo \