summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2005-11-06 12:33:24 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2005-11-06 12:33:24 +0000
commit37db2687b8dd1378102dc1e4016560e8ccb4aaf9 (patch)
treeaae617bb8c05185b70f81f09937dff17d4f3ee71 /dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild
parentfix remote hole in linux-ftpd-ssl - security bug #111573 (diff)
downloadhistorical-37db2687b8dd1378102dc1e4016560e8ccb4aaf9.tar.gz
historical-37db2687b8dd1378102dc1e4016560e8ccb4aaf9.tar.bz2
historical-37db2687b8dd1378102dc1e4016560e8ccb4aaf9.zip
Fix generation of cairo GHCi lib.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild')
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild
index 35780f9aa9ec..503dec3816a4 100644
--- a/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild
+++ b/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild,v 1.1 2005/11/05 16:20:37 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild,v 1.2 2005/11/06 12:33:24 dcoutts Exp $
inherit base ghc-package multilib
@@ -84,7 +84,7 @@ src_install() {
# build ghci .o files from .a files
ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSglib.a"
- if use cairo; then
+ if has_version '>=x11-libs/gtk+-2.8'; then
ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHScairo.a"
fi
ghc-makeghcilib "${D}/usr/$(get_libdir)/gtk2hs/libHSgtk.a"