summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-13 01:13:06 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-13 01:13:06 +0000
commite02e6a753af6a147169064b654f78ee020da0f10 (patch)
treed161a956b0e71af7cd2f48b23f0dbaabb6fbf495 /dev-games
parentVersion bump #77655 by Dennis Schridde. (diff)
downloadhistorical-e02e6a753af6a147169064b654f78ee020da0f10.tar.gz
historical-e02e6a753af6a147169064b654f78ee020da0f10.tar.bz2
historical-e02e6a753af6a147169064b654f78ee020da0f10.zip
only use my asm code on x86 #77706
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ode/Manifest8
-rw-r--r--dev-games/ode/files/0.5-PIC.patch14
2 files changed, 12 insertions, 10 deletions
diff --git a/dev-games/ode/Manifest b/dev-games/ode/Manifest
index 36a5cb4b97b4..7fc31749d573 100644
--- a/dev-games/ode/Manifest
+++ b/dev-games/ode/Manifest
@@ -5,11 +5,11 @@ MD5 d4315ba10979b6441acb5455fe97dbe4 ChangeLog 2488
MD5 897a7d200c1e7b0159d465d3220c9eff metadata.xml 509
MD5 140f4ebb7664313fdc0c27e00cb26844 ode-0.5-r2.ebuild 1711
MD5 24a10f16623003a6f4c8df5d8a0c11f5 files/digest-ode-0.5-r2 57
-MD5 e220c14da604140bcfe43dc34832b10e files/0.5-PIC.patch 450
+MD5 05d1eafa8377f72052f3e5c7eb6fe88c files/0.5-PIC.patch 516
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.14 (GNU/Linux)
-iD8DBQFB33V8roRuSHgZdywRAiecAJ99EtLJqMh1IxRpZxpNHDGf4nQgEACeMSWi
-r4nkNmRXTI7igzyWWrW/44w=
-=FOdg
+iD8DBQFB5ctAroRuSHgZdywRAhyfAKCUL75qA8/GGrsLllEtJRUYeuLFYwCeKsga
+3Zl47Rk+uoIENORqZq+BJDg=
+=6B71
-----END PGP SIGNATURE-----
diff --git a/dev-games/ode/files/0.5-PIC.patch b/dev-games/ode/files/0.5-PIC.patch
index b4fb9aaaa692..8255d34f2cc1 100644
--- a/dev-games/ode/files/0.5-PIC.patch
+++ b/dev-games/ode/files/0.5-PIC.patch
@@ -4,15 +4,17 @@ http://bugs.gentoo.org/show_bug.cgi?id=77079
--- ode-0.5/ode/src/timer.cpp.orig 2005-01-08 00:42:12.799324632 -0500
+++ ode-0.5/ode/src/timer.cpp 2005-01-08 00:42:38.347440728 -0500
-@@ -118,8 +118,10 @@
+@@ -118,6 +118,13 @@
{
asm volatile (
- "mov $0,%%eax\n"
++#if defined(__i386__) && defined(__PIC__)
+ "pushl %%ebx\n"
- "cpuid\n"
-- : : : "%eax","%ebx","%ecx","%edx","cc","memory");
++ "cpuid\n"
+ "popl %%ebx\n"
+ : : : "%eax","%ecx","%edx","cc","memory");
++#else
+ "mov $0,%%eax\n"
+ "cpuid\n"
+ : : : "%eax","%ebx","%ecx","%edx","cc","memory");
++#endif
}
-
-