summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-23 17:01:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-23 17:01:47 +0000
commit6241282d1d716091552c733633f60541013172e4 (patch)
tree81502928f0950892da728b05a467cc2dd69102f1 /dev-games
parentAdded support for the "emboss" and "minimal" "USE" flags. (diff)
downloadhistorical-6241282d1d716091552c733633f60541013172e4.tar.gz
historical-6241282d1d716091552c733633f60541013172e4.tar.bz2
historical-6241282d1d716091552c733633f60541013172e4.zip
fix patch name
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/Manifest2
-rw-r--r--dev-games/crystalspace/crystalspace-0.98.4.ebuild11
2 files changed, 6 insertions, 7 deletions
diff --git a/dev-games/crystalspace/Manifest b/dev-games/crystalspace/Manifest
index 3816bb0bf6d8..7ba9602b21ca 100644
--- a/dev-games/crystalspace/Manifest
+++ b/dev-games/crystalspace/Manifest
@@ -1,5 +1,5 @@
MD5 ee57a512766bae0dfcf88452136cc05f ChangeLog 1833
MD5 e4c7a49ca08eb200cfa0a9f9246e2257 metadata.xml 959
-MD5 1c90ebf5799e46f6eb8770407a6235b9 crystalspace-0.98.4.ebuild 1824
+MD5 518dc79b41c9eb6e71428c8b0c1a16e6 crystalspace-0.98.4.ebuild 1812
MD5 0e0e7b896ce777aa3f4d85f5a48feb25 files/crystalspace-0.98.4-gl.patch 10651
MD5 bec0edb0863c282510494dc014bbf750 files/digest-crystalspace-0.98.4 63
diff --git a/dev-games/crystalspace/crystalspace-0.98.4.ebuild b/dev-games/crystalspace/crystalspace-0.98.4.ebuild
index 7fe886c0f025..aa7c3a0a2ce7 100644
--- a/dev-games/crystalspace/crystalspace-0.98.4.ebuild
+++ b/dev-games/crystalspace/crystalspace-0.98.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.98.4.ebuild,v 1.7 2005/01/07 02:04:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.98.4.ebuild,v 1.8 2005/02/23 17:01:47 mr_bones_ Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/crystal/${MY_P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="ppc x86"
-IUSE="oggvorbis mikmod openal truetype 3ds mng"
+IUSE="3ds mikmod mng oggvorbis openal truetype"
RDEPEND="sys-libs/zlib
>=media-libs/libpng-1.2.1
@@ -38,8 +38,9 @@ CRYSTAL_PREFIX="/opt/crystal"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gl.patch #75702
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gl.patch" #75702
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
}
src_compile() {
@@ -62,7 +63,5 @@ src_install() {
find "${D}"/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
chmod a+rx "${D}"/${CRYSTAL_PREFIX}/bin/*
- dodir /etc/env.d
- echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
doenvd 90crystalspace
}