summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-09-13 23:04:45 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-09-13 23:04:45 +0000
commit7ea8ec4150e8c8b1208039470e60f90f849ab939 (patch)
treef1bbe8a69b9e32a906d41f108de853f4230c8463 /dev-games/clanlib
parentMark 2.14.0 stable on ia64. #139612 (diff)
downloadhistorical-7ea8ec4150e8c8b1208039470e60f90f849ab939.tar.gz
historical-7ea8ec4150e8c8b1208039470e60f90f849ab939.tar.bz2
historical-7ea8ec4150e8c8b1208039470e60f90f849ab939.zip
Fixing segfaults after few seconds of driving, Bug #100987
Package-Manager: portage-2.1.1
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog8
-rw-r--r--dev-games/clanlib/clanlib-0.6.5-r4.ebuild100
-rw-r--r--dev-games/clanlib/files/clanlib-0.6.5-bounds.patch11
-rw-r--r--dev-games/clanlib/files/digest-clanlib-0.6.5-r43
4 files changed, 121 insertions, 1 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 7872dc921fe7..9bf92d6ad51c 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/clanlib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.35 2006/09/12 22:33:43 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.36 2006/09/13 23:04:45 tupone Exp $
+
+*clanlib-0.6.5-r4 (13 Sep 2006)
+
+ 13 Sep 2006; <tupone@gentoo.org> +files/clanlib-0.6.5-bounds.patch,
+ -clanlib-0.6.5-r3.ebuild, +clanlib-0.6.5-r4.ebuild:
+ Fixing segfaults after few seconds of driving, Bug #100987 by Frank Weinberg
12 Sep 2006; <tupone@gentoo.org> +files/clanlib-0.6.5-64bit.patch,
clanlib-0.6.5-r3.ebuild:
diff --git a/dev-games/clanlib/clanlib-0.6.5-r4.ebuild b/dev-games/clanlib/clanlib-0.6.5-r4.ebuild
new file mode 100644
index 000000000000..68daada0df0c
--- /dev/null
+++ b/dev-games/clanlib/clanlib-0.6.5-r4.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.6.5-r4.ebuild,v 1.1 2006/09/13 23:04:45 tupone Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://www.clanlib.org/download/legacy/ClanLib-${PV}-1.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0.6"
+KEYWORDS="amd64 x86" #not big endian safe #82779
+IUSE="arts oss esd alsa png opengl truetype X vorbis mikmod jpeg directfb joystick"
+
+DEPEND=">=media-libs/hermes-1.3.2
+ X? (
+ || (
+ ( media-libs/mesa
+ x11-libs/libXt
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto )
+ virtual/x11
+ )
+ )
+ png? ( media-libs/libpng )
+ jpeg? ( >=media-libs/jpeg-6b )
+ mikmod? ( >=media-libs/libmikmod-3.1.9 )
+ truetype? ( >=media-libs/freetype-2.0 )
+ directfb? ( dev-libs/DirectFB )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}
+ || (
+ ( media-libs/mesa
+ x11-libs/libXmu
+ x11-libs/libXxf86vm )
+ virtual/x11
+ )"
+
+S=${WORKDIR}/ClanLib-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc3.patch
+ epatch "${FILESDIR}"/${P}-DirectFB-update.patch
+ epatch "${FILESDIR}"/${P}-freetype.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-uclibc.patch
+ epatch "${FILESDIR}"/${P}-{64bit,bounds}.patch
+ sed -i 's:@comp_mode@::' Setup/Unix/clanlib-config.in
+}
+
+src_compile() {
+ local myconf=""
+
+ replace-flags -O? -O2
+
+ use jpeg || myconf="${myconf} --enable-smalljpeg"
+ use alsa || use oss || use esd || use arts \
+ && myconf="${myconf} --enable-clansound" \
+ || myconf="${myconf} --disable-clansound"
+
+ econf \
+ --libdir=/usr/$(get_libdir)/${P} \
+ --includedir=/usr/include/${P} \
+ --enable-network \
+ $(use_enable x86 asm386) \
+ --disable-lua \
+ --enable-dyn \
+ $(use_enable X x11) \
+ $(use_enable directfb) \
+ $(use_enable opengl) \
+ $(use_enable vorbis) \
+ $(use_enable png) \
+ $(use_enable truetype ttf) \
+ $(use_enable mikmod) \
+ $(use_enable joystick) \
+ --enable-vidmode \
+ ${myconf} || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install \
+ prefix="${D}"/usr \
+ LIB_PREFIX="${D}"/usr/$(get_libdir)/${P} \
+ INC_PREFIX="${D}"/usr/include/${P} \
+ || die "make install failed"
+ mv "${D}"/usr/bin/clanlib{,0.6}-config
+ dodoc BUGS CODING_STYLE HARDWARE NEWS PATCHES PORTING README* ROADMAP INSTALL.linux
+
+ # setup links for runtime
+ cd "${D}"/usr/$(get_libdir)
+ local l
+ for l in ${P}/*.2 ; do
+ ln -s ${l}
+ done
+}
diff --git a/dev-games/clanlib/files/clanlib-0.6.5-bounds.patch b/dev-games/clanlib/files/clanlib-0.6.5-bounds.patch
new file mode 100644
index 000000000000..c58df4c58cdd
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.6.5-bounds.patch
@@ -0,0 +1,11 @@
+--- Sources/Display/Display/Generic/blit_transparent.cpp.old 2006-09-14 00:48:06.000000000 +0200
++++ Sources/Display/Display/Generic/blit_transparent.cpp 2006-09-14 00:49:16.000000000 +0200
+@@ -278,6 +278,8 @@
+ unsigned int dest_pitch = target->get_pitch();
+
+ unsigned char *dest = (unsigned char *) target->get_data();
++ if (y == 0)
++ y = 1;
+ dest += x*sizeof(T) + (y-1)*dest_pitch;
+
+ // T *dd;
diff --git a/dev-games/clanlib/files/digest-clanlib-0.6.5-r4 b/dev-games/clanlib/files/digest-clanlib-0.6.5-r4
new file mode 100644
index 000000000000..343d6f06c6c9
--- /dev/null
+++ b/dev-games/clanlib/files/digest-clanlib-0.6.5-r4
@@ -0,0 +1,3 @@
+MD5 7115921953ef6fa45102c28622493650 ClanLib-0.6.5-1.tar.gz 2183097
+RMD160 31f060f438925c9ec7dd2a9466ed6bb367549b3b ClanLib-0.6.5-1.tar.gz 2183097
+SHA256 62e16913423945475f3541fc97deaeb9b0f735b6c93c88725a6a771d5a882db5 ClanLib-0.6.5-1.tar.gz 2183097