summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-01-22 19:44:21 +0000
committerTim Harder <radhermit@gentoo.org>2012-01-22 19:44:21 +0000
commit31bf095e114dce9d96baa0d419b150cf4bd78095 (patch)
tree15431a9d4a95e6a0d2f805dbe29d4b0c0475b086 /dev-embedded
parentVersion bump. Migrate to EAPI4 (diff)
downloadhistorical-31bf095e114dce9d96baa0d419b150cf4bd78095.tar.gz
historical-31bf095e114dce9d96baa0d419b150cf4bd78095.tar.bz2
historical-31bf095e114dce9d96baa0d419b150cf4bd78095.zip
Version bump.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/msp430-binutils/ChangeLog10
-rw-r--r--dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120119.ebuild22
-rw-r--r--dev-embedded/msp430-gcc/ChangeLog10
-rw-r--r--dev-embedded/msp430-gcc/msp430-gcc-4.6.1_p20120119.ebuild28
4 files changed, 66 insertions, 4 deletions
diff --git a/dev-embedded/msp430-binutils/ChangeLog b/dev-embedded/msp430-binutils/ChangeLog
index dead4557c0d7..a0a6aa214bfa 100644
--- a/dev-embedded/msp430-binutils/ChangeLog
+++ b/dev-embedded/msp430-binutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/msp430-binutils
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/ChangeLog,v 1.4 2011/12/21 22:06:32 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/ChangeLog,v 1.5 2012/01/22 19:40:13 radhermit Exp $
+
+*msp430-binutils-2.21.1_p20120119 (22 Jan 2012)
+
+ 22 Jan 2012; Tim Harder <radhermit@gentoo.org>
+ +msp430-binutils-2.21.1_p20120119.ebuild:
+ Version bump.
21 Dec 2011; Tim Harder <radhermit@gentoo.org>
msp430-binutils-2.21.1_p20111205.ebuild:
diff --git a/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120119.ebuild b/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120119.ebuild
new file mode 100644
index 000000000000..959832ff6492
--- /dev/null
+++ b/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120119.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120119.ebuild,v 1.1 2012/01/22 19:40:13 radhermit Exp $
+
+PATCHVER="1.4"
+
+BINUTILS_VER=${PV%_p*}
+
+inherit toolchain-binutils
+
+DESCRIPTION="Tools necessary to build programs for MSP430 microcontrollers"
+SRC_URI+=" http://dev.gentoo.org/~radhermit/distfiles/${P}.patch.bz2"
+
+KEYWORDS="~amd64 ~x86"
+
+pkg_setup() {
+ is_cross || die "Only cross-compile builds are supported"
+}
+
+PATCHES=(
+ "${WORKDIR}"/${P}.patch
+)
diff --git a/dev-embedded/msp430-gcc/ChangeLog b/dev-embedded/msp430-gcc/ChangeLog
index 45671775763f..2696a1dd7053 100644
--- a/dev-embedded/msp430-gcc/ChangeLog
+++ b/dev-embedded/msp430-gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/msp430-gcc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-gcc/ChangeLog,v 1.2 2011/12/25 07:24:44 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-gcc/ChangeLog,v 1.3 2012/01/22 19:44:21 radhermit Exp $
+
+*msp430-gcc-4.6.1_p20120119 (22 Jan 2012)
+
+ 22 Jan 2012; Tim Harder <radhermit@gentoo.org>
+ +msp430-gcc-4.6.1_p20120119.ebuild:
+ Version bump.
*msp430-gcc-4.6.1_p20111224 (25 Dec 2011)
diff --git a/dev-embedded/msp430-gcc/msp430-gcc-4.6.1_p20120119.ebuild b/dev-embedded/msp430-gcc/msp430-gcc-4.6.1_p20120119.ebuild
new file mode 100644
index 000000000000..75f8a74a9418
--- /dev/null
+++ b/dev-embedded/msp430-gcc/msp430-gcc-4.6.1_p20120119.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-gcc/msp430-gcc-4.6.1_p20120119.ebuild,v 1.1 2012/01/22 19:44:21 radhermit Exp $
+
+EAPI="4"
+
+PATCH_VER="1.0"
+BRANCH_UPDATE=""
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection for MSP430 microcontrollers"
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="${SRC_URI} http://dev.gentoo.org/~radhermit/distfiles/${P}.patch.bz2"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ ${CATEGORY}/msp430-binutils"
+
+pkg_pretend() {
+ is_crosscompile || die "Only cross-compile builds are supported"
+}
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}.patch.bz2
+}