summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2008-05-31 12:39:35 +0000
committerJurek Bartuszek <jurek@gentoo.org>2008-05-31 12:39:35 +0000
commitb193679ea6789af02b7cc88a87a3cbc8f846c1d0 (patch)
tree8b29e8f7eede3aaf5048de1768a229f6c1414879 /dev-dotnet
parentFix bug #224243. (diff)
downloadhistorical-b193679ea6789af02b7cc88a87a3cbc8f846c1d0.tar.gz
historical-b193679ea6789af02b7cc88a87a3cbc8f846c1d0.tar.bz2
historical-b193679ea6789af02b7cc88a87a3cbc8f846c1d0.zip
dev-dotnet/xsp: version bump (bug #213381)
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/xsp/ChangeLog13
-rw-r--r--dev-dotnet/xsp/xsp-1.9.1.ebuild70
-rw-r--r--dev-dotnet/xsp/xsp-1.9.ebuild70
3 files changed, 152 insertions, 1 deletions
diff --git a/dev-dotnet/xsp/ChangeLog b/dev-dotnet/xsp/ChangeLog
index c3f25082480d..99cee2b4601f 100644
--- a/dev-dotnet/xsp/ChangeLog
+++ b/dev-dotnet/xsp/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-dotnet/xsp
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.54 2008/05/30 22:51:22 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.55 2008/05/31 12:39:35 jurek Exp $
+
+*xsp-1.9.1 (31 May 2008)
+*xsp-1.9 (31 May 2008)
+
+ 31 May 2008; Jurek Bartuszek <jurek@gentoo.org>
+ +files/1.9.1/mod-mono-server.confd, +files/1.9.1/mod-mono-server.initd,
+ +files/1.9.1/xsp.confd, +files/1.9.1/xsp.initd,
+ +files/1.9/mod-mono-server.confd, +files/1.9/xsp.confd,
+ +files/1.9/mod-mono-server.initd, +files/1.9/xsp.initd, +xsp-1.9.ebuild,
+ +xsp-1.9.1.ebuild:
+ Version bump (bug #213381)
30 May 2008; Jurek Bartuszek <jurek@gentoo.org> xsp-1.2.1.ebuild,
xsp-1.2.3.ebuild, xsp-1.2.4.ebuild, xsp-1.2.4-r1.ebuild, xsp-1.2.5.ebuild:
diff --git a/dev-dotnet/xsp/xsp-1.9.1.ebuild b/dev-dotnet/xsp/xsp-1.9.1.ebuild
new file mode 100644
index 000000000000..20df2cc86d6c
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-1.9.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-1.9.1.ebuild,v 1.1 2008/05/31 12:39:35 jurek Exp $
+
+inherit mono multilib autotools eutils
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-${PV}
+ =dev-db/sqlite-3*"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+pkg_preinst() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
+ -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
+ "${S}"/test/2.0/treeview/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake -j1 || {
+ echo
+ eerror "If xsp fails to build, try unmerging and re-emerging it."
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" \
+ "${D}"/usr/bin/xsp{,2} \
+ "${D}"/usr/bin/mod-mono-server{,2} \
+ "${D}"/usr/bin/asp-state{,2} \
+ "${D}"/usr/bin/dbsessmgr{,2} \
+ || die
+
+ newinitd "${FILESDIR}"/${PV}/xsp.initd xsp
+ newinitd "${FILESDIR}"/${PV}/mod-mono-server.initd mod-mono-server
+ newconfd "${FILESDIR}"/${PV}/xsp.confd xsp
+ newconfd "${FILESDIR}"/${PV}/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}
diff --git a/dev-dotnet/xsp/xsp-1.9.ebuild b/dev-dotnet/xsp/xsp-1.9.ebuild
new file mode 100644
index 000000000000..2baed4619892
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-1.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-1.9.ebuild,v 1.1 2008/05/31 12:39:35 jurek Exp $
+
+inherit mono multilib autotools eutils
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-${PV}
+ =dev-db/sqlite-3*"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+pkg_preinst() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
+ -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
+ "${S}"/test/2.0/treeview/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake -j1 || {
+ echo
+ eerror "If xsp fails to build, try unmerging and re-emerging it."
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ sed -i -e "s#/usr/lib/#/usr/$(get_libdir)/#" \
+ "${D}"/usr/bin/xsp{,2} \
+ "${D}"/usr/bin/mod-mono-server{,2} \
+ "${D}"/usr/bin/asp-state{,2} \
+ "${D}"/usr/bin/dbsessmgr{,2} \
+ || die
+
+ newinitd "${FILESDIR}"/${PV}/xsp.initd xsp
+ newinitd "${FILESDIR}"/${PV}/mod-mono-server.initd mod-mono-server
+ newconfd "${FILESDIR}"/${PV}/xsp.confd xsp
+ newconfd "${FILESDIR}"/${PV}/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}