summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Tindal <urilith@gentoo.org>2005-04-02 18:36:42 +0000
committerMichael Tindal <urilith@gentoo.org>2005-04-02 18:36:42 +0000
commit2f46ed6cde6129753b3381831009284a845af9c4 (patch)
tree409d6c5bab9a75c7d3f4790f2b174a74b88bc57c /dev-dotnet
parentMask the new muine which deps on masked *-sharp ebuilds. (diff)
downloadhistorical-2f46ed6cde6129753b3381831009284a845af9c4.tar.gz
historical-2f46ed6cde6129753b3381831009284a845af9c4.tar.bz2
historical-2f46ed6cde6129753b3381831009284a845af9c4.zip
Adding ebuild for NDoc.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/ndoc/ChangeLog9
-rw-r--r--dev-dotnet/ndoc/Manifest4
-rw-r--r--dev-dotnet/ndoc/files/digest-ndoc-1.3.11
-rw-r--r--dev-dotnet/ndoc/metadata.xml10
-rw-r--r--dev-dotnet/ndoc/ndoc-1.3.1.ebuild51
5 files changed, 75 insertions, 0 deletions
diff --git a/dev-dotnet/ndoc/ChangeLog b/dev-dotnet/ndoc/ChangeLog
new file mode 100644
index 000000000000..52c052515aa0
--- /dev/null
+++ b/dev-dotnet/ndoc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-dotnet/ndoc
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ndoc/ChangeLog,v 1.1 2005/04/02 18:36:42 urilith Exp $
+
+*ndoc-1.3.1 (02 Apr 2005)
+
+ 02 Apr 2005; <urilith@gentoo.org> +metadata.xml, +ndoc-1.3.1.ebuild:
+ New ebuild for NDoc.
+
diff --git a/dev-dotnet/ndoc/Manifest b/dev-dotnet/ndoc/Manifest
new file mode 100644
index 000000000000..4227bf03ed8a
--- /dev/null
+++ b/dev-dotnet/ndoc/Manifest
@@ -0,0 +1,4 @@
+MD5 d48ccae9f56bec1901c42b8bf98bbfa3 ndoc-1.3.1.ebuild 1288
+MD5 19df3aee6ec53654d050d0cb0cbaec8d ChangeLog 326
+MD5 443435c45ff66780ef8a6d478be74f1c metadata.xml 256
+MD5 366ef05b58498d63fc6125c49e269c24 files/digest-ndoc-1.3.1 67
diff --git a/dev-dotnet/ndoc/files/digest-ndoc-1.3.1 b/dev-dotnet/ndoc/files/digest-ndoc-1.3.1
new file mode 100644
index 000000000000..b0adff51c54f
--- /dev/null
+++ b/dev-dotnet/ndoc/files/digest-ndoc-1.3.1
@@ -0,0 +1 @@
+MD5 8950a53dd3c379e41781ba7f1834e948 ndoc-devel-v1.3.1.zip 3896669
diff --git a/dev-dotnet/ndoc/metadata.xml b/dev-dotnet/ndoc/metadata.xml
new file mode 100644
index 000000000000..9234eb1c54c5
--- /dev/null
+++ b/dev-dotnet/ndoc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <maintainer>
+ <email>urilith@gentoo.org</email>
+ <name>Michael Tindal</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-dotnet/ndoc/ndoc-1.3.1.ebuild b/dev-dotnet/ndoc/ndoc-1.3.1.ebuild
new file mode 100644
index 000000000000..1430d63b5f76
--- /dev/null
+++ b/dev-dotnet/ndoc/ndoc-1.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ndoc/ndoc-1.3.1.ebuild,v 1.1 2005/04/02 18:36:42 urilith Exp $
+
+inherit mono
+
+DESCRIPTION=".NET Documentation Tool"
+HOMEPAGE="http://ndoc.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/${PN}/${PN}-devel-v${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="debug"
+DEPEND=">=dev-lang/mono-1.0
+ >=dev-dotnet/nant-0.85_rc2"
+RDEPEND=">=dev-lang/mono-1.0"
+
+S=${WORKDIR}
+
+src_compile() {
+ nant -t:mono-1.0 || die
+}
+
+GAC_FILES="NDoc.Core.dll NDoc.Documenter.JavaDoc.dll NDoc.Documenter.Latex.dll NDoc.Documenter.LinearHtml.dll NDoc.Documenter.Msdn.dll NDoc.Documenter.Msdn2.dll NDoc.Documenter.Xml.dll NDoc.ExtendedUI.dll NDoc.VisualStudio.dll"
+
+src_install() {
+ cd ${S}/bin/mono/1.0
+
+ # This installs all of the dll files under the specified gac package
+ # directory.
+ for dll in $GAC_FILES; do
+ gacutil -i $dll -package ndoc -root ${D}/usr/lib || die "Failed to install DLL into the Global Assembly Cache."
+ done
+
+ DEBUG_VAR=""
+
+ use debug && DEBUG_VAR="--debug"
+
+ cat > ndoc <<- EOF
+ #!/bin/bash
+
+ mono $DEBUG_VAR /usr/share/ndoc/NDocConsole.exe "\$@"
+ EOF
+
+ insinto ${D}/usr/share/ndoc/
+ doins NDocConsole.exe
+ dobin ndoc
+}