summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-24 05:09:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-24 05:09:12 +0000
commit7c95f3c7e34778d254947e4e9432adb5a49e67f9 (patch)
treee721debf104634496382af55746834eb3048ac4f /dev-db
parentUSE flag change qt->qt3/qt4 bug #137785 (diff)
downloadhistorical-7c95f3c7e34778d254947e4e9432adb5a49e67f9.tar.gz
historical-7c95f3c7e34778d254947e4e9432adb5a49e67f9.tar.bz2
historical-7c95f3c7e34778d254947e4e9432adb5a49e67f9.zip
USE flag change qt->qt3/qt4 bug #137785
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libodbc++/ChangeLog6
-rw-r--r--dev-db/libodbc++/libodbc++-0.2.3-r1.ebuild8
-rw-r--r--dev-db/libodbc++/libodbc++-0.2.3.ebuild12
3 files changed, 15 insertions, 11 deletions
diff --git a/dev-db/libodbc++/ChangeLog b/dev-db/libodbc++/ChangeLog
index 0103103eb710..509b1f968032 100644
--- a/dev-db/libodbc++/ChangeLog
+++ b/dev-db/libodbc++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/libodbc++
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/ChangeLog,v 1.8 2006/04/14 00:07:27 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/ChangeLog,v 1.9 2006/06/24 05:09:12 cardoe Exp $
+
+ 24 Jun 2006; Doug Goldstein <cardoe@gentoo.org> libodbc++-0.2.3.ebuild,
+ libodbc++-0.2.3-r1.ebuild:
+ USE flag change qt->qt3/qt4 bug #137785
14 Apr 2006; Mark Loeser <halcy0n@gentoo.org>
+files/libodbc++-0.2.3-doxygen.patch, +files/libodbc++-0.2.3-gcc41.patch,
diff --git a/dev-db/libodbc++/libodbc++-0.2.3-r1.ebuild b/dev-db/libodbc++/libodbc++-0.2.3-r1.ebuild
index d367508f27f7..5b681a2ac539 100644
--- a/dev-db/libodbc++/libodbc++-0.2.3-r1.ebuild
+++ b/dev-db/libodbc++/libodbc++-0.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/libodbc++-0.2.3-r1.ebuild,v 1.3 2006/04/14 00:07:27 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/libodbc++-0.2.3-r1.ebuild,v 1.4 2006/06/24 05:09:12 cardoe Exp $
inherit eutils
@@ -11,7 +11,7 @@ LICENSE="LGPL-2.1"
DEPEND="dev-db/unixODBC
sys-libs/libtermcap-compat"
KEYWORDS="~x86 ~ppc ~hppa ~alpha ~amd64"
-IUSE="qt"
+IUSE="qt3"
SLOT=0
SB="${S}-build"
@@ -39,7 +39,7 @@ src_compile() {
append-flags -DODBCXX_DISABLE_READLINE_HACK
buildlist="${SB} ${SB_MT}"
- use qt && buildlist="${buildlist} $SB_QT $SB_QT_MT"
+ use qt3 && buildlist="${buildlist} $SB_QT $SB_QT_MT"
for sd in ${buildlist}; do
mkdir -p "${sd}"
@@ -66,7 +66,7 @@ src_install () {
dodoc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README THANKS TODO
buildlist="${SB} ${SB_MT}"
- use qt && buildlist="${buildlist} $SB_QT $SB_QT_MT"
+ use qt3 && buildlist="${buildlist} $SB_QT $SB_QT_MT"
for sd in ${buildlist}; do
cd ${sd}
make DESTDIR=${D} install || die "make install failed"
diff --git a/dev-db/libodbc++/libodbc++-0.2.3.ebuild b/dev-db/libodbc++/libodbc++-0.2.3.ebuild
index b49734c08cfd..c2734feb6269 100644
--- a/dev-db/libodbc++/libodbc++-0.2.3.ebuild
+++ b/dev-db/libodbc++/libodbc++-0.2.3.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/libodbc++-0.2.3.ebuild,v 1.5 2005/01/01 17:35:37 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libodbc++/libodbc++-0.2.3.ebuild,v 1.6 2006/06/24 05:09:12 cardoe Exp $
DESCRIPTION="Libodbc++ is a c++ class library that provides a subset of the well-known JDBC 2.0(tm) and runs on top of ODBC."
SRC_URI="mirror://sourceforge/libodbcxx/${P}.tar.gz"
HOMEPAGE="http://libodbcxx.sourceforge.net/"
LICENSE="LGPL-2.1"
DEPEND="dev-db/unixODBC"
KEYWORDS="~x86 ~ppc ~hppa ~alpha amd64"
-IUSE="qt"
+IUSE="qt3"
SLOT=0
src_compile() {
@@ -16,7 +16,7 @@ src_compile() {
commonconf="${commonconf} --enable-static --enable-shared"
# " --enable-threads"
- if use qt; then
+ if use qt3; then
einfo "Cloning to build with qt"
einfo "ccache would really help you compiling this package..."
cp -ra ${S} ${S}_qt
@@ -29,7 +29,7 @@ src_compile() {
# using without-qt breaks the build
#--without-qt \
- if use qt; then
+ if use qt3; then
cd ${S}_qt
econf \
${commonconf} \
@@ -43,7 +43,7 @@ src_compile() {
src_install () {
make DESTDIR=${D} install || die "make install failed"
dodoc AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README THANKS TODO
- if use qt; then
+ if use qt3; then
cd ${S}_qt
make DESTDIR=${D} install || die "make install failed"
fi