summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-09-09 22:28:44 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-09-09 22:28:44 +0000
commitedd483c854116ee4871a49afbaea94b210aa7ca6 (patch)
tree5bcb7b04706bb6ac9043b9fce73e966a1f64d195 /dev-db/mysqltool
parentThese are syntax fixes for the new perl eclass. The new perl eclass uses a co... (diff)
downloadhistorical-edd483c854116ee4871a49afbaea94b210aa7ca6.tar.gz
historical-edd483c854116ee4871a49afbaea94b210aa7ca6.tar.bz2
historical-edd483c854116ee4871a49afbaea94b210aa7ca6.zip
Corrected ebuild to use perl-module eclass
Diffstat (limited to 'dev-db/mysqltool')
-rw-r--r--dev-db/mysqltool/ChangeLog6
-rw-r--r--dev-db/mysqltool/mysqltool-0.95-r1.ebuild17
2 files changed, 9 insertions, 14 deletions
diff --git a/dev-db/mysqltool/ChangeLog b/dev-db/mysqltool/ChangeLog
index bfc0e94bd4af..37e69278ba21 100644
--- a/dev-db/mysqltool/ChangeLog
+++ b/dev-db/mysqltool/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-db/mysqltool
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/ChangeLog,v 1.2 2002/05/04 01:58:36 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/ChangeLog,v 1.3 2002/09/09 22:28:44 mcummings Exp $
*mysqltool-0.95-r1 (3 May 2002)
+ 9 Sep 2002; <mcummings@gentoo.org> :
+
+ Added perl-module eclass support properly.
+
3 May 2002; Donny Davies <woodchip@gentoo.org> :
Added LICENSE, SLOT.
diff --git a/dev-db/mysqltool/mysqltool-0.95-r1.ebuild b/dev-db/mysqltool/mysqltool-0.95-r1.ebuild
index 66799c2ed841..7ea06e59d7ec 100644
--- a/dev-db/mysqltool/mysqltool-0.95-r1.ebuild
+++ b/dev-db/mysqltool/mysqltool-0.95-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95-r1.ebuild,v 1.2 2002/07/23 03:08:12 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95-r1.ebuild,v 1.3 2002/09/09 22:28:44 mcummings Exp $
+
+inherit perl-module
S=${WORKDIR}/MysqlTool-${PV}
DESCRIPTION="Web interface for managing one or more mysql server installations"
@@ -14,22 +16,11 @@ KEYWORDS="x86"
RDEPEND="${DEPEND} >=net-www/apache-1.3.24-r1 >=dev-db/mysql-3.23.38
dev-perl/CGI dev-perl/DBI dev-perl/DBD-mysql dev-perl/Crypt-Blowfish"
-src_compile() {
- perl Makefile.PL || die
- make || die
- make test || die
-}
-
src_install() {
eval `perl '-V:installarchlib'`
mkdir -p ${D}/$installarchlib
- perl Makefile.PL
- make \
- PREFIX=${D}/usr \
- INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- INSTALLMAN1DIR=${D}/usr/share/man/man1 \
- install || die
+ make install || die
dodoc COPYING Changes MANIFEST README Upgrade