summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-03 16:04:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-03 16:04:44 +0000
commit7258d110e84fc59ecebbbc5f9bbe28dc15b85344 (patch)
treec63d8160a2077539f932522f8c7635b9b9984fc7 /dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
parentVersion bump. (diff)
downloadhistorical-7258d110e84fc59ecebbbc5f9bbe28dc15b85344.tar.gz
historical-7258d110e84fc59ecebbbc5f9bbe28dc15b85344.tar.bz2
historical-7258d110e84fc59ecebbbc5f9bbe28dc15b85344.zip
Respect USE="gnutls".
Package-Manager: portage-13599-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
index 9b2fca999b6f..c621ef960f68 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild,v 1.2 2009/03/09 04:21:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild,v 1.3 2009/05/03 16:04:44 arfrever Exp $
inherit eutils autotools
@@ -35,12 +35,16 @@ src_compile() {
sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
local myconf
- use gnutls || myconf="--with-openssl"
+ if use gnutls; then
+ myconf="--with-gnutls --without-openssl"
+ else
+ myconf="--without-gnutls --with-openssl"
+ fi
econf \
$(use_enable debug) \
$(use_with ipv6 ) \
- ${myconf} || die "econf failed"
+ ${myconf}
emake -j1 || die "emake failed"
}