summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-09-02 17:14:03 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-09-02 17:14:03 +0000
commit017961bd4e5b41972795535807d04d95b2c53878 (patch)
treeb6c906b07754a7bb38ea3f3ec67c9a9832f49062 /dev-cpp/bakery
parentCleanup of eautoreconf call to use the new style AT_M4DIR variable. Use at le... (diff)
downloadhistorical-017961bd4e5b41972795535807d04d95b2c53878.tar.gz
historical-017961bd4e5b41972795535807d04d95b2c53878.tar.bz2
historical-017961bd4e5b41972795535807d04d95b2c53878.zip
New Package. Bakery is a C++ Framework for creating GNOME applications using gtkmm
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-cpp/bakery')
-rw-r--r--dev-cpp/bakery/ChangeLog11
-rw-r--r--dev-cpp/bakery/Manifest14
-rw-r--r--dev-cpp/bakery/bakery-2.3.15.ebuild36
-rw-r--r--dev-cpp/bakery/files/digest-bakery-2.3.151
-rw-r--r--dev-cpp/bakery/metadata.xml18
5 files changed, 80 insertions, 0 deletions
diff --git a/dev-cpp/bakery/ChangeLog b/dev-cpp/bakery/ChangeLog
new file mode 100644
index 000000000000..b3d806fca222
--- /dev/null
+++ b/dev-cpp/bakery/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-cpp/bakery
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/bakery/ChangeLog,v 1.1 2005/09/02 17:14:03 metalgod Exp $
+
+*bakery-2.3.15 (02 Sep 2005)
+
+ 02 Sep 2005; Luis Medinas <metalgod@gentoo.org> +metadata.xml,
+ +bakery-2.3.15.ebuild:
+ New Package. Bakery is a C++ Framework for creating GNOME applications using
+ gtkmm.
+
diff --git a/dev-cpp/bakery/Manifest b/dev-cpp/bakery/Manifest
new file mode 100644
index 000000000000..ae249423b990
--- /dev/null
+++ b/dev-cpp/bakery/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 5d9e23035862ed0d6ff4ff861eea5746 bakery-2.3.15.ebuild 854
+MD5 f0496e6fea8e6c4d15da5d3ddb4760c7 metadata.xml 697
+MD5 c199cda44f1a415b86cfb14ab713d64b ChangeLog 412
+MD5 190fb0122aa33b579510399e5c267d74 files/digest-bakery-2.3.15 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDGJXkwUpWvClEHQoRAkqKAJ0Sxk7EIwORERgcG3Pk8FoMiEZMxwCeNJ4m
+1Zi1UIjkMlhn6hEQUVwJSDc=
+=mQY/
+-----END PGP SIGNATURE-----
diff --git a/dev-cpp/bakery/bakery-2.3.15.ebuild b/dev-cpp/bakery/bakery-2.3.15.ebuild
new file mode 100644
index 000000000000..c928ae1467fe
--- /dev/null
+++ b/dev-cpp/bakery/bakery-2.3.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/bakery/bakery-2.3.15.ebuild,v 1.1 2005/09/02 17:14:03 metalgod Exp $
+
+inherit gnome2
+
+DESCRIPTION="Bakery is a C++ Framework for creating GNOME applications using
+gtkmm."
+HOMEPAGE="http://bakery.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/gtkmm-2.2
+ >=dev-cpp/libxmlpp-1.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+ use doc && dohtml docs/*.html docs/reference/*.html
+}
diff --git a/dev-cpp/bakery/files/digest-bakery-2.3.15 b/dev-cpp/bakery/files/digest-bakery-2.3.15
new file mode 100644
index 000000000000..d5a407b26b39
--- /dev/null
+++ b/dev-cpp/bakery/files/digest-bakery-2.3.15
@@ -0,0 +1 @@
+MD5 f9e648167f514565f02cd81e37ad5f51 bakery-2.3.15.tar.bz2 346114
diff --git a/dev-cpp/bakery/metadata.xml b/dev-cpp/bakery/metadata.xml
new file mode 100644
index 000000000000..526050fff6ec
--- /dev/null
+++ b/dev-cpp/bakery/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-mm</herd>
+<maintainer>
+<email>metalgod@gentoo.org</email>
+<name>Luis Medinas</name>
+</maintainer>
+<longdescription lang="en">
+Bakery is a C++ Application Framework for use with gtkmm.This application
+provides a Document/View architecture but it doesn't force you to use the whole
+architecture, can use XML as a document storage format, it provides default
+functionality, which can be easily customized, makes it easy to start developing
+GNOME applications, gives your application structure and contains a few utility
+classes.
+</longdescription>
+</pkgmetadata>
+