summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2003-08-13 00:59:33 +0000
committerDavid Holm <dholm@gentoo.org>2003-08-13 00:59:33 +0000
commitf288d821eea2e11a598a80268705c1e4da0b6b26 (patch)
tree2186a82e859b9b3b803fa6fca5cda09e3069ceb9 /dev-ada/xmlada
parent*** empty log message *** (diff)
downloadhistorical-f288d821eea2e11a598a80268705c1e4da0b6b26.tar.gz
historical-f288d821eea2e11a598a80268705c1e4da0b6b26.tar.bz2
historical-f288d821eea2e11a598a80268705c1e4da0b6b26.zip
Closing bug #26207
Diffstat (limited to 'dev-ada/xmlada')
-rw-r--r--dev-ada/xmlada/ChangeLog9
-rw-r--r--dev-ada/xmlada/Manifest4
-rw-r--r--dev-ada/xmlada/files/digest-xmlada-0.7.1-r21
-rw-r--r--dev-ada/xmlada/xmlada-0.7.1-r2.ebuild81
4 files changed, 93 insertions, 2 deletions
diff --git a/dev-ada/xmlada/ChangeLog b/dev-ada/xmlada/ChangeLog
index a040c15e2fe9..ef877e3fd7a2 100644
--- a/dev-ada/xmlada/ChangeLog
+++ b/dev-ada/xmlada/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ada/xmlada
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/ChangeLog,v 1.3 2003/07/24 00:43:08 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/ChangeLog,v 1.4 2003/08/13 00:59:08 dholm Exp $
+
+*xmlada-0.7.1-r2 (13 Aug 2003)
+
+ 13 Aug 2003; David Holm <dholm@gentoo.org> xmlada-0.7.1-r2.ebuild:
+ A small update, this version symlinks the shared libraries into /usr/lib so
+ that applications using the library will be able to find it. This closes my
+ own bug #26207.
23 Jul 2003; George Shapovalov <george@gentoo.org> xmlada-0.7.1-r1.ebuild :
few adjustments suggested in #12081 to make it GNAE compliant, now for real
diff --git a/dev-ada/xmlada/Manifest b/dev-ada/xmlada/Manifest
index 5175304e459b..c87b63a078c4 100644
--- a/dev-ada/xmlada/Manifest
+++ b/dev-ada/xmlada/Manifest
@@ -1,5 +1,7 @@
MD5 2feab8d991e711195c443e263aaba4f0 xmlada-0.7.1.ebuild 1320
+MD5 9e7b880b6f7991622fd4d7b796c6dfd5 xmlada-0.7.1-r2.ebuild 2168
MD5 f00b3e00fcbbeb936c88d521263f7030 xmlada-0.7.1-r1.ebuild 1903
-MD5 28243b599bb803d94414804dd721a6d4 ChangeLog 984
+MD5 bf35288e0c84b0462d18c399b55edbaa ChangeLog 1259
MD5 9d2b99c18fffcb88c4d56d762a271e19 files/digest-xmlada-0.7.1-r1 61
+MD5 9d2b99c18fffcb88c4d56d762a271e19 files/digest-xmlada-0.7.1-r2 61
MD5 9d2b99c18fffcb88c4d56d762a271e19 files/digest-xmlada-0.7.1 61
diff --git a/dev-ada/xmlada/files/digest-xmlada-0.7.1-r2 b/dev-ada/xmlada/files/digest-xmlada-0.7.1-r2
new file mode 100644
index 000000000000..9480560adca5
--- /dev/null
+++ b/dev-ada/xmlada/files/digest-xmlada-0.7.1-r2
@@ -0,0 +1 @@
+MD5 385631115aa6546aaf6790e0ad59e399 XmlAda-0.7.1.tgz 312248
diff --git a/dev-ada/xmlada/xmlada-0.7.1-r2.ebuild b/dev-ada/xmlada/xmlada-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..4e9ea239e3e5
--- /dev/null
+++ b/dev-ada/xmlada/xmlada-0.7.1-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/xmlada/xmlada-0.7.1-r2.ebuild,v 1.1 2003/08/13 00:59:08 dholm Exp $
+
+inherit gnat
+
+IUSE=""
+
+Name="XmlAda"
+
+DESCRIPTION="XML library for Ada"
+HOMEPAGE="http://libre.act-europe.fr/xmlada/"
+SRC_URI="http://libre.act-europe.fr/xmlada/${Name}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="dev-lang/gnat"
+RDEPEND=""
+
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ #making .dvi docs is problemmatic. Skip that for now
+ sed -i -e "s/all: obj test docs/all: obj test/" Makefile.in
+ #increase stack size
+ cd sax
+ sed -i -e "s/Stack_Size : constant Natural := 64;/Stack_Size : constant Natural := 128;/" sax-readers.adb
+
+ #adjust xmlada-config to use new paths instead of hardcoded ones.
+ cd ${S}
+ sed -i -e "s#${prefix}/lib#${prefix}/lib/ada/adalib/xmlada#" xmlada-config.in
+ sed -i -e "s#${prefix}/include/xmlada#${prefix}/lib/ada/adainclude/xmlada#" xmlada-config.in
+}
+
+src_compile()
+{
+ export CFLAGS=$ADACFLAGS
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-shared \
+ --host=${CHOST} \
+ --build=${CHOST} \
+ --target=${CHOST} \
+ --with-system-zlib || die
+
+ export COMPILER=gnatmake
+ make || die "make failed"
+}
+
+src_install ()
+{
+ make PREFIX=${D}/usr install || die "install failed"
+
+ #move components to GNAE compliant directories
+ dodir /usr/lib/ada/adalib/${PN} /usr/lib/ada/adainclude/${PN}
+ cd ${D}/usr/lib/
+ mv * ${D}/usr/lib/ada/adalib/${PN}/
+ cd ${D}/usr/include/${PN}/
+ mv *.ali ${D}/usr/lib/ada/adalib/${PN}
+ mv * ${D}/usr/lib/ada/adainclude/${PN}
+ cd .. && rmdir ${PN}
+ cd .. && rmdir include
+ cd ${S}
+
+ dodoc AUTHORS COPYING README TODO docs/xml.ps
+ dohtml docs/*.html
+ doinfo docs/*.info
+ #need to give a proper name to info file
+ cd ${D}/usr/share/info
+ mv xml.info.gz ${PN}.info.gz
+
+ dosym /usr/lib/ada/adalib/xmlada/libxmlada_dom.so /usr/lib
+ dosym /usr/lib/ada/adalib/xmlada/libxmlada_input_sources.so /usr/lib
+ dosym /usr/lib/ada/adalib/xmlada/libxmlada_sax.so /usr/lib
+ dosym /usr/lib/ada/adalib/xmlada/libxmlada_unicode.so /usr/lib
+}