summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-05-19 10:26:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-05-19 10:26:03 +0000
commit0051b8df7b61bbf8680c680f32d7cc6fe4beed4a (patch)
treed841fc2980460c1417d4b76c2f30ed6ff4a2710e /app-text
parentInitial import of ssddiff, a C++ implementation of xmldiff. (diff)
downloadhistorical-0051b8df7b61bbf8680c680f32d7cc6fe4beed4a.tar.gz
historical-0051b8df7b61bbf8680c680f32d7cc6fe4beed4a.tar.bz2
historical-0051b8df7b61bbf8680c680f32d7cc6fe4beed4a.zip
Initial import of Nokia's xmlpatch suite.
Package-Manager: portage-2.1.5
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libxmlpatch/ChangeLog11
-rw-r--r--app-text/libxmlpatch/files/libxmlpatch-0.3.1-asneeded.patch12
-rw-r--r--app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild32
-rw-r--r--app-text/libxmlpatch/metadata.xml8
4 files changed, 63 insertions, 0 deletions
diff --git a/app-text/libxmlpatch/ChangeLog b/app-text/libxmlpatch/ChangeLog
new file mode 100644
index 000000000000..bd15b22c130b
--- /dev/null
+++ b/app-text/libxmlpatch/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/libxmlpatch
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/ChangeLog,v 1.1 2008/05/19 10:26:03 flameeyes Exp $
+
+*libxmlpatch-0.3.1 (19 May 2008)
+
+ 19 May 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libxmlpatch-0.3.1-asneeded.patch, +metadata.xml,
+ +libxmlpatch-0.3.1.ebuild:
+ Initial import of Nokia's xmlpatch suite.
+
diff --git a/app-text/libxmlpatch/files/libxmlpatch-0.3.1-asneeded.patch b/app-text/libxmlpatch/files/libxmlpatch-0.3.1-asneeded.patch
new file mode 100644
index 000000000000..0ce6cf5d5bda
--- /dev/null
+++ b/app-text/libxmlpatch/files/libxmlpatch-0.3.1-asneeded.patch
@@ -0,0 +1,12 @@
+Index: libxmlpatch-0.3.1/diff/Makefile.am
+===================================================================
+--- libxmlpatch-0.3.1.orig/diff/Makefile.am
++++ libxmlpatch-0.3.1/diff/Makefile.am
+@@ -29,6 +29,7 @@ INCLUDES = $(DEPS_XML_CFLAGS) $(DEPS_GLI
+ lib_LTLIBRARIES = libxmldiff.la
+
+ libxmldiff_la_SOURCES = xml_diff.c
++libxmldiff_la_LIBADD = $(DEPS_GLIB_LIBS)
+
+ libxmldiff_includedir = $(includedir)/libxmldiff
+ libxmldiff_include_HEADERS = xml_diff.h
diff --git a/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild b/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
new file mode 100644
index 000000000000..0401c7a4a601
--- /dev/null
+++ b/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild,v 1.1 2008/05/19 10:26:03 flameeyes Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A set of tools to create and apply patch to XML files using XPath"
+HOMEPAGE="http://opensource.nokia.com/projects/xmlpatch/index.html"
+SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc LEGAL_NOTICE README TODO AUTHORS NEWS ChangeLog
+}
diff --git a/app-text/libxmlpatch/metadata.xml b/app-text/libxmlpatch/metadata.xml
new file mode 100644
index 000000000000..2d083ce3bc66
--- /dev/null
+++ b/app-text/libxmlpatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>