summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-10-18 23:40:37 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-10-18 23:40:37 +0000
commit11ed037935f1b0a685025d2b234b2fd07c346f5d (patch)
tree11e83ffb967669fb3319d063871637becdea37f0 /app-text/tuxcards/tuxcards-1.2.ebuild
parentInitial version. Closes #21874. (diff)
downloadhistorical-11ed037935f1b0a685025d2b234b2fd07c346f5d.tar.gz
historical-11ed037935f1b0a685025d2b234b2fd07c346f5d.tar.bz2
historical-11ed037935f1b0a685025d2b234b2fd07c346f5d.zip
Version bump.
Diffstat (limited to 'app-text/tuxcards/tuxcards-1.2.ebuild')
-rw-r--r--app-text/tuxcards/tuxcards-1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/tuxcards/tuxcards-1.2.ebuild b/app-text/tuxcards/tuxcards-1.2.ebuild
new file mode 100644
index 000000000000..ad350263847b
--- /dev/null
+++ b/app-text/tuxcards/tuxcards-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tuxcards/tuxcards-1.2.ebuild,v 1.1 2004/10/18 23:40:37 ticho Exp $
+
+DESCRIPTION="A heirarchical text editor"
+HOMEPAGE="http://www.tuxcards.de"
+
+SRC_URI="http://www.tifskom.de/tux/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=qt-3.1.1"
+
+src_compile() {
+ sed -e 's:/usr/local:/usr:g' \
+ -e 's:/usr/doc/tuxcards:/usr/share/tuxcards:g' tuxcards.pro > tuxpro && \
+ mv tuxpro tuxcards.pro
+ sed -e 's:/usr/local/doc:/usr/share:g' src/CTuxCardsConfiguration.cpp > temp && \
+ mv temp src/CTuxCardsConfiguration.cpp
+ sed -e 's:/usr/local/bin/:/usr/bin/:g' src/gui/dialogs/optionsDialog/IOptionsDialog.ui > temp && \
+ mv temp src/gui/dialogs/optionsDialog/IOptionsDialog.ui
+
+ qmake tuxcards.pro
+
+ emake || die
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+
+ dodoc AUTHORS COPYING INSTALL README
+}