summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-05-30 02:07:14 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-05-30 02:07:14 +0000
commitd67397060ccd418c8003b7da5400a2f7aad6c0e6 (patch)
tree863560fc80e4259cb778728248a46756df53ca05 /app-text/rhyme/rhyme-0.9.ebuild
parent(non maintainer commit) Respect flags and QA fixes, bug 244014 by Espen Hustad (diff)
downloadhistorical-d67397060ccd418c8003b7da5400a2f7aad6c0e6.tar.gz
historical-d67397060ccd418c8003b7da5400a2f7aad6c0e6.tar.bz2
historical-d67397060ccd418c8003b7da5400a2f7aad6c0e6.zip
(non maintainer commit) Respect CC and QA fixes, bug 243744 by Espen Hustad
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'app-text/rhyme/rhyme-0.9.ebuild')
-rw-r--r--app-text/rhyme/rhyme-0.9.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/app-text/rhyme/rhyme-0.9.ebuild b/app-text/rhyme/rhyme-0.9.ebuild
index 8d1c88e560b3..45c3230e90ca 100644
--- a/app-text/rhyme/rhyme-0.9.ebuild
+++ b/app-text/rhyme/rhyme-0.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rhyme/rhyme-0.9.ebuild,v 1.10 2008/06/14 00:50:18 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rhyme/rhyme-0.9.ebuild,v 1.11 2009/05/30 02:07:14 darkside Exp $
-inherit ccc
+inherit toolchain-funcs
DESCRIPTION="Console based Rhyming Dictionary"
HOMEPAGE="http://rhyme.sourceforge.net/"
@@ -10,24 +10,25 @@ SRC_URI="mirror://sourceforge/rhyme/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 alpha"
+KEYWORDS="alpha x86"
IUSE=""
DEPEND=">=sys-libs/ncurses-5.3
>=sys-libs/readline-4.3
>=sys-libs/gdbm-1.8.0"
+RDEPEND="${DEPEND}"
-src_compile() {
- # gcc is hardcoded, switch to user specified compiler
- replace-cc-hardcode
-
- # CFLAGS are hardcoded, replace with user specified flags
- sed -i "s#\(^FLAGS =\).*#\1 ${CFLAGS}#g" "${S}"/Makefile
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
# termcap is used by default, switch to ncurses
sed -i 's/-ltermcap/-lncurses/g' "${S}"/Makefile
+}
- emake -j1 || die "emake failed"
+src_compile() {
+ # Disable parallell building wrt bug #125967
+ emake -j1 CC="$(tc-getCC)" FLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {