summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-09-04 17:15:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-09-04 17:15:03 +0000
commit5984c98468ed634142984db6e8175a68a59cfcf7 (patch)
tree5cc312ac97bc9c85b8afec0a25ad48b772c1da3a /app-text/rhyme/rhyme-0.9.ebuild
parentinitial import (diff)
downloadhistorical-5984c98468ed634142984db6e8175a68a59cfcf7.tar.gz
historical-5984c98468ed634142984db6e8175a68a59cfcf7.tar.bz2
historical-5984c98468ed634142984db6e8175a68a59cfcf7.zip
initial import
Diffstat (limited to 'app-text/rhyme/rhyme-0.9.ebuild')
-rw-r--r--app-text/rhyme/rhyme-0.9.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-text/rhyme/rhyme-0.9.ebuild b/app-text/rhyme/rhyme-0.9.ebuild
new file mode 100644
index 000000000000..271c734b89cf
--- /dev/null
+++ b/app-text/rhyme/rhyme-0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rhyme/rhyme-0.9.ebuild,v 1.1 2003/09/04 17:14:58 taviso Exp $
+
+inherit ccc
+
+DESCRIPTION="Console based Rhyming Dictionary"
+HOMEPAGE="http://rhyme.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rhyme/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+IUSE="ncurses"
+
+RDEPEND="ncurses? ( >=sys-libs/ncurses-5.3 )
+ !ncurses? ( >=sys-libs/libtermcap-compat-1.2.3 )
+ >=sys-libs/readline-4.3
+ >=sys-libs/gdbm-1.8.0"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # gcc is hardcoded, switch to user specified compiler
+ replace-cc-hardcode
+
+ # CFLAGS are hardcoded, replace with user specified flags
+ sed -i "s#\(^FLAGS =\).*#\1 ${CFLAGS}#g" ${S}/Makefile
+
+ # termcap is used by default, switch to ncurses if requested.
+ if use ncurses; then
+ sed -i 's/-ltermcap/-lncurses/g' ${S}/Makefile
+ fi
+
+ # works fine with parallel build
+ emake || die
+}
+
+src_install() {
+ # author doesnt use -D for install
+ dodir /usr/share/rhyme /usr/bin /usr/share/man/man1
+
+ einstall BINPATH=${D}/usr/bin \
+ MANPATH=${D}/usr/share/man/man1 \
+ RHYMEPATH=${D}/usr/share/rhyme || die
+
+ dodoc INSTALL COPYING
+
+ prepallman
+}
+