summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-02-01 21:46:51 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-02-01 21:46:51 +0000
commiteebef05263509b600df7791cd13647b18e63fae5 (patch)
tree9bab517df427bbf38ced323f76ee083ba5e22088 /app-text/recode/files
parentAdded to Portage, fixes Bug 48011. (diff)
downloadhistorical-eebef05263509b600df7791cd13647b18e63fae5.tar.gz
historical-eebef05263509b600df7791cd13647b18e63fae5.tar.bz2
historical-eebef05263509b600df7791cd13647b18e63fae5.zip
added ~ppc-macos keyword and patch
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-text/recode/files')
-rw-r--r--app-text/recode/files/recode-3.6-ppc-macos.diff29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/recode/files/recode-3.6-ppc-macos.diff b/app-text/recode/files/recode-3.6-ppc-macos.diff
new file mode 100644
index 000000000000..bc005049957f
--- /dev/null
+++ b/app-text/recode/files/recode-3.6-ppc-macos.diff
@@ -0,0 +1,29 @@
+diff -uNr recode/src/Makefile.in recode-new/src/Makefile.in
+--- recode/src/Makefile.in Mon Jan 22 12:14:16 2001
++++ recode-new/src/Makefile.in Tue Feb 1 14:03:47 2005
+@@ -165,11 +165,11 @@
+ strip-data$U.lo testdump$U.lo ucs$U.lo utf16$U.lo utf7$U.lo utf8$U.lo \
+ varia$U.lo vn$U.lo flat$U.lo html$U.lo lat1ltex$U.lo lat1txte$U.lo \
+ rfc1345$U.lo texinfo$U.lo base64$U.lo dump$U.lo endline$U.lo \
+-permut$U.lo quoted$U.lo
++permut$U.lo quoted$U.lo error.lo xstrdup.lo
+ PROGRAMS = $(bin_PROGRAMS)
+
+ recode_OBJECTS = main$U.o freeze$U.o mixed$U.o
+-recode_DEPENDENCIES = librecode.la ../lib/libreco.a
++recode_DEPENDENCIES = librecode.la
+ recode_LDFLAGS =
+ CFLAGS = @CFLAGS@
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+diff -uNr recode/src/request.c recode-new/src/request.c
+--- recode/src/request.c Wed Jun 28 13:40:21 2000
++++ recode-new/src/request.c Tue Feb 1 14:05:13 2005
+@@ -1073,7 +1073,7 @@
+ if (task->output.cursor + 4 >= task->output.limit)
+ {
+ RECODE_OUTER outer = task->request->outer;
+- size_t old_size = task->output.limit - task->output.buffer;
++ size_t old_size = task->output.cursor - task->output.buffer;
+ size_t new_size = task->output.cursor + 4 - task->output.buffer;
+
+ /* FIXME: Rethink about how the error should be reported. */