summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-20 10:11:44 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-20 10:11:44 +0000
commit0595da58dbd6ea7bdc01c94cfbddc3ca458dfa04 (patch)
treeebe5871b8a5bf92c6e586ee2befc3b26f62497be /app-text/psgml
parent*** empty log message *** (diff)
downloadhistorical-0595da58dbd6ea7bdc01c94cfbddc3ca458dfa04.tar.gz
historical-0595da58dbd6ea7bdc01c94cfbddc3ca458dfa04.tar.bz2
historical-0595da58dbd6ea7bdc01c94cfbddc3ca458dfa04.zip
*** empty log message ***
Diffstat (limited to 'app-text/psgml')
-rw-r--r--app-text/psgml/files/digest-psgml-1.2.21
-rw-r--r--app-text/psgml/files/dot_emacs53
-rw-r--r--app-text/psgml/psgml-1.2.2.ebuild30
3 files changed, 84 insertions, 0 deletions
diff --git a/app-text/psgml/files/digest-psgml-1.2.2 b/app-text/psgml/files/digest-psgml-1.2.2
new file mode 100644
index 000000000000..ff50e2f4363f
--- /dev/null
+++ b/app-text/psgml/files/digest-psgml-1.2.2
@@ -0,0 +1 @@
+MD5 b7e68d02b08cfb684926b93ada898f1c psgml-1.2.2.tar.gz
diff --git a/app-text/psgml/files/dot_emacs b/app-text/psgml/files/dot_emacs
new file mode 100644
index 000000000000..ccbd6f6802e4
--- /dev/null
+++ b/app-text/psgml/files/dot_emacs
@@ -0,0 +1,53 @@
+;; $Id: dot_emacs,v 1.2 2000/03/29 19:12:16 nwalsh Exp
+;; DocBook IDE mode
+(autoload 'docbook-mode "docbookide" "Major mode for DocBook documents." t)
+;; Turn on font lock when in DocBook mode
+(add-hook 'docbook-mode-hook
+ 'turn-on-font-lock)
+
+;; You might want to make this the default for .sgml or .xml documents,
+;; or you might want to rely on -*- DocBook -*- on the first line,
+;; or perhaps buffer variables. It's up to you...
+;;(setq auto-mode-alist
+;; (append
+;; (list
+;; '("\\.sgm" . docbook-mode))
+;; '("\\.sgml" . docbook-mode))
+;; '("\\.xml" . docbook-mode))
+;; auto-mode-alist))
+
+;; keyboard mods not specific to any mode.
+(global-set-key [(control h)] 'delete-backward-char) ;backspace, not help!
+(global-set-key "\C-cg" 'goto-line)
+(global-set-key [home] 'beginning-of-line) ;not screen
+(global-set-key "\e[1~" 'beginning-of-line) ;not screen
+(global-set-key "\eOH" 'beginning-of-line) ;Needed on remote xterm?
+(global-set-key [end] 'end-of-line) ;inactive by default?
+(global-set-key "\e[4~" 'end-of-line)
+(global-set-key "\eOF" 'end-of-line) ;Needed on remote xterm?
+
+(global-set-key [delete] 'delete-char) ; delete char, don't move cursor.
+(global-set-key [(meta control h)] 'backward-kill-word)
+(global-set-key [f2] 'other-window) ;convenient shortcuts.
+(global-set-key [f3] 'kill-this-buffer)
+(global-unset-key [escape escape]) ;eval-expr gets in my way.
+
+(global-set-key [(control x)(control u)] 'undo) ;bind to something useful.
+;(require 'redo)
+;(global-set-key [(control x)(control r)] 'redo) ;consistent with my undo.
+
+(global-set-key [(shift button2)] ;<shift>-mouse2 to load
+ 'browse-url-at-mouse) ;url at point into netscape.
+
+;; Make sure we have sgml and xml modes (psgml.el)
+(autoload 'sgml-mode "psgml" "Major mode to edit SGML files." t)
+(autoload 'xml-mode "psgml" "Major mode to edit XML files." t)
+(setq sgml-set-face t)
+(setq sgml-indent-step t)
+(setq sgml-live-element-indicator t)
+;; Recognize Lutris Enhydra doml files as xml. This doesn't work
+;; very well because xml-mode has problems reading the doml dtd.
+(setq auto-mode-alist (cons '("\\.doml$" . xml-mode) auto-mode-alist))
+
+;; Set the global central catalog
+(setq sgml-catalog-files (quote ("CATALOG" "/etc/sgml/catalog")))
diff --git a/app-text/psgml/psgml-1.2.2.ebuild b/app-text/psgml/psgml-1.2.2.ebuild
new file mode 100644
index 000000000000..9fa4da34099f
--- /dev/null
+++ b/app-text/psgml/psgml-1.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/app-text/psgml/psgml-1.2.2.ebuild,v 1.1 2001/03/20 10:11:44 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="PSGML is a GNU Emacs Major Mode for editing SGML and XML coded documents."
+SRC_URI="http://ftp1.sourceforge.net/${PN}/${A}"
+HOMEPAGE="http://psgml.sourceforge.net"
+
+DEPEND="virtual/emacs"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --infodir=/usr/share/info --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr install
+ dodir /usr/share/info
+ try make infodir=${D}/usr/share/info install-info
+
+ dodoc ChangeLog README.psgml ${FILESDIR}/dot_emacs
+
+}
+