summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-09 20:40:41 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-09 20:40:41 +0000
commitdcdecf8a2d083779a810d9263cea201e94b4e42d (patch)
treed40cc1e23a234b0c8c7941dc2b1c79f5bbe85df0 /app-text/pinfo
parentstable on alpha (diff)
downloadhistorical-dcdecf8a2d083779a810d9263cea201e94b4e42d.tar.gz
historical-dcdecf8a2d083779a810d9263cea201e94b4e42d.tar.bz2
historical-dcdecf8a2d083779a810d9263cea201e94b4e42d.zip
Version bump
Diffstat (limited to 'app-text/pinfo')
-rw-r--r--app-text/pinfo/ChangeLog7
-rw-r--r--app-text/pinfo/files/digest-pinfo-0.6.71
-rw-r--r--app-text/pinfo/pinfo-0.6.7.ebuild37
3 files changed, 44 insertions, 1 deletions
diff --git a/app-text/pinfo/ChangeLog b/app-text/pinfo/ChangeLog
index f7bff1e2a1a9..56527f7f9ae4 100644
--- a/app-text/pinfo/ChangeLog
+++ b/app-text/pinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pinfo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.8 2003/02/12 05:33:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.9 2003/03/09 20:40:41 aliz Exp $
+
+*pinfo-0.6.7 (09 Mar 2003)
+
+ 09 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/app-text/pinfo/files/digest-pinfo-0.6.7 b/app-text/pinfo/files/digest-pinfo-0.6.7
new file mode 100644
index 000000000000..8d4db6e5a799
--- /dev/null
+++ b/app-text/pinfo/files/digest-pinfo-0.6.7
@@ -0,0 +1 @@
+MD5 d0ac823aa8fe528ed54004d022cb0896 pinfo-0.6.7.tar.gz 318720
diff --git a/app-text/pinfo/pinfo-0.6.7.ebuild b/app-text/pinfo/pinfo-0.6.7.ebuild
new file mode 100644
index 000000000000..920264c8bdd8
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.7.ebuild,v 1.1 2003/03/09 20:40:41 aliz Exp $
+
+MY_P=${PN}-${PV/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+SRC_URI="http://zeus.polsl.gliwice.pl/~pborys/stable-version/${MY_P}.tar.gz"
+HOMEPAGE="http://zeus.polsl.gliwice.pl/~pborys/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc "
+IUSE="nls readline"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} sysconfdir=/etc install || die
+}