summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-15 11:53:21 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-15 11:53:21 +0000
commita7198cd734c03008c4311b3b26cfe41864363ad4 (patch)
tree6674244865737dc53fad3948becd460af9218c8f /app-text/pinfo
parentadded some extra-making-sure QTDIR exports to help analyze and trace bug #1119 (diff)
downloadhistorical-a7198cd734c03008c4311b3b26cfe41864363ad4.tar.gz
historical-a7198cd734c03008c4311b3b26cfe41864363ad4.tar.bz2
historical-a7198cd734c03008c4311b3b26cfe41864363ad4.zip
Upgraded to new stable version
Diffstat (limited to 'app-text/pinfo')
-rw-r--r--app-text/pinfo/ChangeLog8
-rw-r--r--app-text/pinfo/files/digest-pinfo-0.6.5_p21
-rw-r--r--app-text/pinfo/pinfo-0.6.5_p2.ebuild40
3 files changed, 48 insertions, 1 deletions
diff --git a/app-text/pinfo/ChangeLog b/app-text/pinfo/ChangeLog
index 1bd6856f6d8d..08c45e475a48 100644
--- a/app-text/pinfo/ChangeLog
+++ b/app-text/pinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pinfo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.1 2002/02/01 21:53:10 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.2 2002/03/15 11:53:21 seemant Exp $
+
+*pinfo-0.6.5_p2 (15 Mar 2002)
+
+ 15 Mar 2002; Seemant Kulleen <seemant@gentoo.org> pinfo-0.6.5_p2.ebuild :
+
+ Updated to new version -- patch provided by Matthew B. Kennedy
*pinfo-0.6.3 (1 Feb 2002)
diff --git a/app-text/pinfo/files/digest-pinfo-0.6.5_p2 b/app-text/pinfo/files/digest-pinfo-0.6.5_p2
new file mode 100644
index 000000000000..b065870e4b76
--- /dev/null
+++ b/app-text/pinfo/files/digest-pinfo-0.6.5_p2
@@ -0,0 +1 @@
+MD5 0e4b7a6f764b31e4f0111deb71eeaefb pinfo-0.6.5p2.tar.gz 316079
diff --git a/app-text/pinfo/pinfo-0.6.5_p2.ebuild b/app-text/pinfo/pinfo-0.6.5_p2.ebuild
new file mode 100644
index 000000000000..51b515c36d6e
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.5_p2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.5_p2.ebuild,v 1.1 2002/03/15 11:53:21 seemant Exp $
+
+MY_P=${PN}-0.6.5p2
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+SRC_URI="http://zeus.polsl.gliwice.pl/~pborys/stable-version/${MY_P}.tar.gz"
+HOMEPAGE="http://zeus.polsl.gliwice.pl/~pborys/"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ nls? ( >=sys-devel/gettext-0.10.39 )
+ >=sys-devel/bison-1.28"
+
+src_compile() {
+ local myconf
+ if [ "`use readline`" ] ; then
+ myconf="${myconf} --with-readline"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ else
+ myconf="${myconf} --enable-nls"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}