summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2003-08-29 23:47:28 +0000
committerChuck Short <zul@gentoo.org>2003-08-29 23:47:28 +0000
commit2aa62386e4410edef89b13ad97935faaa70ce853 (patch)
tree897d1202d2284d2bb925cc3d4940e869156fcd23 /app-text/pinfo
parentVersion bump, updated ebuilds, closes #27530 (diff)
downloadhistorical-2aa62386e4410edef89b13ad97935faaa70ce853.tar.gz
historical-2aa62386e4410edef89b13ad97935faaa70ce853.tar.bz2
historical-2aa62386e4410edef89b13ad97935faaa70ce853.zip
Version bump, updated ebuilds, closes #27530
Diffstat (limited to 'app-text/pinfo')
-rw-r--r--app-text/pinfo/Manifest4
-rw-r--r--app-text/pinfo/files/digest-pinfo-0.6.81
-rw-r--r--app-text/pinfo/pinfo-0.6.8.ebuild37
3 files changed, 40 insertions, 2 deletions
diff --git a/app-text/pinfo/Manifest b/app-text/pinfo/Manifest
index dfc99e9c7fdf..127628ac9f95 100644
--- a/app-text/pinfo/Manifest
+++ b/app-text/pinfo/Manifest
@@ -1,7 +1,7 @@
MD5 48419a03f6890b40c9bc0a1159ad8d07 pinfo-0.6.7.ebuild 924
MD5 8879eac2e8cb5fb4ebc67b4e1defd83c pinfo-0.6.5_p2-r1.ebuild 931
-MD5 145d5cb64205d2ff405b04b86214aa35 ChangeLog 1734
-MD5 cf0112588a7ecbeed6f732f51b558e2f pinfo-0.6.8.ebuild 915
+MD5 e60d2832dd48b9dbd5181a7ba4b98eaf ChangeLog 1877
+MD5 843c9e73a02dd966379b6611555fcb28 pinfo-0.6.8.ebuild 913
MD5 cd407b1e6a446c80f336c862fe75b56f files/digest-pinfo-0.6.7 63
MD5 43cd937abc939c31ddaea990ea29acd7 files/digest-pinfo-0.6.8 63
MD5 e132eaa5418eb067f4db536d63f27e07 files/digest-pinfo-0.6.5_p2-r1 65
diff --git a/app-text/pinfo/files/digest-pinfo-0.6.8 b/app-text/pinfo/files/digest-pinfo-0.6.8
new file mode 100644
index 000000000000..159a6f97d23a
--- /dev/null
+++ b/app-text/pinfo/files/digest-pinfo-0.6.8
@@ -0,0 +1 @@
+MD5 55feb4ebaa709b52bd00a15ed0fb52fb pinfo-0.6.8.tar.gz 319857
diff --git a/app-text/pinfo/pinfo-0.6.8.ebuild b/app-text/pinfo/pinfo-0.6.8.ebuild
new file mode 100644
index 000000000000..d7fede75412a
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.8.ebuild,v 1.1 2003/08/29 23:47:01 zul Exp $
+
+MY_P=${PN}-${PV/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+SRC_URI="http://dione.ids.pl/~pborys/software/pinfo/pinfo-${PV}.tar.gz"
+HOMEPAGE="http://dione.ids.pl/~pborys/pinfo"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc sparc "
+IUSE="nls readline"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} sysconfdir=/etc install || die
+}