summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-23 22:31:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-23 22:31:49 +0000
commit88fa6aec2631e433ac245a31d54da7da2cfeee59 (patch)
treed2be5e6fbf7f8265fb1c6e604c741b32625ca6ba /app-text/gtkspell/gtkspell-2.0.13.ebuild
parentBumped to latest releases, removed past version. Lastest 2.1.x version seems ... (diff)
downloadhistorical-88fa6aec2631e433ac245a31d54da7da2cfeee59.tar.gz
historical-88fa6aec2631e433ac245a31d54da7da2cfeee59.tar.bz2
historical-88fa6aec2631e433ac245a31d54da7da2cfeee59.zip
bump to 2.0.13, bug #231810. Use thirdpartymirrors.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64
Diffstat (limited to 'app-text/gtkspell/gtkspell-2.0.13.ebuild')
-rw-r--r--app-text/gtkspell/gtkspell-2.0.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/gtkspell/gtkspell-2.0.13.ebuild b/app-text/gtkspell/gtkspell-2.0.13.ebuild
new file mode 100644
index 000000000000..3db9dfc4c5fb
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-2.0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.13.ebuild,v 1.1 2008/07/23 22:31:49 eva Exp $
+
+inherit eutils
+
+DESCRIPTION="Spell checking widget for GTK2"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+SRC_URI="mirror://sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=app-text/enchant-1.1.6"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ doc? ( >=dev-util/gtk-doc-1
+ =app-text/docbook-xml-dtd-4.2* )"
+
+src_compile() {
+ econf $(use_enable doc gtk-doc) || die "configure failed"
+ emake || die "compile failure"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}