summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-14 22:55:30 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-14 22:55:30 +0000
commit56fb90204aaa9e8d7ea4d0da83994ae13cf513c8 (patch)
treedf0d6416edd4b2ad91825f2e7b5ba831223985af /app-text/enscript
parentRemoved redundant dependencies provided by java.eclass (bug #118651). (diff)
downloadhistorical-56fb90204aaa9e8d7ea4d0da83994ae13cf513c8.tar.gz
historical-56fb90204aaa9e8d7ea4d0da83994ae13cf513c8.tar.bz2
historical-56fb90204aaa9e8d7ea4d0da83994ae13cf513c8.zip
Patch to fix -toc and segfault thanks to Ed Catmur <ed@catmur.co.uk> in bug 111457
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'app-text/enscript')
-rw-r--r--app-text/enscript/ChangeLog9
-rw-r--r--app-text/enscript/Manifest5
-rw-r--r--app-text/enscript/enscript-1.6.4-r1.ebuild42
-rw-r--r--app-text/enscript/files/digest-enscript-1.6.4-r11
-rw-r--r--app-text/enscript/files/enscript-catmur.patch26
5 files changed, 81 insertions, 2 deletions
diff --git a/app-text/enscript/ChangeLog b/app-text/enscript/ChangeLog
index 74a0b819890f..94357f005d0f 100644
--- a/app-text/enscript/ChangeLog
+++ b/app-text/enscript/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/enscript
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.32 2006/01/14 22:39:19 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.33 2006/01/14 22:55:30 genstef Exp $
+
+*enscript-1.6.4-r1 (14 Jan 2006)
+
+ 14 Jan 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/enscript-catmur.patch, +enscript-1.6.4-r1.ebuild:
+ Patch to fix -toc and segfault thanks to Ed Catmur <ed@catmur.co.uk> in bug
+ 111457
14 Jan 2006; Stefan Schweizer <genstef@gentoo.org> enscript-1.6.4.ebuild:
Fix Configure thanks to Keri Harris <harriskeri@mcs.vuw.ac.nz> in bug 94948
diff --git a/app-text/enscript/Manifest b/app-text/enscript/Manifest
index 434b020b5bc7..f8734d72f9fc 100644
--- a/app-text/enscript/Manifest
+++ b/app-text/enscript/Manifest
@@ -1,8 +1,11 @@
-MD5 794f46700fef8cc85dce162de4fe79ac ChangeLog 3832
+MD5 daf38d4c90615db6524b3197f3a8e239 ChangeLog 4066
MD5 3ecae1143becc2047418f67b38407479 enscript-1.6.3-r3.ebuild 913
+MD5 d353603554e023f6e600144d3d0bf80f enscript-1.6.4-r1.ebuild 1023
MD5 f1204f14336bb01477ad8e1721eabee9 enscript-1.6.4.ebuild 978
MD5 528d3e39a7e18ff200cccfd037ee0422 files/digest-enscript-1.6.3-r3 66
MD5 96b207f1bc22828660e417ebaab43d03 files/digest-enscript-1.6.4 67
+MD5 96b207f1bc22828660e417ebaab43d03 files/digest-enscript-1.6.4-r1 67
MD5 2982cb4ed62b45684d5e6e015c34a52e files/enscript-1.6.3-language.patch 456
MD5 e105a37406fc2ff7aa4895780e4b5a66 files/enscript-1.6.3-security.patch 5447
+MD5 854bcc9d4ce6d573dfa5133a55e8ddca files/enscript-catmur.patch 604
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
diff --git a/app-text/enscript/enscript-1.6.4-r1.ebuild b/app-text/enscript/enscript-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..4e155f89eb8a
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/enscript-1.6.4-r1.ebuild,v 1.1 2006/01/14 22:55:30 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="powerful text-to-postscript converter"
+SRC_URI="http://www.iki.fi/mtr/genscript/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/enscript/enscript.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha ~mips ~ppc64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/enscript-1.6.3-security.patch
+ epatch ${FILESDIR}/enscript-1.6.3-language.patch
+ epatch ${FILESDIR}/enscript-catmur.patch
+}
+
+src_compile() {
+ unset CC
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog FAQ.html NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ einfo "Now, customize /etc/enscript.cfg."
+}
diff --git a/app-text/enscript/files/digest-enscript-1.6.4-r1 b/app-text/enscript/files/digest-enscript-1.6.4-r1
new file mode 100644
index 000000000000..55e9e490e932
--- /dev/null
+++ b/app-text/enscript/files/digest-enscript-1.6.4-r1
@@ -0,0 +1 @@
+MD5 b5174b59e4a050fb462af5dbf28ebba3 enscript-1.6.4.tar.gz 1036734
diff --git a/app-text/enscript/files/enscript-catmur.patch b/app-text/enscript/files/enscript-catmur.patch
new file mode 100644
index 000000000000..bd4b222f7f36
--- /dev/null
+++ b/app-text/enscript/files/enscript-catmur.patch
@@ -0,0 +1,26 @@
+--- src/main.c 2005/11/04 11:02:27 1.1
++++ src/main.c 2005/11/04 11:16:28
+@@ -1695,7 +1695,7 @@ name width\theight\tllx\tlly
+ }
+
+ /* Table of Contents. */
+- if (toc)
++ if (ofp != NULL && toc)
+ {
+ /* This is really cool... */
+
+@@ -1714,9 +1714,11 @@ name width\theight\tllx\tlly
+ process_file (_("Table of Contents"), &is, 1);
+ is_close (&is);
+ }
+-
+- /* Clean up toc file. */
+- fclose (toc_fp);
++ else
++ {
++ /* Clean up toc file. */
++ fclose (toc_fp);
++ }
+ }
+
+ /* Give trailer a chance to dump itself. */