summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 21:49:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 21:49:19 +0000
commit172ec70fbfc920f7d96581b7c3886845218e7195 (patch)
tree12a8d5c97f8d7b029d9d242aadf23507d91329e7 /app-text/cmigemo
parentAdded a check to the ebuild to update the patch to use the latest available K... (diff)
downloadhistorical-172ec70fbfc920f7d96581b7c3886845218e7195.tar.gz
historical-172ec70fbfc920f7d96581b7c3886845218e7195.tar.bz2
historical-172ec70fbfc920f7d96581b7c3886845218e7195.zip
add inherit eutils
Diffstat (limited to 'app-text/cmigemo')
-rw-r--r--app-text/cmigemo/cmigemo-1.2.ebuild29
1 files changed, 10 insertions, 19 deletions
diff --git a/app-text/cmigemo/cmigemo-1.2.ebuild b/app-text/cmigemo/cmigemo-1.2.ebuild
index a7b610b5a053..0e528450e172 100644
--- a/app-text/cmigemo/cmigemo-1.2.ebuild
+++ b/app-text/cmigemo/cmigemo-1.2.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/cmigemo/cmigemo-1.2.ebuild,v 1.2 2004/03/13 08:55:11 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/cmigemo/cmigemo-1.2.ebuild,v 1.3 2004/04/07 21:40:05 vapier Exp $
-IUSE="emacs"
+inherit eutils
DESCRIPTION="C/Migemo -- Migemo library implementation in C"
HOMEPAGE="http://www.kaoriya.net/#CMIGEMO"
SRC_URI="http://www.kaoriya.net/dist/${P}.tar.bz2"
LICENSE="cmigemo"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
-S="${WORKDIR}/${P}"
+KEYWORDS="~x86 ~alpha"
+IUSE="emacs"
DEPEND="virtual/glibc
app-i18n/qkc
@@ -21,43 +21,35 @@ RDEPEND="virtual/glibc
emacs? ( >=app-text/migemo-0.40-r1 )"
src_unpack() {
-
unpack ${A}
-
epatch ${FILESDIR}/${P}-migemo-dict.diff
-
touch ${S}/dict/SKK-JISYO.L
-
}
src_compile() {
-
emake CFLAGS="-fPIC ${CFLAGS}" gcc || die
-
}
src_install() {
-
- make prefix=${D}/usr \
- docdir=${D}/usr/share/doc/${P} \
- gcc-install || die
+ make \
+ prefix=${D}/usr \
+ docdir=${D}/usr/share/doc/${P} \
+ gcc-install || die
mv ${D}/usr/share/migemo/euc-jp/*.dat ${D}/usr/share/migemo
rm -rf ${D}/usr/share/migemo/{cp932,euc-jp}
- if has_version 'app-editors/vim-core'; then
+ if has_version 'app-editors/vim-core' ; then
insinto /usr/share/vim/vimfiles/plugin
doins tools/migemo.vim
fi
dodoc tools/migemo.vim
dodoc doc/{README_j,TODO_j,vimigemo}.txt
-
}
pkg_postinst() {
-
- if use emacs; then
+ if use emacs ; then
einfo ""
einfo "Please add to your ~/.emacs"
einfo " (setq migemo-command \"cmigemo\")"
@@ -68,5 +60,4 @@ pkg_postinst() {
einfo "to use cmigemo instead of migemo under emacs."
einfo ""
fi
-
}