summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-04-05 11:22:42 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-04-05 11:22:42 +0000
commit22b3a058ec2bf0de598baf3c56133657972b0d16 (patch)
tree8b85c585a1ff4868b78a892d7e6a2b2b6006002e /app-text/c2ps/c2ps-4.0.ebuild
parentUse virtual/perl-Sys-Syslog in DEPEND. Bug #211631, by Jakub Moc. Old ebuild ... (diff)
downloadhistorical-22b3a058ec2bf0de598baf3c56133657972b0d16.tar.gz
historical-22b3a058ec2bf0de598baf3c56133657972b0d16.tar.bz2
historical-22b3a058ec2bf0de598baf3c56133657972b0d16.zip
* COPYING removed from dodoc. * Fix hardcoded CC. * Honour FHS by installing the man page to /usr/share/man instead of /usr/man. * Honour Gentoo CFLAGS. * Use emake in src_install. thanks to Tiago Cunha (AMD64/SPARC AT) <me@tiagocunha.org> in bug 215008
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-text/c2ps/c2ps-4.0.ebuild')
-rw-r--r--app-text/c2ps/c2ps-4.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/app-text/c2ps/c2ps-4.0.ebuild b/app-text/c2ps/c2ps-4.0.ebuild
index 49675cb5f4d2..3ee7a49fac7b 100644
--- a/app-text/c2ps/c2ps-4.0.ebuild
+++ b/app-text/c2ps/c2ps-4.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/c2ps/c2ps-4.0.ebuild,v 1.14 2008/01/20 16:02:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/c2ps/c2ps-4.0.ebuild,v 1.15 2008/04/05 11:22:42 genstef Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Generates a beautified ps document from a source file (c/c++)"
HOMEPAGE="http://www.cs.technion.ac.il/users/c2ps"
@@ -12,11 +14,11 @@ KEYWORDS="amd64 ~mips ppc ~sparc x86"
IUSE=""
src_compile() {
- emake || die
+ emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}" || die
}
src_install() {
- dodir /usr/bin /usr/man/man1
- make PREFIX="${D}"/usr install || die
- dodoc COPYING README
+ dodir /usr/bin /usr/share/man/man1
+ emake MAN="${D}"/usr/share/man/man1 PREFIX="${D}"/usr install || die
+ dodoc README
}