summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-20 10:57:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-20 10:57:15 +0000
commitc30fa9a396d54fbc55c5a14689ba6a9777680f89 (patch)
tree24af9fc511f562f2bc77c5c1688d8cf9ed074a48 /app-shells
parentFix for security bug #112968 (diff)
downloadhistorical-c30fa9a396d54fbc55c5a14689ba6a9777680f89.tar.gz
historical-c30fa9a396d54fbc55c5a14689ba6a9777680f89.tar.bz2
historical-c30fa9a396d54fbc55c5a14689ba6a9777680f89.zip
use bash code to auto-export vars
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sandboxshell/Manifest8
-rw-r--r--app-shells/sandboxshell/files/sandboxshell.conf7
2 files changed, 7 insertions, 8 deletions
diff --git a/app-shells/sandboxshell/Manifest b/app-shells/sandboxshell/Manifest
index 669f0712d45f..362607b8cacc 100644
--- a/app-shells/sandboxshell/Manifest
+++ b/app-shells/sandboxshell/Manifest
@@ -5,13 +5,13 @@ MD5 1d5718b8f683595a25fe3a28a285e380 ChangeLog 1116
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-sandboxshell-0.2 0
MD5 9a9a13478f46e54048795ba214e5e84d files/sandboxshell 1355
MD5 89728cab133398dad145e13d92fff6b2 files/sandboxshell.1 3117
-MD5 d43b043244f1b814b3f4d7e5ed9cf064 files/sandboxshell.conf 1908
+MD5 c295e6e7bd0933033a63791ef54e0370 files/sandboxshell.conf 1715
MD5 1fb0cef8c20e31d8fee121ebb2205588 metadata.xml 221
MD5 dd79ec5b34a47984cfb0f918ad2d9b35 sandboxshell-0.2.ebuild 663
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDgCwegIKl8Uu19MoRAvBRAJoDPZC87P1VUSzrIIbZom4u3lsn8wCfUoAg
-3FPyrvvmlDQYdlG9DSSoYw4=
-=oNEj
+iD8DBQFDgFbsgIKl8Uu19MoRAkzeAJ98Gl7Jg94J/4mlcieI90McaYL+wwCeJZ8K
+oiVsfERmmBYJ3itA9ZfFjH0=
+=tHgc
-----END PGP SIGNATURE-----
diff --git a/app-shells/sandboxshell/files/sandboxshell.conf b/app-shells/sandboxshell/files/sandboxshell.conf
index e824bb985956..75df274ca688 100644
--- a/app-shells/sandboxshell/files/sandboxshell.conf
+++ b/app-shells/sandboxshell/files/sandboxshell.conf
@@ -1,7 +1,7 @@
#!/bin/bash
# Written by vapier@gentoo.org
# public-domain code ... z0r ...
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.5 2005/11/20 07:54:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/files/sandboxshell.conf,v 1.6 2005/11/20 10:57:15 vapier Exp $
trap ":" INT QUIT TSTP
@@ -31,10 +31,9 @@ if [[ ${PWD:0:${#sbs_pdir}} == "${sbs_pdir}" ]] ; then
read env
sbs_PREPWD=${PWD}
if [[ ${env} == "y" ]] ; then
- # First try to source variables and export them ...
- eval $(sed -e '/^[[:alnum:]_-]*=/s:^:export :' -e '/^[[:alnum:]_-]* ()/Q' "${sbs_tmpenvfile}") 2>/dev/null
- # Then grab everything (including functions)
+ set -a
source "${sbs_tmpenvfile}" 2> /dev/null
+ set +a
export SANDBOX_WRITE=${SANDBOX_WRITE}:${sbs_pdir}${sbs_bdir}:${sbs_pdir}/homedir
fi
PWD=${sbs_PREPWD}