summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-04-06 15:21:19 +0000
committerMamoru Komachi <usata@gentoo.org>2005-04-06 15:21:19 +0000
commit10a04b90a5b91f3d2c955d95bcd8ecde4ea20f06 (patch)
tree3384ff3ba0f4c4e78edcf9082fb1ca6f137f6aa8 /app-shells
parentversion bump (diff)
downloadhistorical-10a04b90a5b91f3d2c955d95bcd8ecde4ea20f06.tar.gz
historical-10a04b90a5b91f3d2c955d95bcd8ecde4ea20f06.tar.bz2
historical-10a04b90a5b91f3d2c955d95bcd8ecde4ea20f06.zip
Version bumped.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/ChangeLog7
-rw-r--r--app-shells/zsh/Manifest4
-rw-r--r--app-shells/zsh/files/digest-zsh-4.2.53
-rw-r--r--app-shells/zsh/zsh-4.2.5.ebuild153
4 files changed, 165 insertions, 2 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 40b3e8570a70..1270b12c0d4e 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.80 2005/04/06 04:41:42 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.81 2005/04/06 15:21:19 usata Exp $
+
+*zsh-4.2.5 (06 Apr 2005)
+
+ 06 Apr 2005; Mamoru KOMACHI <usata@gentoo.org> +zsh-4.2.5.ebuild:
+ Version bumped.
06 Apr 2005; Mamoru KOMACHI <usata@gentoo.org> -files/_portage-20040204,
-files/_portage-20040730, -zsh-4.2.0-r1.ebuild, -zsh-4.2.1-r1.ebuild:
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
index 68d5d78487a5..e0e801a3b6a9 100644
--- a/app-shells/zsh/Manifest
+++ b/app-shells/zsh/Manifest
@@ -1,8 +1,10 @@
+MD5 dda0351160d816bed6735d4591e01a87 zsh-4.2.5.ebuild 4315
MD5 26886d0a410d5883eced6bda50cf2f1c zsh-4.2.3.ebuild 4196
-MD5 d526b8d17d1cc0f748c93afb977fcf16 ChangeLog 13234
+MD5 c14957a6fcb8b4e329899f8b61870802 ChangeLog 13347
MD5 28ed8ea6cdccb353e2e8ad783eb51f5b metadata.xml 506
MD5 94f8381cc21da147fc0975a5d208f637 zsh-4.2.4.ebuild 4307
MD5 28ae3771eb1a6ebb64171197c8d390e7 zsh-4.0.9-r4.ebuild 2893
+MD5 1710d7b038f0aac2aca3520bb546659c files/digest-zsh-4.2.5 199
MD5 e6a9690e5c9b23757e887e14da621c9c files/zsh-4.2.1-gentoo.diff 735
MD5 64023b41a9987655e0e014d32562cfad files/zprofile 404
MD5 de0db046f0f40cb1cc3cd3f6e6b2645a files/zshenv 318
diff --git a/app-shells/zsh/files/digest-zsh-4.2.5 b/app-shells/zsh/files/digest-zsh-4.2.5
new file mode 100644
index 000000000000..7b0af656621e
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.2.5
@@ -0,0 +1,3 @@
+MD5 e2060f743dcdf3b383e80e862a6548fe zsh-4.2.5.tar.bz2 2074535
+MD5 8172d69a12886c85b0a4b579a695dffe zsh-4.2.4-euc-0.3.patch.gz 2942
+MD5 6dc896b52a3bc20a514148d621e13282 zsh-4.2.5-doc.tar.bz2 1768286
diff --git a/app-shells/zsh/zsh-4.2.5.ebuild b/app-shells/zsh/zsh-4.2.5.ebuild
new file mode 100644
index 000000000000..d6deab7b8e13
--- /dev/null
+++ b/app-shells/zsh/zsh-4.2.5.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.2.5.ebuild,v 1.1 2005/04/06 15:21:19 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
+ linguas_ja? ( http://www.ono.org/software/dist/${PN}-4.2.4-euc-0.3.patch.gz )
+ doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="maildir ncurses static doc pcre cap"
+
+RDEPEND="pcre? ( >=dev-libs/libpcre-3.9 )
+ cap? ( sys-libs/libcap )
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="sys-apps/groff
+ >=sys-apps/sed-4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use doc && unpack ${P}-doc.tar.bz2
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-4.2.1-gentoo.diff
+ epatch ${FILESDIR}/${PN}-init.d-gentoo.diff
+ use linguas_ja && epatch ${DISTDIR}/${PN}-4.2.4-euc-0.3.patch.gz
+ cd ${S}/Doc
+ ln -sf . man1
+ # fix zshall problem with soelim
+ soelim zshall.1 > zshall.1.soelim
+ mv zshall.1.soelim zshall.1
+}
+
+src_compile() {
+ local myconf
+
+ use static && myconf="${myconf} --disable-dynamic" \
+ && LDFLAGS="${LDFLAGS} -static"
+
+ if use ppc-macos; then
+ LDFLAGS="${LDFLAGS} -Wl,-x"
+ myconf="${myconf} --enable-libs=-liconv"
+ fi
+
+ econf \
+ --bindir=/bin \
+ --libdir=/usr/lib \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/zsh/zprofile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
+ --enable-site-fndir=/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --enable-ldflags="${LDFLAGS}" \
+ --with-tcsetpgrp \
+ $(use_with ncurses curses-terminfo) \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable cap) \
+ ${myconf} || die "configure failed"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ sed -i -e "s/link=no/link=static/g" \
+ -e "s/load=no/load=yes/g" \
+ config.modules || die
+ else
+ # avoid linking to libs in /usr/lib, see Bug #27064
+ sed -i -e "/LIBS/s%-lpcre%/usr/lib/libpcre.a%" \
+ Makefile || die
+ fi
+
+ # emake still b0rks
+ emake -j1 || die "make failed"
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ make check || die "make check failed"
+}
+
+src_install() {
+ einstall \
+ bindir=${D}/bin \
+ libdir=${D}/usr/lib \
+ fndir=${D}/usr/share/zsh/${PV%_*}/functions \
+ sitefndir=${D}/usr/share/zsh/site-functions \
+ install.bin install.man install.modules \
+ install.info install.fns || die "make install failed"
+
+ insinto /etc/zsh
+ doins ${FILESDIR}/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+ doins ${FILESDIR}/prompt_gentoo_setup || die
+
+ # install miscellaneous scripts; bug #54520
+ sed -i -e "s:/usr/local:/usr:g" {Util,Misc}/* || "sed failed"
+ insinto /usr/share/zsh/${PV%_*}/Util
+ doins Util/* || die "doins Util scripts failed"
+ insinto /usr/share/zsh/${PV%_*}/Misc
+ doins Misc/* || die "doins Misc scripts failed"
+
+ dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
+
+ if use doc ; then
+ dohtml Doc/*
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh{.dvi,_us.ps,_a4.ps}
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+}
+
+pkg_preinst() {
+ # Our zprofile file does the job of the old zshenv file
+ # Move the old version into a zprofile script so the normal
+ # etc-update process will handle any changes.
+ if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
+ mv /etc/zsh/zshenv /etc/zsh/zprofile
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to enable Portage completions and Gentoo prompt,"
+ einfo "emerge app-shells/zsh-completion and add"
+ einfo " autoload -U compinit promptinit"
+ einfo " compinit"
+ einfo " promptinit; prompt gentoo"
+ einfo "to your ~/.zshrc"
+ einfo
+ einfo "Also, if you want to enable cache for the completions, add"
+ einfo " zstyle ':completion::complete:*' use-cache 1"
+ einfo "to your ~/.zshrc"
+ einfo
+ # see Bug 26776
+ ewarn
+ ewarn "If you are upgrading from zsh-4.0.x you may need to"
+ ewarn "remove all your old ~/.zcompdump files in order to use"
+ ewarn "completion. For more info see zcompsys manpage."
+ ewarn
+}