summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-07 20:09:48 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-07 20:09:48 +0000
commit1046124f171fa086920d7cd134e7c73e4d9075c7 (patch)
treef55665329a720680570a20c53792a23cab55df10 /app-shells
parentadd inherit eutils (diff)
downloadhistorical-1046124f171fa086920d7cd134e7c73e4d9075c7.tar.gz
historical-1046124f171fa086920d7cd134e7c73e4d9075c7.tar.bz2
historical-1046124f171fa086920d7cd134e7c73e4d9075c7.zip
add inherit eutils
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/zsh-4.0.9-r2.ebuild25
-rw-r--r--app-shells/zsh/zsh-4.0.9-r3.ebuild28
-rw-r--r--app-shells/zsh/zsh-4.1.1-r4.ebuild25
3 files changed, 39 insertions, 39 deletions
diff --git a/app-shells/zsh/zsh-4.0.9-r2.ebuild b/app-shells/zsh/zsh-4.0.9-r2.ebuild
index 5e04bd82c78e..5a4108797586 100644
--- a/app-shells/zsh/zsh-4.0.9-r2.ebuild
+++ b/app-shells/zsh/zsh-4.0.9-r2.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.9-r2.ebuild,v 1.2 2004/01/22 12:42:09 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.9-r2.ebuild,v 1.3 2004/04/07 20:06:56 vapier Exp $
-IUSE="maildir ncurses static doc cjk"
+inherit flag-o-matic eutils
DESCRIPTION="UNIX Shell similar to the Korn shell"
HOMEPAGE="http://www.zsh.org/"
-
SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )
cjk? ( http://www.ono.org/software/dist/${P}-euc-0.2.patch.gz )"
-SLOT="0"
LICENSE="ZSH"
+SLOT="0"
KEYWORDS="x86 alpha ~ppc ~sparc"
+IUSE="maildir ncurses static doc cjk"
-DEPEND="virtual/glibc
- sys-apps/groff
- ${RDEPEND}"
RDEPEND="ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="${RDEPEND}
+ virtual/glibc
+ sys-apps/groff"
src_unpack() {
unpack ${A}
@@ -37,8 +37,9 @@ src_compile() {
use ncurses && myconf="--with-curses-terminfo"
use maildir && myconf="${myconf} --enable-maildir-support"
- use static && myconf="${myconf} --disable-dynamic" \
- && LDFLAGS="${LDFLAGS} -static"
+ use static \
+ && myconf="${myconf} --disable-dynamic" \
+ && append-ldflags -static
econf \
--bindir=/bin \
@@ -77,7 +78,7 @@ src_install() {
dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
- if [ "`use doc`" ] ; then
+ if use doc ; then
dohtml Doc/*
insinto /usr/share/doc/${PF}
doins Doc/zsh{.dvi,_us.ps,_a4.ps}
@@ -91,7 +92,7 @@ pkg_preinst() {
# Our zprofile file does the job of the old zshenv file
# Move the old version into a zprofile script so the normal
# etc-update process will handle any changes.
- if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
- mv /etc/zsh/zshenv /etc/zsh/zprofile
+ if [ -f ${ROOT}/etc/zsh/zshenv -a ! -f ${ROOT}/etc/zsh/zprofile ]; then
+ mv ${ROOT}/etc/zsh/zshenv ${ROOT}/etc/zsh/zprofile
fi
}
diff --git a/app-shells/zsh/zsh-4.0.9-r3.ebuild b/app-shells/zsh/zsh-4.0.9-r3.ebuild
index 77072ede5e74..adb267295a85 100644
--- a/app-shells/zsh/zsh-4.0.9-r3.ebuild
+++ b/app-shells/zsh/zsh-4.0.9-r3.ebuild
@@ -1,26 +1,25 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.9-r3.ebuild,v 1.2 2004/03/03 18:41:45 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.9-r3.ebuild,v 1.3 2004/04/07 20:08:32 vapier Exp $
-IUSE="maildir ncurses static doc cjk"
+inherit flag-o-matic eutils
+MYDATE="20040204"
DESCRIPTION="UNIX Shell similar to the Korn shell"
HOMEPAGE="http://www.zsh.org/"
-
-MYDATE="20040204"
-
SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )
cjk? ( http://www.ono.org/software/dist/${P}-euc-0.2.patch.gz )"
-SLOT="0"
LICENSE="ZSH"
+SLOT="0"
KEYWORDS="x86 alpha ~ppc ~sparc"
+IUSE="maildir ncurses static doc cjk"
-DEPEND="virtual/glibc
- sys-apps/groff
- ${RDEPEND}"
RDEPEND="ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="${RDEPEND}
+ virtual/glibc
+ sys-apps/groff"
src_unpack() {
unpack ${A}
@@ -39,8 +38,9 @@ src_compile() {
use ncurses && myconf="--with-curses-terminfo"
use maildir && myconf="${myconf} --enable-maildir-support"
- use static && myconf="${myconf} --disable-dynamic" \
- && LDFLAGS="${LDFLAGS} -static"
+ use static \
+ && myconf="${myconf} --disable-dynamic" \
+ && append-ldflags -static
econf \
--bindir=/bin \
@@ -79,7 +79,7 @@ src_install() {
dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
- if [ "`use doc`" ] ; then
+ if use doc ; then
dohtml Doc/*
insinto /usr/share/doc/${PF}
doins Doc/zsh{.dvi,_us.ps,_a4.ps}
@@ -93,7 +93,7 @@ pkg_preinst() {
# Our zprofile file does the job of the old zshenv file
# Move the old version into a zprofile script so the normal
# etc-update process will handle any changes.
- if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
- mv /etc/zsh/zshenv /etc/zsh/zprofile
+ if [ -f ${ROOT}/etc/zsh/zshenv -a ! -f ${ROOT}/etc/zsh/zprofile ]; then
+ mv ${ROOT}/etc/zsh/zshenv ${ROOT}/etc/zsh/zprofile
fi
}
diff --git a/app-shells/zsh/zsh-4.1.1-r4.ebuild b/app-shells/zsh/zsh-4.1.1-r4.ebuild
index c781988b9bc7..2be9737bc812 100644
--- a/app-shells/zsh/zsh-4.1.1-r4.ebuild
+++ b/app-shells/zsh/zsh-4.1.1-r4.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.1.1-r4.ebuild,v 1.3 2004/02/04 15:32:45 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.1.1-r4.ebuild,v 1.4 2004/04/07 20:09:48 vapier Exp $
-IUSE="cjk maildir ncurses static doc"
+inherit flag-o-matic eutils
DESCRIPTION="UNIX Shell similar to the Korn shell"
HOMEPAGE="http://www.zsh.org/"
-
SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
cjk? ( http://www.ono.org/software/dist/${P}-euc-0.2.patch.gz )
doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
-SLOT="0"
LICENSE="ZSH"
+SLOT="0"
KEYWORDS="x86 alpha ppc sparc amd64 hppa"
+IUSE="cjk maildir ncurses static doc"
-DEPEND="sys-apps/groff
- >=sys-apps/sed-4
- ${RDEPEND}"
RDEPEND=">=dev-libs/libpcre-3.9
sys-libs/libcap
ncurses? ( >=sys-libs/ncurses-5.1 )"
+DEPEND="sys-apps/groff
+ >=sys-apps/sed-4
+ ${RDEPEND}"
src_unpack() {
unpack ${P}.tar.bz2
@@ -42,7 +42,7 @@ src_compile() {
use ncurses && myconf="--with-curses-terminfo"
use maildir && myconf="${myconf} --enable-maildir-support"
use static && myconf="${myconf} --disable-dynamic" \
- && LDFLAGS="${LDFLAGS} -static"
+ && append-ldflags -static
econf \
--bindir=/bin \
@@ -59,7 +59,7 @@ src_compile() {
--enable-ldflags="${LDFLAGS}" \
${myconf} || die "configure failed"
- if [ -n "`use static`" ] ; then
+ if use static ; then
# compile all modules statically, see Bug #27392
sed -i -e "s/link=no/link=static/g" \
-e "s/load=no/load=yes/g" \
@@ -93,7 +93,7 @@ src_install() {
dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
- if [ "`use doc`" ] ; then
+ if use doc ; then
dohtml Doc/*
insinto /usr/share/doc/${PF}
doins Doc/zsh{.dvi,_us.ps,_a4.ps}
@@ -107,13 +107,12 @@ pkg_preinst() {
# Our zprofile file does the job of the old zshenv file
# Move the old version into a zprofile script so the normal
# etc-update process will handle any changes.
- if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
- mv /etc/zsh/zshenv /etc/zsh/zprofile
+ if [ -f ${ROOT}/etc/zsh/zshenv -a ! -f ${ROOT}/etc/zsh/zprofile ]; then
+ mv ${ROOT}/etc/zsh/zshenv ${ROOT}/etc/zsh/zprofile
fi
}
pkg_postinst() {
-
# see Bug 26776
ewarn
ewarn "If you are upgrading from zsh-4.0.x you may need to"