summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-26 16:53:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-26 16:53:39 +0000
commit2adf884fc883d9f7fcccfaff9af4dcd4c7f3f9e7 (patch)
treee657154834c2b74fbd36c020696ae5d5419ef155 /app-shells/scsh/scsh-0.6.5.ebuild
parentUnmasking ut2004-demo-3120-r2. (diff)
downloadhistorical-2adf884fc883d9f7fcccfaff9af4dcd4c7f3f9e7.tar.gz
historical-2adf884fc883d9f7fcccfaff9af4dcd4c7f3f9e7.tar.bz2
historical-2adf884fc883d9f7fcccfaff9af4dcd4c7f3f9e7.zip
*** empty log message ***
Diffstat (limited to 'app-shells/scsh/scsh-0.6.5.ebuild')
-rw-r--r--app-shells/scsh/scsh-0.6.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/scsh/scsh-0.6.5.ebuild b/app-shells/scsh/scsh-0.6.5.ebuild
new file mode 100644
index 000000000000..6242a5bcadfd
--- /dev/null
+++ b/app-shells/scsh/scsh-0.6.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/scsh/scsh-0.6.5.ebuild,v 1.1 2004/02/26 16:53:38 mkennedy Exp $
+
+DESCRIPTION="Unix shell embedded in Scheme"
+SRC_URI="ftp://ftp.scsh.net/pub/scsh/0.6/${P}.tar.gz"
+HOMEPAGE="http://www.scsh.net/"
+
+SLOT="0"
+LICENSE="as-is | BSD | GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND=""
+
+src_compile() {
+ econf --prefix=/usr --libdir=/usr/lib --includedir=/usr/include || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc RELEASE COPYING
+ # Let Scsh install the documentation and then clean up afterwards
+ dosed "s:${D}::" /usr/share/man/man1/scsh.1
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/lib/scsh/doc/* ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/lib/scsh/doc
+}