summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-02 12:41:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-02 12:41:59 +0000
commit91dc37232e06571c15e2e330c04035a6d15cf9c7 (patch)
tree87ba301188c4709a7c9e808eb292c68e9c22a0a7 /app-shells/rc
parentVersion bump with minor bugfixes. Also adds passive BGP support. (diff)
downloadhistorical-91dc37232e06571c15e2e330c04035a6d15cf9c7.tar.gz
historical-91dc37232e06571c15e2e330c04035a6d15cf9c7.tar.bz2
historical-91dc37232e06571c15e2e330c04035a6d15cf9c7.zip
Initial commit wrt #45183, thanks to Ken Pizzini, Adrian Frühwirth and Arseny Solokha.
Package-Manager: portage-2.2_rc42/cvs/Linux x86_64
Diffstat (limited to 'app-shells/rc')
-rw-r--r--app-shells/rc/ChangeLog10
-rw-r--r--app-shells/rc/Manifest4
-rw-r--r--app-shells/rc/metadata.xml9
-rw-r--r--app-shells/rc/rc-1.7.1.ebuild42
4 files changed, 65 insertions, 0 deletions
diff --git a/app-shells/rc/ChangeLog b/app-shells/rc/ChangeLog
new file mode 100644
index 000000000000..0ab3ec8c8ee1
--- /dev/null
+++ b/app-shells/rc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-shells/rc
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rc/ChangeLog,v 1.1 2009/10/02 12:41:59 ssuominen Exp $
+
+*rc-1.7.1 (02 Oct 2009)
+
+ 02 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> +rc-1.7.1.ebuild:
+ Initial commit wrt #45183, thanks to Ken Pizzini, Adrian Frühwirth and
+ Arseny Solokha.
+
diff --git a/app-shells/rc/Manifest b/app-shells/rc/Manifest
new file mode 100644
index 000000000000..e5d46b4a9ed1
--- /dev/null
+++ b/app-shells/rc/Manifest
@@ -0,0 +1,4 @@
+DIST rc-1.7.1.tar.gz 177302 RMD160 b01d142fe9f99fc291c019a5425884a7b2bb7bbc SHA1 e282fde927c91b7f580426bcdfc62f780c6645c5 SHA256 1cff23e897a038422458ba01567a5a2650935205862c3bbf73e773807c248240
+EBUILD rc-1.7.1.ebuild 1024 RMD160 02be5df718178065a57de6d356f27309c9782dd6 SHA1 ab1e4e2b75927517ac2778185d9b1b3b284849dd SHA256 67c32c89d29c5f8041c685037ac07ad874a57d108e2cd8687e9e33fd5cdce7d1
+MISC ChangeLog 392 RMD160 1b9c2893dba27a08540bcded944ba99f16757c0f SHA1 db8957f3170f3167ec489c731cc0576ac2b04140 SHA256 5816679ca3c95db267ea47717ba38cd92a8ab89c2cb1b3259d33aac4323cef4a
+MISC metadata.xml 270 RMD160 da01208028bb208a2a3bda11d65e0c0ea7bad6cf SHA1 8db0be7c11944f76c82d875901c478c6b7746284 SHA256 ef58b1c4316d37bc29175e278d9664a16eb45869f908eb692acbd6e6f97e7da2
diff --git a/app-shells/rc/metadata.xml b/app-shells/rc/metadata.xml
new file mode 100644
index 000000000000..eb72a8082544
--- /dev/null
+++ b/app-shells/rc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/rc/rc-1.7.1.ebuild b/app-shells/rc/rc-1.7.1.ebuild
new file mode 100644
index 000000000000..fcf0ec2e6f9c
--- /dev/null
+++ b/app-shells/rc/rc-1.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rc/rc-1.7.1.ebuild,v 1.1 2009/10/02 12:41:59 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="A reimplementation of the Plan 9 shell"
+HOMEPAGE="http://rc-shell.slackmatic.org/"
+SRC_URI="http://rc-shell.slackmatic.org/release/${P}.tar.gz"
+
+LICENSE="rc"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libedit readline"
+
+RDEPEND="readline? ( sys-libs/readline )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf="--with-history"
+ use readline && myconf="--with-readline"
+ use libedit && myconf="--with-editline"
+
+ econf \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_install() {
+ into /
+ newbin rc rcsh || die
+ newman rc.1 rcsh.1
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/rcsh$" "${ROOT}"etc/shells; echo "/bin/rcsh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}