summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-13 12:10:49 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-13 12:10:49 +0000
commit5107d3cbff6bc9dd1c94287666b1d199b280c0fa (patch)
tree7376f68792343a7a73db9dbd504b7db1fe5bc1c9 /app-shells/esh
parent*** empty log message *** (diff)
downloadhistorical-5107d3cbff6bc9dd1c94287666b1d199b280c0fa.tar.gz
historical-5107d3cbff6bc9dd1c94287666b1d199b280c0fa.tar.bz2
historical-5107d3cbff6bc9dd1c94287666b1d199b280c0fa.zip
*** empty log message ***
Diffstat (limited to 'app-shells/esh')
-rw-r--r--app-shells/esh/esh-0.8-r1.ebuild40
-rw-r--r--app-shells/esh/files/digest1
2 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/esh/esh-0.8-r1.ebuild b/app-shells/esh/esh-0.8-r1.ebuild
new file mode 100644
index 000000000000..fc751fcdf00e
--- /dev/null
+++ b/app-shells/esh/esh-0.8-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=esh-0.8
+A=${P}.tar.gz
+S=${WORKDIR}/esh
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+SRC_URI="http://esh.netpedia.net/"${A}
+HOMEPAGE="http://esh.netpedia.net/"
+CATEGORY="app-shells"
+
+src_compile() {
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS} :" \
+ -e "s:^LIB=:LIB=-lncurses :" Makefile.orig > Makefile
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin esh
+ into /usr
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ docinto html
+ dodoc doc/*.html
+ docinto examples
+ dodoc examples/*
+ insinto /usr/share/emacs/site-lisp/
+ doins emacs/esh-mode.el
+}
+
+
+
+
+
diff --git a/app-shells/esh/files/digest b/app-shells/esh/files/digest
new file mode 100644
index 000000000000..4ea7be5f1d42
--- /dev/null
+++ b/app-shells/esh/files/digest
@@ -0,0 +1 @@
+MD5 b59022b88bae24420156d25869b8be54 esh-0.8.tar.gz