summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-08 14:54:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-08 14:54:50 +0000
commit2dd27bab45570577495f932c666db0b73c96bc63 (patch)
tree73d6503f93357737eb7d1c9b0d9ab1cad61aa24d /app-shells/bash/bash-2.05b-r10.ebuild
parentFix klibc version in the ebuild. Closes bug #63170. (diff)
downloadhistorical-2dd27bab45570577495f932c666db0b73c96bc63.tar.gz
historical-2dd27bab45570577495f932c666db0b73c96bc63.tar.bz2
historical-2dd27bab45570577495f932c666db0b73c96bc63.zip
Make sure we statically link with ncurses #51901 and turn on emake since it seems to work fine for me.
Diffstat (limited to 'app-shells/bash/bash-2.05b-r10.ebuild')
-rw-r--r--app-shells/bash/bash-2.05b-r10.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-shells/bash/bash-2.05b-r10.ebuild b/app-shells/bash/bash-2.05b-r10.ebuild
index c0617e08a9dc..f12744f53707 100644
--- a/app-shells/bash/bash-2.05b-r10.ebuild
+++ b/app-shells/bash/bash-2.05b-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r10.ebuild,v 1.3 2004/08/19 22:08:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r10.ebuild,v 1.4 2004/09/08 14:54:50 vapier Exp $
inherit eutils flag-o-matic gnuconfig
@@ -87,8 +87,9 @@ src_compile() {
--with-curses \
--without-gnu-malloc \
${myconf} || die
-
- make || die
+ # Make sure we always link statically with ncurses
+ sed -i "/^TERMCAP_LIB/s:-lcurses:${ROOT}/usr/lib/libcurses.a:" Makefile || die "sed failed"
+ emake || die "make failed"
}
src_install() {