summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerris McCormick <fmccor@gentoo.org>2004-07-03 16:51:56 +0000
committerFerris McCormick <fmccor@gentoo.org>2004-07-03 16:51:56 +0000
commit68d70e353a6e884793f5eda2e409864337352021 (patch)
tree28136065dc7d0608369f48c80642360fb553affe /app-sci
parentAdded patch to produce shared objects as well, necessary for multisync on amd64. (diff)
downloadhistorical-68d70e353a6e884793f5eda2e409864337352021.tar.gz
historical-68d70e353a6e884793f5eda2e409864337352021.tar.bz2
historical-68d70e353a6e884793f5eda2e409864337352021.zip
Modify ebuild for correct sparc CFLAGS (kugelfang@gentoo.org) & add ~sparc keyword
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/blas-atlas/ChangeLog6
-rw-r--r--app-sci/blas-atlas/Manifest10
-rw-r--r--app-sci/blas-atlas/blas-atlas-3.6.0.ebuild34
3 files changed, 42 insertions, 8 deletions
diff --git a/app-sci/blas-atlas/ChangeLog b/app-sci/blas-atlas/ChangeLog
index f7a02487fbc3..752042c4d0a0 100644
--- a/app-sci/blas-atlas/ChangeLog
+++ b/app-sci/blas-atlas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/blas-atlas
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/ChangeLog,v 1.9 2004/06/25 01:32:07 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/ChangeLog,v 1.10 2004/07/03 16:51:56 fmccor Exp $
+
+ 03 Jul 2004; Ferris McCormick <fmccor@gentoo.org> blas-atlas-3.6.0.ebuild:
+ 1. Restructure .ebuild for correct sparc CFLAGS (kugelfang@gentoo.org)
+ 2. Add ~sparc keyword to restructured build.
24 Jun 2004; George Shapovalov <george@gentoo.org> blas-atlas-3.6.0.ebuild :
ifc useflag got retained even though this ebuild does not support ifc (yet), cleaned up
diff --git a/app-sci/blas-atlas/Manifest b/app-sci/blas-atlas/Manifest
index 872c245c9933..f76a916b6776 100644
--- a/app-sci/blas-atlas/Manifest
+++ b/app-sci/blas-atlas/Manifest
@@ -1,9 +1,9 @@
-MD5 c3b6eb1b4bc193461a9368023524327d blas-atlas-3.6.0.ebuild 3069
-MD5 21f46d1325b53a60881969403d1b393f ChangeLog 1661
+MD5 5c28e229ea57907ea67e2e53e3f20496 ChangeLog 1860
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 13d26350d75e6993f1b3ec48ca97f14e files/war 545
-MD5 d2c0eb312a847254d9ae8258445dfd86 files/c-ATLAS 409
+MD5 838f96fe70ed3f427bf9a69df72c5ad0 blas-atlas-3.6.0.ebuild 3725
MD5 a34d592240cf84fa29a3d4fd2ed9be32 files/f77-ATLAS 368
+MD5 d2c0eb312a847254d9ae8258445dfd86 files/c-ATLAS 409
MD5 27554885aa990f902f9d44ceb549e24d files/c-threaded-ATLAS 475
-MD5 e144969a0b4220a8e1de72d0bc8fbeeb files/f77-threaded-ATLAS 431
MD5 c1c57e922c1763ddde357504442e94c4 files/digest-blas-atlas-3.6.0 139
+MD5 e144969a0b4220a8e1de72d0bc8fbeeb files/f77-threaded-ATLAS 431
+MD5 13d26350d75e6993f1b3ec48ca97f14e files/war 545
diff --git a/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild b/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
index dbca4ba0039f..9cbeea50486c 100644
--- a/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
+++ b/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.8 2004/06/25 01:32:07 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.9 2004/07/03 16:51:56 fmccor Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86 amd64 ~ppc"
+KEYWORDS="~x86 amd64 ~ppc ~sparc"
IUSE="doc"
DEPEND="app-sci/blas-config
@@ -49,6 +49,32 @@ atlas_fail() {
die "ATLAS auto-config failed."
}
+# Added to allow compilation on sparc architecture. The default CCFLAG0
+# and MMFLAGS are *bad*.
+# Danny van Dyk <kugelfang@gentoo.org> 2004/07/02
+#
+reconfigure() {
+ case "`uname -p`" in
+ "sun4m")
+ MY_CCFLAG0="-O3 -mcpu=v8"
+ MY_MMFLAGS="-O -mcpu=v8"
+ ;;
+ "sun4u")
+ MY_CCFLAG0="-O3 -mcpu=ultrasparc"
+ MY_MMFLAGS="-O -mcpu=ultrasparc"
+ ;;
+ *)
+ MY_CCFLAG0="${CFLAGS}"
+ MY_MMFLAGS="${CFLAGS}"
+ ;;
+ esac
+
+ MY_FILE="`find -name Make.Linux*`"
+
+ sed -i -e "s/CCFLAG0 =/CCFLAG0 = ${MY_CCFLAG0}\n#&/1" ${MY_FILE}
+ sed -i -e "s/MMFLAGS =/MMFLAGS = ${MY_MMFLAGS}\n#&/" ${MY_FILE}
+}
+
src_compile() {
# Libraries will be installed in ${RPATH}/atlas and ${RPATH}/threaded-atlas:
RPATH="${DESTTREE}/lib/blas"
@@ -64,6 +90,10 @@ src_compile() {
(echo | make config CC="${GCC} -DUSE_LIBTOOL") || atlas_fail
fi
+ if [ "${ARCH}" == "sparc" ]; then
+ reconfigure
+ fi
+
TMPSTR=$(ls Make.Linux*)
ATLAS_ARCH=${TMPSTR#'Make.'}