summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-05-07 01:57:35 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-05-07 01:57:35 +0000
commit62efbcad70dc6a6119eb5756e764e40f468bf772 (patch)
tree9d9fa77bc520106db061150fd8bc76c8153eb3b1 /app-sci/units
parentmoved gperiodic from app-misc to app-sci (diff)
downloadhistorical-62efbcad70dc6a6119eb5756e764e40f468bf772.tar.gz
historical-62efbcad70dc6a6119eb5756e764e40f468bf772.tar.bz2
historical-62efbcad70dc6a6119eb5756e764e40f468bf772.zip
moved kstars, moldy, scigraphica, units and xcirquit from app-misc to app-sci
Diffstat (limited to 'app-sci/units')
-rw-r--r--app-sci/units/ChangeLog17
-rw-r--r--app-sci/units/files/digest-units-1.741
-rw-r--r--app-sci/units/units-1.74.ebuild44
3 files changed, 62 insertions, 0 deletions
diff --git a/app-sci/units/ChangeLog b/app-sci/units/ChangeLog
new file mode 100644
index 000000000000..56c73b13a40e
--- /dev/null
+++ b/app-sci/units/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for app-misc/units
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/units/ChangeLog,v 1.1 2002/05/07 01:57:35 george Exp $
+
+*units-1.74 (1 Feb 2002)
+
+ 06 May 2002; G. Shapovalov <george@gentoo.org> Changelog:
+
+ Moved from app-misc to app-sci
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-sci/units/files/digest-units-1.74 b/app-sci/units/files/digest-units-1.74
new file mode 100644
index 000000000000..066a3128baa5
--- /dev/null
+++ b/app-sci/units/files/digest-units-1.74
@@ -0,0 +1 @@
+MD5 230d1cb0367f9f4ac345beda371bbb53 units-1.74.tar.gz 178224
diff --git a/app-sci/units/units-1.74.ebuild b/app-sci/units/units-1.74.ebuild
new file mode 100644
index 000000000000..a4679b5bdcb3
--- /dev/null
+++ b/app-sci/units/units-1.74.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $ Header: $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Units is a program for units conversion and units calculation."
+
+SRC_URI="ftp://ftp.gnu.org/gnu/units/${P}.tar.gz"
+
+HOMEPAGE="http://www.gnu.org/software/units/units.html"
+
+DEPEND=">=sys-libs/readline-4.1-r2
+ >=sys-libs/ncurses-5.2-r3"
+
+
+src_compile() {
+
+#Note: the trailing / is required in the datadir path.
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/${PN}/ \
+ --prefix=/usr \
+ --host=${CHOST} || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+#Note: the trailing / is required in the datadir path.
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share/${PN}/ \
+ install || die
+
+dodoc COPYING ChangeLog INSTALL NEWS README
+
+}
+