summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-09-22 18:53:52 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-09-22 18:53:52 +0000
commitaded5deec538efb0f92df77fbc2c2289f6e636c2 (patch)
tree384d9733e15f3cbf19d4a49312375f02aa1c5e6d /app-sci/oregano
parentfix bug with non-local fetches where ECVS_SUBDIR has depth of two levels or m... (diff)
downloadhistorical-aded5deec538efb0f92df77fbc2c2289f6e636c2.tar.gz
historical-aded5deec538efb0f92df77fbc2c2289f6e636c2.tar.bz2
historical-aded5deec538efb0f92df77fbc2c2289f6e636c2.zip
oregano ebuild overhaul
Diffstat (limited to 'app-sci/oregano')
-rw-r--r--app-sci/oregano/ChangeLog6
-rw-r--r--app-sci/oregano/oregano-0.23.ebuild31
2 files changed, 22 insertions, 15 deletions
diff --git a/app-sci/oregano/ChangeLog b/app-sci/oregano/ChangeLog
index 31a998db5f96..370dbb94d4db 100644
--- a/app-sci/oregano/ChangeLog
+++ b/app-sci/oregano/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-sci/oregano
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/oregano/ChangeLog,v 1.1 2002/06/13 07:35:44 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/oregano/ChangeLog,v 1.2 2002/09/22 18:53:52 blocke Exp $
*oregano-0.23 (13 Jun 2002)
+ 22 Sep 2002; Bruce A. Locke <blocke@shivan.org> oregano-0.23.ebuild:
+
+ In place overhaul of existing ebuild, it was not working for many people.
+
13 Jun 2002; Brandon Low <lostlogic@gentoo.org> oregano-0.23.ebuild:
Initial ebuild, this seems like a very nice schematic editing program
diff --git a/app-sci/oregano/oregano-0.23.ebuild b/app-sci/oregano/oregano-0.23.ebuild
index cec1137ff3a4..d3baf1288857 100644
--- a/app-sci/oregano/oregano-0.23.ebuild
+++ b/app-sci/oregano/oregano-0.23.ebuild
@@ -1,29 +1,32 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/oregano/oregano-0.23.ebuild,v 1.2 2002/07/18 04:09:19 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/oregano/oregano-0.23.ebuild,v 1.3 2002/09/22 18:53:52 blocke Exp $
-DESCRIPTION="This is a sample skeleton ebuild file"
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.codefactory.se/pub/CodeFactory/software/oregano/${P}.tar.gz"
+DESCRIPTION="Oregano is an application for schematic capture and simulation of electrical circuits."
HOMEPAGE="http://oregano.codefactory.se/"
-LICENSE="GPL-2"
-DEPEND="x11-libs/gtk+
- gnome? gnome-base/gnome"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4
+ >=gnome-base/libglade-0.17 <gnome-base/libglade-2.0.0
+ >=gnome-base/gnome-print-0.30
+ >=dev-libs/libxml-1.8.17
+ >=app-sci/spice-3.5.5"
RDEPEND="${DEPEND}"
-SRC_URI="ftp://ftp.codefactory.se/pub/CodeFactory/software/oregano/${P}.tar.gz"
-S=${WORKDIR}/${P}
+
SLOT="0"
KEYWORDS="x86"
+LICENSE="GPL-2"
src_compile() {
local myconf
- [ `use nls` ] || myconf="${myconf} --disable-nls"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
emake || die
}
src_install () {
- make DESTDIR=${D} install || die
+ einstall || die
}